iOS WLAN trouble


Userlevel 2
Most of the time when I start the Sonos app on my iOS device, it says it can't find the Sonos system. When I deactivate and reactivate WLAN, it always works for a while, but already the next time I try, I may have to do thos cycle again. Happens on several iPads and iPhones. Everything is on latest version.

Network: a ZP100 connected to a switch, to which an Airport Time Capsule is connected. The switch is connected to my router. To extend the range, I have an Airport Extreme connected via inhouse Ethernet cabling to the same router via another switch. They both provide a WLAN with the same ID, as Apple suggests. Both Airports are in bridge mode. No other network problems except this one.

What might be the problem?

9 replies

cbrand,

First post! Welcome to the forums.

What do you mean when you "deactivate and reactivate WLAN"? Is this done on the iDevice or something that you do to one of the Airports?

Are you physically moving your iDevice from one location to another before these communication failure events?

What other devices are on your network? (computers, printers, thermostats, Sonos, etc.)
Userlevel 2
I recently had a similar issue using Ubiquiti Networks UniFi access points, a Connect and a Play:5. I had a UAP-LR and UAP wirelessly linked to the UAP-LR to extend my WiFi range.

My solution was to prevent my Connect from connecting to the UAP right next to it. I created a second SSID and hid it and setup my sonos to connect to it. It fixed all my issues.

For some reason, when my iPhone would roam to the UAP to the UAP-LR back to the UAP it couldn't find my sonos. Since I created the second SSID I haven't had any issues.
JFord,

Had you tried the UBIQUITI "Zero Handoff" feature?
Userlevel 2
JFord,

Had you tried the UBIQUITI "Zero Handoff" feature?


No. It isn't supported unless every access point is wired. Since I am using a wireless uplink I can't. I tried and when it wouldn't work I learned that tid bit. Nearly ran some cat5 when I ran my speaker wire for my rear speakers and outdoor speakers but didn't. Now I wish I had.
Userlevel 2
disable UPnP on router... Read it somewhere and it immediately fixed my issue...
Userlevel 2
Deactivate WLAN means: on my iphone or ipad, either switch off WLAN an on again or just enter airplane mode and switch it off again. The device reconnects to WLAN and it sees the Sonos system again.

There are lots of devices on the network, this problem wasn't there until a few weeks ago. No idea what caused it.

I was thinking that somehow it may be an issue with my two Airport access points, but they are both in bridge mode, have the same SSID and are connected to the same router.

I need UPnP active, I use it for my TV.
cbrand,

Which model router and switches are you using?

On a few of the older routers the UPnP setting seemed to behave backwards. In this case toggling the setting was helpful.
I need UPnP active, I use it for my TV.
Not in your router surely.

Router UPnP is for gateway control so, say, a peer-to-peer application could dynamically request that an external IP port be opened up and forwarded to the relevant device.

Your TV is presumably using UPnP AV as part of DLNA, which is quite different.
Userlevel 3
Badge +1

I was thinking that somehow it may be an issue with my two Airport access points, but they are both in bridge mode, have the same SSID and are connected to the same router.


Are you really sure of that? The behaviour could very well be explained by one router not being in the same subnet. Please check the IP address on your iOS device when Sonos works and when it doesn't. If they are not the same or not on the same subnet (only the last number of your IP address differs), you haven't setup one AP correctly.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings