Indexing 8,000 tracks -- pushing 4 hours now

  • 18 October 2018
  • 30 replies
  • 665 views

Badge
  • Trending Lyricist I
  • 18 replies
I am trying to reindex my iTunes library, which is housed on an external drive (iMac OS 10.11.6 wired to a Lacie drive). I have approximately 8,000 tracks. I've read other relevant threads and did as they suggested (reboot, clean up file types, etc). I called SONOS support but they said to keep waiting. (4 hour earlier wait, currently pushing 90 minutes after another reboot.) I've had the system a couple of years now and have never had to wait this long to index or reindex. What can/should I do?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Userlevel 7
Badge +21
Sonos systems sometimes die but your symptoms are not sounding like any of the common cases.

I'm loving my Raspberry Pi and the new version 3b+ is even better as a NAS than what I'm using. Just to tempt you and hide from the wife who is wanting assistance with a job I hate.

Pi 3b+ kit https://smile.amazon.com/CanaKit-Raspberry-Complete-Starter-Premium/dp/B07BLRSKBV?ref_=w_bl_hsx_s_pa_web_3020163011

USB - SATA https://smile.amazon.com/gp/product/B00HJZJI84/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

SSD 120 to 1 TBhttps://smile.amazon.com/SanDisk-120GB-Solid-State-SDSSDA-120G-G27/dp/B07621PNWC/ref=sr_1_13

How to SAMBA https://www.raspberrypi.org/magpi/samba-file-server

To enable Sonos access just add this to your /etc/smb.conf file, global section:

code:
# enable v1 authentication for Sonos access
ntlm auth=yes
Badge
I'm loving my Raspberry Pi and the new version 3b+ is even better as a NAS than what I'm using.

Thanks for this recommendation. I'll check it out.

Of course, if I can get my library to index. It ran all night and nothing. I sure wish I knew what changed from the last time I updated successfully. I'm going crazy without my music.
Badge
Amazing. It finally indexed! It was caught in a 6 hour loop. I created a second folder with only 8 albums in it to do a test share on a smaller set of files. That folder indexed in seconds. And, when the smaller shared showed up, the full share showed up as well! To further test, I added a single album to the original, full share and re-indexed. It updated in seconds again.

It is going to bother me not knowing what the problem was because.. how will I fix it next time? I also now have a folder structure requiring much more hands-on management. No more just ripping CDs or downloading music files to the iTunes default. But I should be paying more attention to file metadata anyway. And, I wish I could give the community a "this is what fixed it."

My only issue now is determining why the Sonos app on my iPhone, iPad, and Air are not finding the Sonos system. But at least I can do it streaming music.

Thanks again, all, for the help and advice.
Userlevel 7
Badge +21
Check that the apps devices are connecting to your 2.4 GHz WiFi.
Badge
Check that the apps devices are connecting to your 2.4 GHz WiFi.

this seemed to be the issue. but, they are connected now!