How to fix error? "The device where the music files are stored may not be powered on..."

  • 16 January 2017
  • 3 replies

Having trouble getting Sonos to index all of my music for the first time. Getting "//XXXXXXXXXXXXXX/folder/' is no longer available. The device where the music files are stored may not be powered on, or the path may have changed." This pops up after just a few minutes of attempting to index.

I am able to index the "Music/iTunes/iTunes Music" folder (where some of my music is), but I get the above message when I try to index at just one level up, at "Music/iTunes" (where all the playlists are). Very frustrating, since this is on a local computer and not on an external drive.

Most frustratingly, the bulk of my music is on the external drive. When I try to index that, it also kicks back the same error message.

Here's how my system is set up:

- Mac OSX 10.11.6
- iTunes on Mac's Local Drive (some of my music, about 200 files, is in the same folder as iTunes)
- most of the rest of my music (~27,000 audio files) is on an external hard drive, but some is organized in iTunes playlists (which I presume are on the local drive folder /Music/iTunes/)?)

Remedies I have tried:

- re-named computer to shorter name (to match Netbios) and restarted
- rebooted router
- tried indexing individual album/artist folders on the external drive - this worked, but I shouldn't have to do each one at a time, right?

I would like to index my iTunes playlists and the external drive files.

Any help would be appreciated!

Best answer by NoAssemblyReqd 19 January 2017, 17:07

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

UPDATE: I also tried consolidating and organizing my entire iTunes library into the "Music/iTunes/iTunes Music" folder. This went off without a hitch (i.e. all my playlists within iTunes seem to have been updated), but Sonos is still not able to index the folder.
Tried to index my (now consolidated and organized) iTunes music folder. Got the same error. Here's my diagnostic #: 7007917

(I am able to index individual artist folders. I added two artist folders -- ~2000 files successfully. Sonos only chokes when I try to index the entire "iTunes/iTunes Music/Music" folder or at any level upward to the "iTunes" folder, where the playlist data are stored.)
I've been working on this issue with Support privately, but for those interested, here is how I (mostly) solved the issue:

1. Shut down Mac computer, router and Sonos device

2. Turned on router, waited for connection

3. Turned on Sonos device, waited for connection

4. Turned on Mac

5. Started Sonos controller, added iTunes library.

With this action, most of my 21,000 file library finally appeared. However, I found that the library (especially playlists) is still somewhat stubborn to update, even with manual updating.

To remedy this, I am consolidating my playlist folders within iTunes so that they are no more than 2 or 3 levels deep, and this seems to be working so far.