Help! "There is no shared folder on the computer"



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

38 replies

Badge
Can we PLEASE get a response from a Sonos Rep so we know they are aware of this issue!??
The 2 responses from Jeff weren't satisfactory? He has already recommended that you call in to Sonos directly.
Badge
The 2 responses from Jeff weren't satisfactory? He has already recommended that you call in to Sonos directly.

I stated a few posts up that I (and I'm sure many others) do not have the time to spend a few hours on the phone trying to resolve this issue.

Others have also commented with the same problem and we have all agreed that it was more than likely something Microsoft did in one of their recent updates that's causing conflict.

It would be nice if we could get some more help in here to resolve this issue as it will probably be more common when everyone starts updating their PCs to the latest Windows update.
Userlevel 7
Badge +20
The 2 responses from Jeff weren't satisfactory? He has already recommended that you call in to Sonos directly.

I stated a few posts up that I (and I'm sure many others) do not have the time to spend a few hours on the phone trying to resolve this issue.

Others have also commented with the same problem and we have all agreed that it was more than likely something Microsoft did in one of their recent updates that's causing conflict.

It would be nice if we could get some more help in here to resolve this issue as it will probably be more common when everyone starts updating their PCs to the latest Windows update.


The phone team has more tools available, and by now you'd likely be up and running.

In your report I see that your computer does not have any shared folders set up. The error you've described should not show up during the process to add a music share as the Sonos app will create the share. Are you trying to connect to a network share instead of setting up a share in the app? If so, you'll need to share the folder in windows, giving a user with a password access to read that folder. Once that's done you can enter in the network path, "\\computername\sharedfolder" and then enter the user name and password.
Badge
The 2 responses from Jeff weren't satisfactory? He has already recommended that you call in to Sonos directly.

I stated a few posts up that I (and I'm sure many others) do not have the time to spend a few hours on the phone trying to resolve this issue.

Others have also commented with the same problem and we have all agreed that it was more than likely something Microsoft did in one of their recent updates that's causing conflict.

It would be nice if we could get some more help in here to resolve this issue as it will probably be more common when everyone starts updating their PCs to the latest Windows update.


The phone team has more tools available, and by now you'd likely be up and running.

In your report I see that your computer does not have any shared folders set up. The error you've described should not show up during the process to add a music share as the Sonos app will create the share. Are you trying to connect to a network share instead of setting up a share in the app? If so, you'll need to share the folder in windows, giving a user with a password access to read that folder. Once that's done you can enter in the network path, "\\computername\sharedfolder" and then enter the user name and password.


Thanks for the response.

Here's the story:

I've had Sonos for a good 7 to 10 years maybe longer (Time flies!) And I've had and used the same folder this whole time with no issues what so ever. I love Sonos!

Anyways, something happened recently that stopped me from using the same folder that I have been using. Not sure if it was a windows update or an update from Sonos that caused this problem.

The folder in question is just a basic folder that's on my desktop. I am the only user on my PC and therfore the sole admin.

I have not changed any settings what so ever and now all the sudden "There is no shared folder" error every single time. I checked firewall settings and they appear to be fine. I have sharing enabled on my PC.

I don't know what else to do here.
Userlevel 7
Badge +20
The 2 responses from Jeff weren't satisfactory? He has already recommended that you call in to Sonos directly.

I stated a few posts up that I (and I'm sure many others) do not have the time to spend a few hours on the phone trying to resolve this issue.

Others have also commented with the same problem and we have all agreed that it was more than likely something Microsoft did in one of their recent updates that's causing conflict.

It would be nice if we could get some more help in here to resolve this issue as it will probably be more common when everyone starts updating their PCs to the latest Windows update.


The phone team has more tools available, and by now you'd likely be up and running.

In your report I see that your computer does not have any shared folders set up. The error you've described should not show up during the process to add a music share as the Sonos app will create the share. Are you trying to connect to a network share instead of setting up a share in the app? If so, you'll need to share the folder in windows, giving a user with a password access to read that folder. Once that's done you can enter in the network path, "\\computername\sharedfolder" and then enter the user name and password.


Thanks for the response.

Here's the story:

I've had Sonos for a good 7 to 10 years maybe longer (Time flies!) And I've had and used the same folder this whole time with no issues what so ever. I love Sonos!

Anyways, something happened recently that stopped me from using the same folder that I have been using. Not sure if it was a windows update or an update from Sonos that caused this problem.

The folder in question is just a basic folder that's on my desktop. I am the only user on my PC and therfore the sole admin.

I have not changed any settings what so ever and now all the sudden "There is no shared folder" error every single time. I checked firewall settings and they appear to be fine. I have sharing enabled on my PC.

I don't know what else to do here.


For whatever reason the folder doesn't seem to be shared anymore. To set it up so that it is sharing again, try these steps:

1. Right-click on the folder containing your music, choose Properties
2. Go to the Sharing tab, click Share below.
3. Type your computer's administrator user name in the field that shows up, click Add
4. The Read permission level should be fine for this share, click Share or Done.

This should make that folder available on the network for your user name and password. Now you can head into the Sonos app, and go into the music library settings menu to add a share. This time, choose a network share or NAS share. The path should be \\computername\foldername, After the path, the app should prompt you for the user name and password, which should be the user account you specified in the sharing settings.
Badge
The 2 responses from Jeff weren't satisfactory? He has already recommended that you call in to Sonos directly.

I stated a few posts up that I (and I'm sure many others) do not have the time to spend a few hours on the phone trying to resolve this issue.

Others have also commented with the same problem and we have all agreed that it was more than likely something Microsoft did in one of their recent updates that's causing conflict.

It would be nice if we could get some more help in here to resolve this issue as it will probably be more common when everyone starts updating their PCs to the latest Windows update.


The phone team has more tools available, and by now you'd likely be up and running.

In your report I see that your computer does not have any shared folders set up. The error you've described should not show up during the process to add a music share as the Sonos app will create the share. Are you trying to connect to a network share instead of setting up a share in the app? If so, you'll need to share the folder in windows, giving a user with a password access to read that folder. Once that's done you can enter in the network path, "\\computername\sharedfolder" and then enter the user name and password.


Thanks for the response.

Here's the story:

I've had Sonos for a good 7 to 10 years maybe longer (Time flies!) And I've had and used the same folder this whole time with no issues what so ever. I love Sonos!

Anyways, something happened recently that stopped me from using the same folder that I have been using. Not sure if it was a windows update or an update from Sonos that caused this problem.

The folder in question is just a basic folder that's on my desktop. I am the only user on my PC and therfore the sole admin.

I have not changed any settings what so ever and now all the sudden "There is no shared folder" error every single time. I checked firewall settings and they appear to be fine. I have sharing enabled on my PC.

I don't know what else to do here.


For whatever reason the folder doesn't seem to be shared anymore. To set it up so that it is sharing again, try these steps:

1. Right-click on the folder containing your music, choose Properties
2. Go to the Sharing tab, click Share below.
3. Type your computer's administrator user name in the field that shows up, click Add
4. The Read permission level should be fine for this share, click Share or Done.

This should make that folder available on the network for your user name and password. Now you can head into the Sonos app, and go into the music library settings menu to add a share. This time, choose a network share or NAS share. The path should be \\computername\foldername, After the path, the app should prompt you for the user name and password, which should be the user account you specified in the sharing settings.


But why would I have to go through all of that when I never had to go that route before?

Something is not working properly between Windows and the Sonos Controller.

I have actually tried several different random folders on my computer just to see if they would work and same problem. It's not just that folder. But Sonos doesn't recognize any folder on my PC as shareable unless I manually set each folder to sharable. (Something I have never had to do before and your average computer user would not know how to do)
Badge
I made a short clip of my problem if it helps.

Also in the video I right clicked on the music folder and gave Sonos permission to it. And also tried opening the Sonos Controller as admin. Still not working.
Hi Chris.
I had the same problem, doing the same thing, but I found that right clicking and "giving access to" Sonos is not the same thing as right-clicking, going into properties and the sharing tab and clicking share as Jeff mentioned above.
Once I did that, it worked right away!
Good luck!
Badge
I am having the same issue on a Mac with a NAS. Our NAS is connected to the same network as our Sonos system and I have tried using both the symbolic name and the IP address (a much less preferred route). We have no issues with sharing the system with any other applications on either our Windows, Mac OS X or IOS devices but since the Sonos update everything is broken. Sonos works fine off my laptop but the whole point of a NAS is so my family can use the system when I am not there. Please help. I have spent >1K on my system (4 speakers, 1 CONNECT) for a set of white things.
Userlevel 7
Badge +21
The usual issue in situations like yours is that SMB v1 is not enabled on the NAS, without that Sonos won't connect but most other devices will.
Badge
I have checked, and SMB v1 is enabled.
Userlevel 7
Badge +21
Time to submit a diagnostic then, I'd suggest calling Sonos support but twitter, facebook or here are all options. Give them your issue and the diagnostic number and they should be able to walk you through the issue on the first three, the forum will be a lot slower as it isn't always staffed by Sonos folks.