Answered

Help pls - Beam with Panasonic TV (stopped working)

  • 14 February 2021
  • 8 replies
  • 57 views

Afternoon 

I've got a Panasonic TX-43FX550B 

Aside from being a rubbish TV, my Beam stopped working when I changed routers 

I can connect the Beam to my Sonos app but when I try to connect to the TV the app tells me to switch Viera link on. There is no option to do this ok my TV, so I assume my TV does not have it 

So I can't progress with adding the Beam

Note: this has worked before, and I've actually gone back to the router that was fine, so I've no idea why this Viera link issue would occur now 

Any suggestions gratefully received

 

 

 

 

icon

Best answer by Paul A 14 February 2021, 16:24

Hi @Simon321456.

Thanks for the update and immediate response.

From this point, I would recommend contacting our technical support team for more in-depth troubleshooting steps or possible product replacement. It is best to contact our technical support team so they can take a look into what is the root cause of the issue.

I don’t have an optical to HDMI adapter, must have lost it. I’ll purchase one if unable to resolve this query - Does it have to be Sonos branded?  No, any HDMI to optical adapter will do.

 

It looks to be an issue with the Sonos app believing incorrectly, that the Panasonic TV has Viera. Is there any way of correcting it?  we can’t say for now, contacting our technical support team may have positive results on this.

 

I’ll be more than happy to help if you have any other questions or concerns.

Thanks,

View original

8 replies

Userlevel 6
Badge +17

Hi @Simon321456.

Welcome to the Sonos community and thanks for reaching out to us. This is a common behavior of Sonos when a new router is in place. Allow me to share some recommendations to help you out.

 I would like to recommend, by providing some situations and the corresponding steps on what to do accordingly. 

  • ​If you only have one Sonos device. (considering that the Sonos device is plugged into power and has a solid white light)

    1. Open the Sonos app.

    2. You will be prompted at the top of the Sonos app “can’t connect to Sonos, Fix it” prompt.

    3. Tap on that prompt and then select Update wireless settings.

    4. And then follow the prompts.

  • If you have more than one Sonos device.

    1. Unplug all Sonos devices from power and while all the Sonos devices are unplugged from power, temporarily connect one Sonos device to the new router via ethernet cable. (ethernet cable first before connecting to power)

    2. Once the Sonos device (connected to the router via ethernet cable) has a solid white light, plug into power the rest of the Sonos device (not connected to the router).

    3. After all Sonos devices are connected to power and have a solid white light, open the Sonos app go to settings » system » network » wireless set up. And then follow the prompts.

    4. The prompt would also provide you the details on when to unplug the ethernet cable from the Sonos device connected to the router. (a wired connection is just temporary) or it can be permanent depending on your decision.

I hope this helps.

Please let us know if you still have further questions or concern. I’ll be more than happy to help.

Thanks,

Hi Paul

Thanks for your response

I’ve got the Beam registered, connected to my app and am able to play music through it

My issue is that I can’t get it to connect to the TV, when using the app to setup I’m presented with an instruction to ‘Switch Viera link on’, but my TV does not have a Viera link 

So I’m unable to progress past this point 

Thanks 

Userlevel 6
Badge +17

Hi @Simon321456.

Thanks for the update and immediate response.

I would like to recommend contacting the manufacturer’s customer service as they may have the answer to be able to solve this issue. I would also like to add to make sure that the Beam is connected to HDMI 2 on the TV as this is the only HDMI Port which is HDMI ARC compatible. We can also try using the Optical to HDMI adapter that came with the Beam just to check if the setup would push through.

Please let me know if you still have further questions or concern. I’ll be more than happy to help.

Thanks,

Hi Paul 

Thanks again

I’ve already contacted Panasonic but they are unable to assist. The only advice they provided was that this TV does not have a Viera link. 

I don’t have an optical to HDMI adapter, must have lost it. I’ll purchase one if unable to resolve this query - Does it have to be Sonos branded?

It looks to be an issue with the Sonos app believing incorrectly, that the Panasonic TV has Viera. Is there any way of correcting it? 

It can’t just not be compatible, presumably 

Userlevel 7
Badge +17

Vieralink is Panasonic speak for HDMI-CEC. Looking at the manual for your TV (https://www.manualslib.com/download/1563793/Panasonic-Tx-43fx550b.html) there are CEC-settings. CEC should be set to enabled.

Set to enabled, but this was news to me so thanks! 

 

Not working still, but it's knowledge I didn't have 

Userlevel 6
Badge +17

Hi @Simon321456.

Thanks for the update and immediate response.

From this point, I would recommend contacting our technical support team for more in-depth troubleshooting steps or possible product replacement. It is best to contact our technical support team so they can take a look into what is the root cause of the issue.

I don’t have an optical to HDMI adapter, must have lost it. I’ll purchase one if unable to resolve this query - Does it have to be Sonos branded?  No, any HDMI to optical adapter will do.

 

It looks to be an issue with the Sonos app believing incorrectly, that the Panasonic TV has Viera. Is there any way of correcting it?  we can’t say for now, contacting our technical support team may have positive results on this.

 

I’ll be more than happy to help if you have any other questions or concerns.

Thanks,

By way of an update: 

 

Sonos Support basically said it's the manufacturer's fault. They suggested I buy the optical cable that I'd lost but could help no further. Somewhat disappointing

 

I bought the cable and it semi works. I need to switch the volume down on the TV and assign a different command on the remote to control volume thru Beam. This is a pain as we normally just use the Virgin remote, and that's not possible 

 

The error lies solely with the Sonos app incorrectly believing my TV has Vieira Link, the previous version of the app worked fine. But there is no option for me to use that previous version 

 

So essentially, an app update has caused my device to stop working, but I just have to live with it 

 

Disappointing

Reply