Answered

Hard-Wiring Connect


Badge +5
So this conversation started one way and exposed some deeper issues....
https://en.community.sonos.com/troubleshooting-228999/can-t-change-compression-6827320

Basically, here's my "final" question. (I hope!)

I need to reduce "interference" with my Connect. I see a few ways to improve my home network:

  1. Buy a new, stronger router. (Mine is - gasp - three years old)
  2. Plug the Connect directly into the modem/router (instead of relying on Wi-Fi)
  3. Build a mesh network
  4. Some combination of above
My ultimate question is... If I plug the modem/router directly into the Connect, will that eliminate issues of my stereo dropping out?

Thanks, I'll take your answers off the air.
icon

Best answer by Stanley_4 10 July 2019, 06:51

A new router won't help as you are in Boost mode.

If you plug the Connect into your Ethernet then it won't need to use the Sonos mesh and should have a more solid connection. If you have other Sonos devices you can plug them in too, the more the merrier as far as I can tell.

If you build a non-Sonos mesh network the mesh and Boost mode work fine together as long as you can restrict the mesh from the channel you are using for the Boost mode SonosNet. Sonos in Boost mode won't use the Mesh for anything but connecting your controllers to the router.

I'd say connecting to Ethernet is the best bet. Also assign Sonos devices static/reserved IP addresses from the router's DHCP page. Make sure your Sonos is set to your quietest channel and the WiFi credentials are cleared. Set the router to your second best channel.
View original

5 replies

Userlevel 7
Badge +21
A new router won't help as you are in Boost mode.

If you plug the Connect into your Ethernet then it won't need to use the Sonos mesh and should have a more solid connection. If you have other Sonos devices you can plug them in too, the more the merrier as far as I can tell.

If you build a non-Sonos mesh network the mesh and Boost mode work fine together as long as you can restrict the mesh from the channel you are using for the Boost mode SonosNet. Sonos in Boost mode won't use the Mesh for anything but connecting your controllers to the router.

I'd say connecting to Ethernet is the best bet. Also assign Sonos devices static/reserved IP addresses from the router's DHCP page. Make sure your Sonos is set to your quietest channel and the WiFi credentials are cleared. Set the router to your second best channel.
Badge +5
Thanks!

Hardwiring is the least best option, in that involves moving furniture (which will greatly upset the wife) or have exposed cables (even more greatly upsetting the wife, AND defeating the purpose of buying Sonos in the first place). But, if that's the only way to get uninterrupted sound...

But then I will need either a much more powerful router or a mesh network, because that will involve moving the router from the dead center of the apartment to the far side - right now it's equidistant from the Connect and the teevee....

But, explain please, what you mean by "WiFi credentials are cleared". And how do I know what my quietest channel is?
Userlevel 7
Badge +21
I'm not sure why you think a more powerful (WiFI AP section I'm assuming) router will help since you aren't using that to connect to your Sonos devices since you have a Boost.

Same for a mesh network, aside from making things worse if it uses the same channel as your Boost network is using it will have no impact since your Sonos won't be using it.

WiFi credentials are your SSID and passphrase, if they are set the controller will offer the chance to clear them under settings.

If wiring isn't a simple option then you should try to troubleshoot the Sonos Boost network, probably starting at the network matrix in the internal diagnostics you can see from a web browser.

Replace my IP with yours: http://172.16.1.115:1400/support/review (don't look at the Boost for this)

Quietest channel is harder, you can get some idea using a phone or tablet based WiFi signal analyzer but they only show signals they recognize, not noise or non-WiFi signals. Maybe send in a diagnostic and ask Sonos support to look at it, they have direct 24x7 support options on the contact page.
Badge +5
My router is in the middle of my apartment - the Connect is at one end and the Teevee is at the other.

If I move the router to the Connect and plug it in, it will not be strong enough for the Teevee.

So by "fixing" the Connect by plugging it into the modem, I create two new problems.

Yeah, I have a Wi-Fi analyzer and have been scolded because it doesn't show all those other points of interference you mentioned. I hoped maybe you were thinking of something else.

Thanks, will report back.
Userlevel 7
Badge +21
I moved off a WiFi router combination a while back and got an Ubiquity AP and the controller app, they have a great built in RF analyzer that gives you a full analysis. Adding an AP to your current router and turning off the internal AP would improve your WiFi to the TV but wouldn't impact Sonos since it is only using the Boost and not your WiFi.

Any way you can move just the Boost to a better position, sometimes a move of a meter is enough to make a big difference. I moved one of my Sonos devices about 4 feet and it suddenly started working far better. Researching "why it wasn't happy in the original spot" turned up a WD external drive that even though it contained no radio components was killing any WiFi near it. The Network Matrix can show you background noise in the left column.

I'd do the Network Matrix research and try identifying any local interference before I did anything else, particularly stuff that makes for an unhappy spouse.

Reply