Question

Groove Music cutting out


Userlevel 2
Badge +1
Immediately installed the Groove service.

Unfortunately Sonos keeps losing the 'groove' connection every 45-60 seconds, and skips to the next song.

Unusable right now. But i trust this will be fixed. Note: This conversation was created from a reply on: Groove Music now in Beta on Sonos.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

94 replies

Userlevel 7
Badge +26
Are you having trouble with all of Groove Music, or just the Collection section? Do you have any trouble with your local music as well or any other music source? If you're just having trouble with the Collection section, we're currently investigating trouble with that right now.

Just the Collection. What are the results of your investigation?


The latest news is that the team is narrowing down exactly where the issue is coming from. We're working with Microsoft on tracking down the cause and finding a resolution. I'll let you all know when we've got this one fixed. Thanks
Userlevel 7
Badge +26
Come on guys, what's the status on this? We sent you all the diagnostics and information you need, and obviously the problem is widely present. Now it's your turn to fix it.

Absolutely, we're working with Microsoft to resolve this currently. We've collected enough data at this point and are working with them to get this resolved. We'll let you know as soon as we have more details to share.
Hi all, I'm using the Microsoft Groove Service on my Sonos 5 and I 've stored my mp3's on Onedrive. When I try to play music from my Onedrive Library after some seconds or minutes an error is poping up that the connection has been lost and the next track is playing. This happens with every track I haven't been able to play any track completly. is this a know issue??
I've been following this thread for sometime, but thought I'd chime in and let the SONOS team know I'm having the exact same issue. Evidently, this is a seriously difficult problem to fix!

I'm trying to be patient, but it's getting a bit ridiculous.
Come on guys, what's the status on this? We sent you all the diagnostics and information you need, and obviously the problem is widely present. Now it's your turn to fix it.

Absolutely, we're working with Microsoft to resolve this currently. We've collected enough data at this point and are working with them to get this resolved. We'll let you know as soon as we have more details to share.


Ryan, anything new on the fix?
Exact same issue. Highly annoying my wife, will need to move away from groove collection and Sonos combo if this looks like a long dragging item. Have issue on connect amp, play 1, 3, 5 and soundbars in my house Have removed local storage to rely on onedrive but this will be deal breaker on that front.
Userlevel 2
Badge +1
It's been more than a year ago, since I reported this.
Still not fixed.

Lost all hope!

Both the Groove Music team, and Sonos are supposedly in the music streaming business.
Having serious doubts about both.

This is getting ridiculous.
Userlevel 7
Badge +26
I modified your post to hide your email.

I'll pass the information you provided on. They may reach out if more details are needed.

Thanks!
Ryan,

As an FYI, I've had a support ticket open with you guys on this issue for literally over a year now. The ticket was initially opened in August 25th 2015. In this ticket we've already ruled out issues in network connectivity between my home and Microsoft's servers. As of the latest response from Nate D., you guys are apparently working with Microsoft on this and have been since December 2015.

All of this to say, it's basically impossible that network issues are the cause of Bas_3's issues.
Hi all,

similar for me... I have a few own mp3s on OneDrive that I want to stream via Groove / Sonos. I don't use the Music Pass. Tried it with my Play:5 and Play:3.

Mostly the songs play for a random time between 1:30 and 3:00.... sometimes they even run through for 5:00. But after that error message and the next song starts.
I use Spotify and Amazon Music too without any problems. So it's only Groove that has that problem.
Userlevel 1
@Sonos staff: can your devs look into this? There are a lot of customers experiencing this, and it probably has to do with the fact that Onedrive seems to close idle connections after 60 seconds. There has to be a bug in the way the speaker handles keepalive connections / connections closed by the server. It probably mainly surfaces with Onedrive because 60 seconds is more aggressive than what other music services have...
Userlevel 2
Badge
I am having issues with Groove as well, although not just tracks on OneDrive.
Same issue for me , tracks cutting out when streamed from one drive library. Windows 10 Music app streams same files from one drive perfectly. Will play a minute or so then fail. Would be really great to have this working.
Userlevel 7
Badge +26
Same issue for me , tracks cutting out when streamed from one drive library. Windows 10 Music app streams same files from one drive perfectly. Will play a minute or so then fail. Would be really great to have this working.

Thanks for the details. We're taking a close look into this issue right now and will let you know when there's more to share. If you consistently have trouble, I'd recommend giving us a call and working with a technician. You can find our contact information and hours here: http://www.sonos.com/contact
I have been experiencing this issue as long as Groove has been on Sonos. At first I could accept it because I figured that it was just an issue with the beta. Now that it has been more than six months, it is no longer acceptable.

Every time I have friends over to my house someone will comment that none of the songs play to the end and they ask "does it do this all of the time?" when I say yes, they say "I can't believe you can even listen to this thing." Either support Groove music or don't.
Userlevel 2
Badge +1
I have to agree. After 7 months, I've given up on this. We all know Sonos is slow to implement anything (still waiting on a white playbar....), and they don't really want to support Windows. The Microsoft Groove team is much worse. That team must be the worst development team I've ever seen. I'd say double jeopardy in this case. This will probably never work right..... A shame.
Come on guys, what's the status on this? We sent you all the diagnostics and information you need, and obviously the problem is widely present. Now it's your turn to fix it.
Come on guys, what's the status on this? We sent you all the diagnostics and information you need, and obviously the problem is widely present. Now it's your turn to fix it.

Absolutely, we're working with Microsoft to resolve this currently. We've collected enough data at this point and are working with them to get this resolved. We'll let you know as soon as we have more details to share.


Thanks Ryan,
We appreciate the effort that Sonos and Microsoft are putting in. Really looking forward to having this resolved.

Roy
I am also experiencing this issue. Makes Sonos and Groove combination worthless.
Badge
Same here, only onedrive collection, drop outs after40-60sec.
Waiting patiently for a fix.

Good to hear its on its way. (I guess)
Still no fix on the horizon?
Userlevel 7
Badge +26
Still no fix on the horizon?
We don't have a timeline for it yet, but we'll let everyone know as soon as it's ready to go.
Badge
unbelievable
Badge
It's been more than a year ago, since I reported this.
Still not fixed.

Lost all hope!

Both the Groove Music team, and Sonos are supposedly in the music streaming business.
Having serious doubts about both.

This is getting ridiculous.



It's getting so frustrating.. I keep all my music on OneDrive (with groove), bought de expensive play 5(gen2) and now... I still can't even use it in full effect...
Same problem here. Have a 5, two 1s and a connect. Groove music pass and a ton of music on OneDrive -- all useless. This has been going on for a year now.