Question

Groove Music cutting out


Userlevel 2
Badge +1
Immediately installed the Groove service.

Unfortunately Sonos keeps losing the 'groove' connection every 45-60 seconds, and skips to the next song.

Unusable right now. But i trust this will be fixed. Note: This conversation was created from a reply on: Groove Music now in Beta on Sonos.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

94 replies

Still no updates? I do experience the problem as well - it is only with groove and sonos...
Userlevel 2
Badge +1
Updates?????
Here is a diagnostic for my problem: 6972571
Dear all,

I have the same problem with my Groove account. Groove works perfect with its own apps and all other providers work fine with Sonos. Just the combination Groove on Sonos causes constant interruptions ("connection to groove lost"). How can I help you to further investigate this?

Oliver
Ryan,

As an FYI, I've had a support ticket open with you guys on this issue for literally over a year now. The ticket was initially opened in August 25th 2015. In this ticket we've already ruled out issues in network connectivity between my home and Microsoft's servers. As of the latest response from Nate D., you guys are apparently working with Microsoft on this and have been since December 2015.

All of this to say, it's basically impossible that network issues are the cause of Bas_3's issues.
Userlevel 7
Badge +26
I modified your post to hide your email.

I'll pass the information you provided on. They may reach out if more details are needed.

Thanks!
Userlevel 2
Badge +1
Cancelled the call after being in the waiting queue for 10 minutes.
Not enough skype minutes left to keep waiting...
(calling the US through my fixed landline will get expensive real fast 🙂 )

Tech support can reach me on Skype if they need extra information.
Userlevel 7
Badge +26
Contact details are here and if you need them to switch to call you on a different number when you're on with them, they can do that.
Userlevel 2
Badge +1
Let them contact me on skype, and we can work out some extra traces......
Or let me know what number to call.....

I'm starting to litter the topic

Btw: playing OneDrive music through the Groove App works perfectly fine.
Userlevel 2
Badge +1
Especially the callback to telfort.nl at the end......
Userlevel 2
Badge +1
Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. All rights reserved.

C:\Users\Bas>tracert sonos.auth.xboxlive.com

Tracing route to sonos.auth.gtm.xboxlive.com [66.119.149.154]
over a maximum of 30 hops:

1 1 ms 3 ms 2 ms 192.168.1.254
2 28 ms 23 ms 23 ms 82-171-191-xxx.ip.telfort.nl [82.171.191.xxx]
3 51 ms 25 ms 24 ms ams-ix-1.microsoft.com [80.249.209.20]
4 404 ms 406 ms 402 ms be-72-0.ibr02.ams.ntwk.msn.net [104.44.9.146]
5 365 ms 406 ms 409 ms be-4-0.ibr02.amb.ntwk.msn.net [104.44.5.34]
6 34 ms 35 ms 37 ms ae6-0.pra-96cbe-1b.ntwk.msn.net [104.44.4.231]
7 40 ms 38 ms 34 ms ae12-0.pra-96cbe-1a.ntwk.msn.net [104.44.225.212]
8 49 ms 36 ms 43 ms ae27-0.lon04-96cbe-1b.ntwk.msn.net [104.44.227.112]
9 325 ms 406 ms 407 ms be-8-0.ibr02.nyc04.ntwk.msn.net [104.44.5.28]
10 376 ms 407 ms 405 ms be-4-0.ibr02.was05.ntwk.msn.net [104.44.4.28]
11 385 ms 407 ms 406 ms be-1-0.ibr01.was05.ntwk.msn.net [104.44.4.18]
12 374 ms 407 ms 405 ms be-4-0.ibr03.atb.ntwk.msn.net [104.44.4.23]
13 342 ms 346 ms 406 ms be-3-0.ibr01.atb.ntwk.msn.net [104.44.4.42]
14 370 ms 405 ms 408 ms be-6-0.ibr02.sn4.ntwk.msn.net [104.44.4.47]
15 388 ms 398 ms 407 ms be-1-0.ibr01.sn4.ntwk.msn.net [104.44.4.205]
16 370 ms 406 ms 406 ms be-3-0.ibr02.lax03.ntwk.msn.net [104.44.4.4]
17 174 ms 202 ms 202 ms ae72-0.lax-96cbe-1b.ntwk.msn.net [104.44.8.111]
18 278 ms * 369 ms ae26-0.tya-96cbe-1a.ntwk.msn.net [198.206.164.135]
19 322 ms 304 ms 314 ms ae19-0.kaw-96cbe-1a.ntwk.msn.net [198.206.164.104]
20 366 ms 264 ms 343 ms ae0-0.kaw-96cbe-1b.ntwk.msn.net [104.44.227.9]
21 309 ms 305 ms 261 ms ae9-0.tyb-96cbe-1b.ntwk.msn.net [104.44.227.10]
22 374 ms 407 ms 406 ms ae4-0.hkg-96cbe-1b.ntwk.msn.net [204.152.141.62]
23 338 ms 508 ms 409 ms ae11-0.hkg-96cbe-1a.ntwk.msn.net [104.44.226.178]
24 309 ms 375 ms 408 ms ae13-0.hk2-96cbe-1a.ntwk.msn.net [207.46.38.73]
25 416 ms 405 ms 407 ms 82-168-234-41.ip.telfort.nl [82.168.234.41]
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.

C:\Users\Bas>


Looks like a msn.net network problem to me!
Not sure what going on, but that is one strange network they have going.......
Userlevel 7
Badge +26
They'll want to run a few traces and collect that information to move it up to the team for investigation. They'll want to confirm there isn't any other local trouble, but it sounds like it may be something along the link outside your network.
Userlevel 2
Badge +1
Others work fine. Amazon, google play and Deezer. No problems. Local music fine as well.
It's just Groove that hasn't work EVER!

Just did a trace on sonos.auth.xboxlive.com, and it seems the msn.net network is going in circles....
I'm confident my own network isn't the cause.

I'm willing to give you a call, what information are you looking for?
Userlevel 7
Badge +26
6492718

Thanks, there are some communication issues internally on the network, but doesn't look like it should cause a lot of problems. Do you usually play other services too? If so, do any of them have trouble?

It'd be great to give us a call on our support line and work with a technician live here so we can get a really good look internally at the system.
same here, still broken. It skips tracks every 2 mins....really poor from both Sonos and Microsoft!
Userlevel 2
Badge +1
6492718
Userlevel 7
Badge +26
Nope still not working like it should.

Really disappointed about both Sonos and Microsoft.


Mind sending a diagnostic our way? I'll take a look for you. Directions here to submit a diagnostic from your Sonos system and reply back with your confirmation number.
Userlevel 2
Badge +1
Still skips to the next track every 2 minutes.

Unusable!!!!

Really, after more than a year, without any real communication by both Sonos, and Microsoft, still no fix!

Does Sonos (or the Groove team) have anything to say about this?
(How about a fix within a week, and an apology for taking more than a year)
Userlevel 2
Badge +1
Nope still not working like it should.

Really disappointed about both Sonos and Microsoft.
Will confirm tonight. 6 pieces of sonos kit to try with. Wife will be very happy if this is resolved.
Just tried a couple of ways. Seems to be working now.
Userlevel 7
Badge +26
Hi everyone, they've been rolling out some stability improvements. So let us know how it goes. If you have any further trouble we'll still be looking into things, so just let us know.

Thanks
I will try it again...I've been using Google music, argh! Microsoft has updated Groove today to play that customised playlist through sonos...maybe they've put a fix in place for the streaming issue? dunno yet. I will post my feedback here later in the week.

This is the link for the update news: http://www.windowscentral.com/personalized-playlist-recommendations-come-groove-music-sonos
Badge
Ey, seems to be working again after the last (beta) update? Anyone else noticed that too?

But i trust this will be fixed.


Haha don't you think the devs have something better to do than actually help their customers or just push out "new and exciting" music services?