Question

Groove Music cutting out


Userlevel 2
Badge +1
Immediately installed the Groove service.

Unfortunately Sonos keeps losing the 'groove' connection every 45-60 seconds, and skips to the next song.

Unusable right now. But i trust this will be fixed. Note: This conversation was created from a reply on: Groove Music now in Beta on Sonos.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

94 replies

Userlevel 7
Badge +26
Hi Bas,

First we've heard any trouble, mind sending a diagnostic from there and we'll take a look?
Userlevel 2
Badge +1
# 4766680 & # 4766705
Userlevel 2
Badge +1
The router is setup in bridged mode. Everything is Gigabit (cable). Both routers are 2.4 & 5 Ghz. The distance between the router and the Play:1's is about 7-8 feet. All 3 Play:1's are connected wirelessly.
Userlevel 2
Badge +1
Maybe a problem with the msn.net network?
Userlevel 7
Badge +26
Thanks guys, that's great information, really useful. The time it's taking it a little troubling. Do you think you can also run one more traceroute over to progdownload.zune.net for us and let us know the results?

Also, what router are you using?
Userlevel 2
Badge +1
Ah, the good old Zune. Really miss it.

(Wish they would have kept it. Was so much better than the current offering.... alas)

Also: Seems 'progdownload.zune.net' is in akamai's cache. (or was that the point?)
I am away rest of the weekend but will create new traceet when I return. My router is an Asus RT68ac with newest official firmware.
Hi all, I'm using the Microsoft Groove Service on my Sonos 5 and I 've stored my mp3's on Onedrive. When I try to play music from my Onedrive Library after some seconds or minutes an error is poping up that the connection has been lost and the next track is playing. This happens with every track I haven't been able to play any track completly. is this a know issue??
Userlevel 7
Badge +26
Groove is still in beta, so there are some issues still. I just moved your thread over to this one polikmuj where we're working with a few other people having trouble.

Can you send a diagnostic from there and give us the confirmation numbers? We'll take a closer look.
Userlevel 1
Badge
So far the service is working great for me, at least the streaming portion. I haven't tried files on One Drive.
Hi all,

similar for me... I have a few own mp3s on OneDrive that I want to stream via Groove / Sonos. I don't use the Music Pass. Tried it with my Play:5 and Play:3.

Mostly the songs play for a random time between 1:30 and 3:00.... sometimes they even run through for 5:00. But after that error message and the next song starts.
I use Spotify and Amazon Music too without any problems. So it's only Groove that has that problem.
Badge
Groove Music failing after 1-3minutes
Speedtest.net - 159mbps down 10mbps UP

Deezer and google play working FINE - Would much prefer to use Groove due to one drive sync from my NAS.

Pingtest
22ms
Jitter 1ms
Line Quality A

Router on gigabit connection via cat5e to laptop and bridge

Traceroute to sonos.auth.xboxlive.com

1 11 ms 9 ms 9 ms 10.10.140.1
2 10 ms 10 ms 10 ms brig-core-2a-xe-002-0.network.virginmedia.net [8
0.3.64.225]
3 12 ms 11 ms 13 ms brnt-bb-1a-ae19-0.network.virginmedia.net [213.1
05.159.153]
4 * * * Request timed out.
5 * * * Request timed out.
6 14 ms 17 ms 17 ms brhm-bb-1c-ae1-0.network.virginmedia.net [62.254
.42.210]
7 * * * Request timed out.
8 20 ms 42 ms 21 ms 213.105.64.30
9 89 ms * 87 ms ae25-0.nyc-96cbe-1a.ntwk.msn.net [207.46.43.47]

10 87 ms 89 ms 87 ms ae0-0.nyc-96cbe-1b.ntwk.msn.net [207.46.38.113]

11 94 ms 92 ms 93 ms ae6-0.was02-96cbe-1c.ntwk.msn.net [191.234.84.14
2]
12 92 ms 93 ms 93 ms 191.234.85.32
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 132 ms 133 ms 134 ms 104.44.224.117
18 138 ms 136 ms 137 ms 104.44.224.32
19 * * * Request timed out.
20 159 ms 160 ms 160 ms ae26-0.co1-96c-1b.ntwk.msn.net [191.234.82.247]

21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 160 ms 160 ms 171 ms cpc66113-brig15-2-0-cust104.3-3.cable.virginm.ne
t [80.7.18.105]
27 159 ms 158 ms 156 ms 134.170.179.243

Trace complete.

Traceroute to progdownload.zune.net

Tracing route to e2821.g.akamaiedge.net [23.195.53.195]
over a maximum of 30 hops:

1 8 ms 8 ms 8 ms 10.10.140.1
2 10 ms 9 ms 9 ms brig-core-2a-xe-002-0.network.virginmedia.net [8
0.3.64.225]
3 25 ms 14 ms 12 ms brnt-bb-1a-ae19-0.network.virginmedia.net [213.1
05.159.153]
4 * * * Request timed out.
5 10 ms 13 ms 12 ms tele-ic-7-ae0-0.network.virginmedia.net [62.253.
175.114]
6 12 ms 13 ms 13 ms a84-53-177-193.deploy.akamaitechnologies.com [84
.53.177.193]
7 10 ms 10 ms 10 ms a23-195-53-195.deploy.static.akamaitechnologies.
com [23.195.53.195]

Trace complete.
Userlevel 2
Badge +1
Any news from Sonos...... What's the status of this right now?
I'm experiencing the same issue. My router is the ASUS RT-AC68U. My SONOS Connect is plugged in via Ethernet and I have strong wireless signal where the speakers are.

Just submitted diagnostic number 4917665 in case it helps.
Userlevel 3
Badge
Have the same problem, have tried removing and reinstating the sercie. I have submitted a diagnostic (4921599).

Router is Virgin Superhub 2ac, speakers connected wirelessly without bridge. First speaker in the mesh is no more than a meter away.

Speed test showed 108 Mbps download and 6.3 Mbps upload

Ping test showed line quality A; ping 31ms; jitter 3ms and packet loss 0%

Tracert to sonos.auth.xboxlive.com;

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>tracert sonos.auth.xboxlive.com

Tracing route to sonos.auth.gtm.xboxlive.com [134.170.178.243]
over a maximum of 30 hops:

1 2 ms 2 ms * routerlogin.net [192.168.0.1]
2 * * * Request timed out.
3 16 ms 16 ms 16 ms cpc1-bror3-4-0-cust173.bmly.cable.ntl.com [80.1.241.173]
4 * * * Request timed out.
5 * * * Request timed out.
6 29 ms 19 ms 19 ms brhm-bb-1c-ae1-0.network.virginmedia.net [62.254.42.210]
7 * * * Request timed out.
8 23 ms 23 ms 36 ms m322-mp2.cvx3-a.ltn.dial.ntli.net [213.104.85.66]
9 407 ms 23 ms 26 ms 104.44.224.210
10 198 ms 93 ms 91 ms ae26-0.nyc-96cbe-1a.ntwk.msn.net [207.46.45.225]
11 93 ms 92 ms 94 ms ae0-0.nyc-96cbe-1b.ntwk.msn.net [207.46.38.113]
12 110 ms 99 ms 97 ms ae6-0.was02-96cbe-1c.ntwk.msn.net [191.234.84.142]
13 234 ms 95 ms 292 ms 191.234.85.32
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 139 ms 138 ms 138 ms 104.44.224.117
19 141 ms 141 ms 144 ms 104.44.224.25
20 * * * Request timed out.
21 168 ms 167 ms 167 ms ae26-0.co1-96c-1b.ntwk.msn.net [191.234.82.247]
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 270 ms 163 ms 168 ms 134.170.178.243

Trace complete.

Tracert to progdownload.zune.net ;

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>tracert progdownload.zune.net

Tracing route to e2821.g.akamaiedge.net [104.82.235.53]
over a maximum of 30 hops:

1 * * 1 ms routerlogin.net [192.168.0.1]
2 * * * Request timed out.
3 16 ms 17 ms 23 ms cpc1-bror3-4-0-cust173.bmly.cable.ntl.com [80.1.241.173]
4 * * * Request timed out.
5 * * * Request timed out.
6 * * * Request timed out.
7 22 ms 17 ms 17 ms telw-ic-3-ae4-0.network.virginmedia.net [212.250.14.110]
8 21 ms 19 ms 19 ms cpc1-hart1-4-0-cust174.midd.cable.ntl.com [62.254.84.174]
9 20 ms 20 ms 20 ms a104-82-235-53.deploy.static.akamaitechnologies.com [104.82.235.53]

Trace complete.

Let us know if there is any further information that might be helpful.
Userlevel 7
Badge +26
Thanks guys, that's all very helpful. Just to check, are you having this problem when playing from "Collection" only or when playing any tracks from Groove Music?
Badge
When playing from my collection saved on Onedrive - all other streaming is ok from Deezer or Google
Userlevel 3
Badge
Same here. Just OneDrive collection.
Badge
Added detailed info on this thread, now submitted diagostic 4928426

ANY INFO? Much appreciated.
Userlevel 2
Badge
here is the same problem.
music from my collections skips every ~50-60seconds.

i have no music pass.
Badge
I have the same issue. I have no music pass but I do have a mix of OneDrive songs and purchased songs.

The last time I tried playing, it played the first few songs OK and then started to skip about a minute or so into the song.

Local music, Google Music, Amazon Music, and Pandora all play without issue.
Userlevel 4
Badge +3
Please be aware that the Groove Music Service is currently experiencing a system-wide issue. Playback may result in the error: “Playing this content requires a Groove Music Pass.” We'll let you know here once the service has been restored, thank you for your patience.
Userlevel 7
Badge +26
Please be aware that the Groove Music Service is currently experiencing a system-wide issue. Playback may result in the error: “Playing this content requires a Groove Music Pass.” We'll let you know here once the service has been restored, thank you for your patience.

This issue has been resolved now. Let us know if you have any trouble or questions with Groove Music on Sonos.
Userlevel 1
@Sonos staff: can your devs look into this? There are a lot of customers experiencing this, and it probably has to do with the fact that Onedrive seems to close idle connections after 60 seconds. There has to be a bug in the way the speaker handles keepalive connections / connections closed by the server. It probably mainly surfaces with Onedrive because 60 seconds is more aggressive than what other music services have...
Userlevel 7
Badge +26
@Sonos staff: can your devs look into this? There are a lot of customers experiencing this, and it probably has to do with the fact that Onedrive seems to close idle connections after 60 seconds. There has to be a bug in the way the speaker handles keepalive connections / connections closed by the server. It probably mainly surfaces with Onedrive because 60 seconds is more aggressive than what other music services have...

I just replied to your post on the other thread, let's keep the conversation going on that other thread. Thanks!