Google Wifi issue - solved

  • 31 March 2018
  • 6 replies
  • 14483 views

Hi All

I was having the same problem a lot of other people were with connecting to my Sonos once I installed Google WiFi. As best as I can work out, the problem is due to the controller apps using broadcast traffic and that Google WiFi actually creates a separate network and routes traffic between the WiFi network and the local LAN network.

Now that I have solid WiFi across the house, the answer is fairly simple. You need to connect the Sonos systems to the WiFi rather than the LAN cable.

If you already have Sonos setup,
1. Use the desktop application to go into each of the "rooms"
2. Right click the room and select settings
3. Select advanaced
4. You should now have the option to connect your system to the Wireless network. Put your details in to connect to your Google WiFi
5. (I don't understand why these steps are needed, but seemed required to finish the process) - Disconnect the network cable from the Sonos controlled
6. Press the advertise combination, eg mute button and the increase volume

Worked for me, hopefully it will work for you 🙂

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +20
Hi ShaneAu,

Thanks for posting this. Hopefully some of our community members will find this helpful.
I am sorry but I don't think these steps are necessary or optimal. For a start it is never necessary to re-enter wifi details for every speaker, as this is a system-wide setting.

Sonos with Google wifi is best run in Boost mode. The key steps are to disable DHCP and wireless on the original router, and wire a Sonos component to a Google unit not the original router.
https://en.community.sonos.com/ask-a-question-228987/sonos-and-google-wifi-6798278
The key steps are to disable DHCP and wireless on the original router, and wire a Sonos component to a Google unit not the original router.

This worked for me! Had to log into the old router as admin to switch off both 2.4 and 5 Ghz Wifi, then followed the steps in the Sonos App. Thanks!
Glad it worked. My optimal advice now would be to leave DHCP on on the original router, to ensure the Google puck gets an IP address. However, this goes with the requirements to disable wireless on the original router and to wire nothing to it other than the Google puck. That way nothing else will get an IP address from the original router.
Badge +1
Glad it worked. My optimal advice now would be to leave DHCP on on the original router, to ensure the Google puck gets an IP address. However, this goes with the requirements to disable wireless on the original router and to wire nothing to it other than the Google puck. That way nothing else will get an IP address from the original router.

Hi John,

So what is the status of the DHCP on the base router here? turn it off initially before configuring SONOS through the Google WIFI and enable once it is complete?