Google Wifi connection

  • 4 September 2018
  • 30 replies
  • 3769 views

Userlevel 3
Badge +3
  • Prominent Collaborator I
  • 80 replies
I have been using Google Wifi with Sonos for about six months. I have seven Sonos zones, using eight devices. It used to be pretty good, but lately, I've been getting a lot of dropouts. I had it all set up to work over wifi, not Sonosnet. Google's app allows you to check connection speeds to each wifi device. When I do that, I see that my Sonos units are getting terrible speeds. For example, my Connect:Amp, which is about six feet away from one of the Google nodes, was getting a speed of

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Hi. I don't think there is much doubt that we have our culprit. A few thoughts:

1. What the red showed was that the Sonos units were working hard to resist the interference, but it doesn't show that they were failing to do so. But given that you are having a few issues, it is a pretty good bet that this is a significant factor.
2. If you are able to experiment by turning the system off when the children don't need remote monitoring, that would help to show if this is the cause of any drops.
3. Given that the cameras aren't that close to Sonos, and changing the SonosNet channel has little effect, the monitors must be blitzing the whole 2.4GHz spectrum pretty powerfully. I know nothing about baby monitors, but I would have thought there were systems out there that don't cause so much interference at the critical wifi frequencies. Whether you want to research that, or go to the trouble and expense of changing (with no guarantees) is your call.

Hope that helps.
Userlevel 3
Badge +3
I think my children are almost out of the stage where the monitor is needed, so we'll just live with it for the time being. At least now I know the likely cause.

Thanks for all your help
Userlevel 7
Badge +21
You tried channel switching with little impact but if you put Sonos or the cameras on channel 1 and the other on channel 11 or higher if that is allowed in Canada you'll have the least interference.

Another thing to try is antenna orientation on the cameras, if they have movable antennas. Switch then from vertical to horizontal and try to point the low signal spots at your nearest Sonos devices. Tinfoil looks so tacky but it can be fun to play with as a RF signal director, but only after you assure the spouse it is temporary!
Userlevel 3
Badge +3
Good point, I never thought to check if I can change the channel on the monitor. It's not a wifi monitor but I will see what options i have.
Howdy all, I too have the exact same intermittent issue. My ISP is AT&T and I have four Google Mesh Routers. Over the past 6 months, I have called AT&T yelling and bashing them to fix this problem and they have changed their modem three times. This week it started getting really bad so again I called AT&T and was ready to tell them this was the last call I'm making.

Well, the great news is, the AT&T technician who came out is experienced with the Google WiFi router AND, the issues I've been having. He thoroughly tested the AT&T side and said their network was fine. This was the first I ever heard of an issue with Google. I called Google Support this evening and a long story short, they found a problem. One of my devices (a Printer) was set hard in the cloud as a Priority Device. This allows 90% of the network bandwidth to be dedicated to that device. Mine was set for a printer since February (5 months ago). But it didn't show on the Google WiFi app. So she had me prioritize a device (any device) then turn it off manually. This pops up after you set the device for priority. Then, she had me unplug everything, including the AT&T router for 5 minutes. After I plugged everything back in and the network stabilized, she checked the cloud and everything was fine.

(I left out an important step. After I prioritized a device then turned it off, she had me go to NETWORK & GENERAL then PRIVACY. She then had me turn off all three settings in this menu. We sat there for a minute so she could check the cloud then she had me turn them back on and again, she checked the cloud.)

If you believe this might be your issue, instead of doing this yourself, I highly recommend you contact Google Support. They answered the phone almost immediately and they were easy to work with. They're available 24 hours a day and the number is in the WiFi app under APP & SUPPORT DETAILS then WIFI CARE SUPPORT.

I hope this helps some of you!