Google Wifi connection

  • 4 September 2018
  • 30 replies
  • 3769 views

Userlevel 3
Badge +3
  • Prominent Collaborator I
  • 80 replies
I have been using Google Wifi with Sonos for about six months. I have seven Sonos zones, using eight devices. It used to be pretty good, but lately, I've been getting a lot of dropouts. I had it all set up to work over wifi, not Sonosnet. Google's app allows you to check connection speeds to each wifi device. When I do that, I see that my Sonos units are getting terrible speeds. For example, my Connect:Amp, which is about six feet away from one of the Google nodes, was getting a speed of

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Userlevel 7
Hi jnak

Although you were getting good speeds in the beginning with Google Wi-Fi it's still Wi-Fi subject to outside and/or inside interference. Also, make sure your Google Wi-Fi components are up-to-date with the latest firmware and that your Sonos App is v9.1.

A Boost setup may be your best solution as the Google Wi-Fi may be overloaded with competing components. If setting up a Boost network for Sonos is something you are against then I suggest you take every Wi-Fi component off-line (unplug) and bring each one back one-by-one. I'd start with bringing back Sonos first and the others afterwards. You might also submit a diagnostic and post the Reference ID in this forum. Good Luck!

Cheers!
Userlevel 3
Badge +3
OK, I put my Sonos back in wifi mode and submitted a diagnostic 1173139766. The speeds according to the Google wifi app show all my Sonos devices have poor speeds. For example, my playbase was 3 mbps while the Roku that is right next to the playbase was hitting 50 mbps. It doesn't make sense to me, all of the Sonos devices have poor speeds on wifi mode while the other devices have very good speeds.
Userlevel 7
Badge +21
How are you testing the speed of the Sonos gear? As far as I know it doesn't support any speed test systems.

Are you possibly just looking at the bandwidth that the Sonos gear is using? That of course will be fairly low as Sonos devices do not normally consume a lot of bandwidth.

Sonos isn't expecting to see much use given that they installed 100 MBit/Sec Ethernet ports.
Userlevel 3
Badge +3
The Google Wifi app allows me to test the speed of the wifi connection to any device connected via wifi. It's not an internet speed test, just wifi. My phone, for example, generally shows speeds of around 400 mbps although my interest is only 150.
Userlevel 7
I don't know if you are still concerned about speeds and dropouts, but here's something else you might investigate. Quality of Service (QoS) settings. QoS allow you to specify what type of usage is prioritized for band width. The typical choices are Video, Gaming and General Internet usage. Sonos I'd guess would fall in the general internet category. If your QoS is set to prioritize Video (i.e. your Roku) you may be depriving your General Internet of band width.

QoS is also influenced by your ISP meaning that if you are on a 1GB tier setting QoS parameters may not be as critical as opposed to being on 500Mbs tier. Just food for thought.

Cheers!
Userlevel 3
Badge +3
QoS on Google WIFI is turned off. I was testing speeds over wifi only, not ISP speeds.

I bought a Boost so I am unable to check wifi speeds to Sonos via the Google WIFI app. However, the Sonos network matrix shows a lot of red boxes. Not sure what is happening. The dropouts appear to have stopped though, so I am cautiously optimistic that the Boost is helping.
The red generally suggests interference - what channels are Google and Sonos using? If you are using an ISP modem/router to access internet, is that in modem only mode, or does it at least have wireless turned off?
Userlevel 3
Badge +3
The ISP provided router is set to modem only. I am unable to change the channels in Google Wifi, as the system automatically chooses the channel it thinks is best.

I was getting a lot of red boxes when using the Sonos in WIFI mode too.
If you want to post a screenshot of the matrix I can take a look. Some people worry about posting Mac addresses, although I don't really think there is a risk, but I thought I ought to mention.
Userlevel 3
Badge +3
Thanks, John. I will post a screenshot tonight
Userlevel 7
In about Sonos you might also check to see if all Sonos registers as being in Boost mode. Here's what to look for:

Userlevel 3
Badge +3
Here's a screenshot of the network matrix. It looks a little better than before:



And everything shows WM=0 in the Sonos app.
There is serious wireless interference around a number of your speakers, although communications don't seem to be too badly affected. Any ideas about the source? Baby monitors? Home automation? What other wireless systems do you have?
Userlevel 3
Badge +3
We do have a baby monitor, but the cameras and monitor are nowhere near any Sonos device. We also have a lot of other wireless stuff:
2 Logitech Harmony Hubs
2 ecobee Switch+
1 ecobbe3 thermostat
1 Nanoleaf light panel
2 Rokus
Various other wifi enabled stuffs (phones, tablets, game consoles etc.)
Cordless phone (base is not near any Sonos equipment)

So narrowing it down to a single device might be a little tricky. I can try unplugging the monitor and see what that does.

I find it a bit funny that the two devices that aren't red are Patio and Basement. Patio is not even in our house, it's in our shed which is attached to our house. And the Basement is in a cabinet surrounded by a Roku, Nintendo switch, an AV receiver, and various other equipment. I would have expected those two to have poorer connection than everything else.

Playroom, for example, is the closest device to the Boost. There is one wall separating them, although the Google WIFI hub and a wifi printer are also in between the Boost and the Playroom device. It seems really odd that Playroom is red and Patio and Basement are not.
Basement and patio do have weaker signals. This is about interference, not signal strength
Userlevel 3
Badge +3
If I understand the matrix correctly, the OFDM is interference while the inbound/outbound numbers are signal strength? So if I make some change and the OFDM drops, then I know I'm on the right track?

Also - does the Boost have to be wired in to the main Google WIFI point - the one that is connected to the modem? Or can I connect the Boost to a secondary wifi point?
I think systematic switching off of other wireless systems would probably be instructive. Yes, looking for OFDM ANI to drop.

I note that none of your Sonos devices is acting as the root of the SonosNet mesh. This may not be significant, but can you confirm that the Boost is wired to your primary Google unit, and the primary Google unit is the only device wired to the modem? Boost could be wired to another unit though
You should also experiment with changing the SonosNet wireless channel. Keep the Boost at least a metre from the Google unit.
Userlevel 7
Badge +21
If switching off the devices that use WiFi doesn't help you might move on to suspect other devices, ones that don't have a radio. I have had issues with an external hard drive that even with no radio made so much RF noise it impacted one of my Play 3s.

It might be easier to pick up one Sonos device and move it around, a 2 meter extension cord helps, usually moving a meter or more away from a noise source can be seen on the Matrix.
Good suggestions Stanley.
Userlevel 7
Badge +21
I have a great portable 2.4 GHz RF detector that I wish worked for WiFi level signals and noise sources but it is calibrated for microwave oven leakage levels and isn't very useful for WiFi situations. Does anyone have a link or other suggestion for a usable RF monitor other than the Ubiquity AP built in one?

https://smile.amazon.com/gp/product/B00AMXSEAI/ref=oh_aui_search_detailpage?ie=UTF8&psc=1
Userlevel 3
Badge +3
I thought the point of the Boost was to act as the root of the SonosNet mesh. It is plugged into a switch, which is plugged into the main Google WIFI point. The Boost is about 1 metre from the Google point. The Google WIFI is the only device plugged into my ISP modem.

I have tried changing the SonosNet channel but that doesn't seem to do much. The problem with the Google WIFI is that it selects its own channels automatically, and I cannot see which channel it's currently on. So changing the SonosNet channel might only be a temporary fix.

Thanks for the suggestions John and Stanley - I really appreciate your help.
Looks like the switch is acting as the root. I don't think that matters. The cables from the Google router to the switch to the Boost are still bridging the wifi and SonosNet segments of your LAN.

I look forward to news of the hunt for red interference.

Is that just an unmanaged switch?
Userlevel 7
Badge +21
The root ( a spanning tree protocol thing) doesn't always go to the Boost, in my case it tries to go to one of my antique ZP-80s. It doesn't seem to make much difference to the system operation who wins the cookie.

If you look at the Sonos Mesh, then the Boost can act as the Ethernet to SonosNet WiFi mesh bridge but again it isn't cast in stone. In my case my shiny new Boost is ignored by my Bathroom and Garage Play 1s that instead use one of my wired to Ethernet Play 3s to connect to.

Auto-changing WiFi channels are frustrating, be they yours or close-by neighbors, it is always a pain to stay ahead of them. I have knocked on doors and offered router setup assistance to a few folks around here so we all are as far apart as possible. Other folks are clueless and using channels other than 1, 6 or 11 and making things worse for everyone, while refusing assistance.

I'd think for coexisting with Sonos auto changing hardware would be particularly frustrating. Say you pick the quietest channel for your Sonos, the Sonos goes to sleep mode, the silly auto-changing router sees the quiet channel (only a tiny bit of Sonos data moving) and switches over to it. In that situation picking the second quietest channel for Sonos might actually be the best solution.
Userlevel 3
Badge +3
It would appear that our baby monitor is causing a good chunk of the interference. This is the matrix after unplugging both cameras and turning off the monitor:



From my limited understanding of the matrix, it looks like everything improved.

I also tried unplugging our cordless phone and taking the batteries out of all the handsets, but that had no impact on the matrix - everything was still red.

Unfortunately, it's not feasible to leave the baby monitor cameras unplugged. The cameras are nowhere near any of the Sonos devices so I don't think moving them will help. Do you have any suggestions on how I can deal with this, or is it just something we'll have to live with until we decide we can stop spying on our children?