Google Play music moves to the next track before the end of the previous song

  • 11 January 2019
  • 34 replies
  • 7614 views

Userlevel 1
Sonos Play 1 Amazon Music unlimited works flawlessly, but Google Play music prematurely moves on to the next track before the end of the song. This seems like a lack of compatibility between Sonos and Google Play music. It happens regardless of casting from the Google Play Music app, or from the Sonos App. All other streaming music services operate as expected. Google play music plays back correctly through my Nvidia Shield, Chromecast Audio and other chromecast devices. One of which sits near the Sonos, ruling out network connectivity issues, if the fact that other streaming services work fine wasn't enough to convince you. And of course when not Streaming through the Sonos Google Play Music works as expected on my Samsung S9. So far a bit disappointed with this product and the lack of support for Youtube Music as well.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

I put a support ticket through and there wasn't anything they would / could do for me. So basically the end result was i should use their app to play music on my speakers. I seem to remember them advertising when google play casting was first supported. Anyway, it's a bit frustrating. i'm making do with using the app instead.
I am having the same problem casting from and Android phone to a play 5. This has only been a recent problem, possibly a month. Quite frustrating. I like GPM but may have to cancel the subscription and move to Spotify.
I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and either post the number here, or contact Sonos Support to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
I'm pretty sure that this is no Wifi issue. I have my Playbase connected using the ethernet cable and deactivated Wifi for the Playbase. So it is wired to a rock solid 100 MBit Internet connection.

For me the issue started and now occurs for every track. I started the playback using GPM. Once the playlist was playing I put the phone to flight mode. Two my understanding now only the Sonos Playbase and the Sonos/Google servers should be communicating.

I suggest not to invest time to fix your Wifi. Based on the previous posts it is unlikely to be related to this issue. The time is better spent contacting the Sonos or Google support. Unfortunately my general experience with Google support is very bad if something does not work as intended even for paid services. (e.g. GMail, Google Photos)

My diagnostics are submitted # 484335088

Steve
Badge
Just adding in here that this is still an issue for me, just in case anyone is listening.
edward.peterson, you should do what SteveNes did, and then contact Sonos Support to discuss it. I suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.
They don't even care about us.

/Thread
New to Sonos, out of box I am having this problem. This is the most current thread I can find relevant to my setup. All apps and hardware are current.

Pixel 3 casting GPM stream to Play:1, skips the last bit of the track. And it doesn't matter if I start the stream from within the Sonos app or from the GPM app. Also, it should be noted, when casting, GPM recognizes it is casting, but it will not update the icon as it would for other cast-enabled devices.

Network interference is a tech speak for "not our problem." However, for good measure, I rebooted my router and the Play:1, as seen on other threads. The problem still exists.

Between this issue and not being able to group up with my other non-Sonos devices in Google Home, I am about to pack it up and return it.

I just fixed this on my phone! 

Clear the cache and then clear the storage in the app settings for Google Play Music. 

All of your important data should be backed up on Google's servers so you shouldn't lose anything except for some minor app settings when you clear the storage.

Hope this helps!!