Question

Google Play Music

  • 9 November 2019
  • 19 replies
  • 296 views

All of a sudden whenever I go into the google play music service I get a message saying  

“ play music’s free radio isn't playable on the sonos app . Use play music or play your purchased and uploaded music”

My uploaded play music library now isn't showing yet if i search for an artist I can see my music within google play 

I haven't tried to use play music radio

Is anyone else experiencing this problem ??


19 replies

I am having the same issue when i try to browse directly from the service. “Play Music’s free radio isn’t playable on the sonos app. use Play Music or play your purchased and uploaded music.”. saw that going to Search will still find the specific music but that is a clunky work around.  something definitely changes last night. 

At least i know its not just me then !!!!

I am getting the same message as the people above….what is going on? 

I am having the same problem. When I browse Google Play music I get the message “google play musics free radio isn’t playable on the Sonos app”.

i don’t want free radio, I just want to browse my Google play music!

Any solutions?

Userlevel 1
Badge +2

Same here! I’ve gone into settings and re-authorised my google account but no luck. HELP!!!

I certainly have this same issue, tried reauthorizing on multiple devices, but it doesn’t seem to work, I wonder if this is perhaps an issue with Google rather than with Sonos?

Userlevel 7
Badge +20

Just FYI, working for me (playing from my uploaded library), so it’s not universal.

Nothing currently showing against GPM on the Sonos Status page.

Same here, i can’t  browse my music library uploaded in google play music. 

But i can search for artists to play their albums.

I'm having the same problems and would like it resolved ASAP

I have to search for any music to show up -- searching for an asterisk * shows everything.

I’m going to hazard a guess that since Sonos hasn’t changed their software today, it’s likely an issue on Google’s side. All Sonos does is point the player on the speakers to grab the data from Google.

I'm fairly certain it's a Google problem as my Amazon music works fine

Badge

Same here, I had just updated my Sonos beam to the latest software when the problem occurred wonder if that did it....

I had the issue before updating the software. I hoped updating would fix the problem but it made no difference

Userlevel 1
Badge +2

Mines back working now. 

Mine’s back as well~ magic!

Same here - Result !!

I just noticed the same problem with Sonos not playing Google Play, when it has worked for the last many years. I have removed and re-added the Google Play app to Sonos with no luck. My Google Play app was just updated yesterday. Most likely that is the cause.

For those whose Google Play started working, did you do anything, or did it magically start working on its own?

Any info is appreciated.

Badge

I have had this issue for over a month now and don’t know how to fix it!   I was able to Access my Google Play through the Sonos app at my in-law’s house the other day, though.   So now I suspect it’s got something to do with the way my wireless network is set up.  Any ideas?

Reply