Question

Galaxy s7 problems!

  • 3 March 2017
  • 6 replies
  • 582 views

I know this has previously been discussed but not exactly the same as me. Im fairly confident with tech but not in depth. I have 4 sonos play 1's and have had them set up without a problem for months. My wife and I have all apple devices, phones, ipads and mac book. All worked flawlessley with sonos. I have now got a samsung galaxy s7 and it doesnt work at all with sonos. I have re installed app, turned router on and off, cleared the cache etc. The app still says it cant find my system. Even when it asks me to press the two buttons on top of speaker the app cant find them.

So frustrating as sonos was meant to be basically plug and play, surely the app developed on android should be just as easy as apple.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 6
Badge +16
surely the app developed on android should be just as easy as apple.
Mostly it is. How are your Play:1's connected? Via wifi or via SonosNet? If the latter is the case, you could try connecting your Samsung to SonosNet, instead of wifi, which will give you a better connection.
It usually should be as easy as Apple, or even easier. The fact that the Samsung is asking for button presses means it's not seeing the Sonos devices at all.

Turning the router off and on could be perpetuating an IP address conflict, so I'd suggest you restart all the devices on your network to ensure they all get fresh, unique IPs.

You didn't mention how the PLAY:1s are connected but I'd guess they're in 'Standard Setup', i.e. using your router's WiFi. In that case look at which WiFi band your Samsung's using. If it's the 5GHz one try switching it to 2.4GHz.
Hi thank you for your responses! They are all connected by wifi. Apologies for lack if knowledge again but how do I change the Ghz on my phone?
Is your router dual band? What make/model is it? The 5GHz network ID on some routers is different from the main 2.4GHz one, though some use the same ID for both.

Also, make sure your Samsung hasn't attached itself to a 'guest' WiFi put out by your router.
Hi its the generic sky router. Not sky q hub. So i change the frequency on my router not my phone?

Thank you again
The router's no doubt made by someone else for Sky.

Do the full network restart recommended in post #3, and see if that helps.

Does the router put out more than one network ID?
Can the Samsung be constrained (in WiFi settings/Advanced) to only recognise 2.4GHz networks?