Four out my five Sonos speakers disappear every time I disconnect Ethernet plug

  • 24 February 2017
  • 1 reply

Hi guys,

This is driving me crazy. I have 4 Play:1's and a Connect.

If I have one Play:1 (Nursery) connected via Ethernet to my router (in the guest bedroom) the system works fine. All 5 devices show up play without any dropouts lost connections.

The problem comes in when I want to set up wireless so I can move the Nursery Play:1 to the actual nursery.
If I go through the wireless setup, the controller picks up the wireless network and asks me for the password. After I put in the password it processes a a long time and comes back with the message to "Please check the name and password for your network etc....Try again or use alternative setup"

The weird part is, if I unplug the ethernet cable anyway, all my devices disappear except the Office Play:1 and it works fine (over what I can only assume is the Wifi network of the gods). With the cable plugged in to Nursery, Office is there as well as all the others.

My system was completely Wireless before, I think the problem might have started after a power outage.

I have a Netgear Nighthawk R7000 router connected to a modem connected to adsl internet.

Does anyone have any idea how I can fix this and get my system completely wireless again?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 1
Badge +2
I'm not the expert here, but I think this will work: With the Play1 hardwired, thus seeing the whole system on your controller go into wifi settings and delete the wifi credentials. Then reset wifi up. I'm going out on a limb here, but you CAN have a Sonos system setup as Wifi; and hardwire a portable that you'll occasionally disconnect, Taking the SonosNet down and reverting to Wifi thruout. The reason Sonos prefers you don't do this is the chance a player reboots powering up (as in a firmware update) a player may connect via Wifi before it senses SonosNet. So you're probably best staying all wireless unless advised otherwise.