Error: Unable to play xxxx - the connection to Spotify was lost.


I am receiving an error that sonos is unable to play a song (plays one song then the error comes up) and the connection to Spotify is lost. This seems to have been happening since I did the last Sonos update a few months ago and i have tried reloading Spotify and Sonos and none have worked. Are you able to get this working?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

29 replies

A couple of suggestions for you, McFalconer.

First, try rebooting your router. It's an outside chance, but it's possible that there's an issue there that might be causing this problem. Second, and especially if that doesn't work, please submit a system diagnostic and post the number in this thread. That would give the folks from Sonos a more complete look at the logs of your system, and allow them to provide you a more concrete answer to the issue.
I have rebooted the router and it didn't work, I have submitted the diagnostics report, confirmation number is 7423383
Userlevel 7
Badge +19
Hi there, McFalconer! Thanks for the diagnostic and confirmation number. Check for any updates and see if your connection to Spotify has become a bit more stable.
I have done every update, I have rebooted, I have deleted Sonos and reloaded it, I have deleted Spotify and reloaded it and it still doesn't work. It plays one song and then it stops with the error. I am sick of paying for Spotify and I cant use it properly.
I'd recommend that if you've done the update that he requested, it might be worth submitting another system diagnostic , as he'll need the latest information from your system to continue to help you.
Badge
Hey McFalconer, thanks for following up. We have made a change to your system on our end. Please follow these instructions to run the update. Try playing from Spotify again and you should be good to go. If you continue to experience any problems, submit a new diagnostic within 5 minutes of the error message. Send us the number and we'll be happy to take another look.
We are experiencing the "Unable to play Connection to Spotify was lost" error on our Sonos speaker. Diagnostics reference # is 7506135. Please help.
Userlevel 7
Badge +19
Hello BrewDevil,

You should have an update available. Please apply the update and test the Spotify connection. If we are still having the same issues, reply with another diagnostic confirmation number.
have the same issue!:(
Userlevel 5
Badge +3
have the same issue!:(

Hey pcarno - Welcome to the community. Can you submit a diagnostic and then post the confirmation number here so we can take a look?
Hi @Andy B

i take a lot already with your college's at chat:

Me:
Hi, I having some issue with all my sonos. Since the update the sonos is giving the error code on spotify not encode correctly.
Submit diagnostic 7514710

Sonos:
Hello Arno, thanks for reaching out. It looks like half your system is running in Sonos Net (or BOOST mode) and half is running in wifi mode. The devices that are wired and appear to have the wireless antenna disabled. This is unsupported by Sonos, and you'll need to re-enable the wireless antenna so we can continue troubleshooting.

Me:
Hi Sonos, this is because i having trouble connecting the other speakers if that's enabled, so i like them the use the prefered wifi network. but good i get the point i will enable the wifi on the sonos once again

Sonos:
If you're having issues with the wired players, it could be a different issue. Does it happen when watching TV or listening to music?

me:
Only if listening to music on spotify
No problem What so ever with tv sound
Spotify tracks are Just skimming after 12sec
Skipping

Sonos:
Does this happen on any devices that are connected via Ethernet?
Me:
Yes
I only have one Room with 5.1 surround on ethernet
En Keeps happenings over there

Sonos:
Can you send us a current diagnostic? Also, what is your internet download speed? Thanks.

Me:
I will do this as soon as I got home
Speedtest result 180Mbps down 18Mbps up
18:15

Sonos
Got it Arno. We'll wait for the confirmation number for the diagnostic.

Me:
Sooo since I enabled the wifi again on my Ethernet connected device
My hole setup is not Working any more
Room disapering and so one and one
Not able to play music
I can't even make a diagnostic
After disabling the wireless adapters on the Ethernet connected device.
Everything is Working again
7518658
Excepte for the music still skipping
No issue if not using spotify
Thanks for understanding I need to disable the wireless adapter also I understand Its not supporter but the range from the sonos net is just not good enough
so i found this also:
Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a4IIUaKqGMElZ3rGtuvYlNc?sid=9&flags=8224&sn=1, friendly name: Wild Thoughts, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a4IIUaKqGMElZ3rGtuvYlNc?sid=9&flags=8224&sn=1, ip: , host: , extra info: , http: -1, framer: spotify-nts
[1970-01-01 00:04:06.643] Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a3trg82Eql6tqi2EAxluhy8?sid=9&flags=8224&sn=1, friendly name: Versace On The Floor, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a3trg82Eql6tqi2EAxluhy8?sid=9&flags=8224&sn=1, ip: , host: , extra info: , http: -1, framer: spotify-nts
[1970-01-01 00:04:08.874] Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a4QNpBfC0zvjKqPJcyqBy9W?sid=9&flags=8224&sn=1, friendly name: Give Me Everything, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a4QNpBfC0zvjKqPJcyqBy9W?sid=9&flags=8224&sn=1, ip: , host: , extra info: , http: -1, framer: spotify-nts

Also i noticed that i can get one song to play on spotify!
if i tried any other it will failed soo here are the output if i do this on my system

Works:
1970-01-01 01:35:02.196] [chsnk-as]: reset stream - contained 11996009us
[1970-01-01 01:35:02.221] [chsnk-as]: calling drain on stream w/o pt 0, 1
[1970-01-01 01:35:02.221] [chsnk-as]: reset stream - contained 0us
[1970-01-01 01:35:02.765] [chsnk-as]: reset stream - contained 0us
[1970-01-01 01:35:02.765] [chsnk-as]: setting presentation time 5702.546836
[1970-01-01 01:35:02.771] starting startup delay @5702.138117 by 278 ms
[1970-01-01 01:35:03.049] [hta-chsnk-mixer]: scheduling stream for 5702.546836, now 5702.416394 ba 76992, od 0, t 0
[1970-01-01 01:35:03.050] [chsnk-as]: perfect initial sync 5702.546836, available 76992
[1970-01-01 01:35:03.050] ending startup delay @5702.416598


other songs:
[chsnk-as]: reset stream - contained 11994557us
[1970-01-01 01:35:58.117] [chsnk-as]: calling drain on stream w/o pt 0, 1
[1970-01-01 01:35:58.117] [chsnk-as]: reset stream - contained 0us
[1970-01-01 01:35:58.555] [chsnk-as]: reset stream - contained 0us
[1970-01-01 01:35:58.555] [chsnk-as]: setting presentation time 5758.340691
[1970-01-01 01:35:58.558] starting startup delay @5757.928503 by 283 ms
[1970-01-01 01:35:58.841] waited over expected @5758.211678 by 1 ms
[1970-01-01 01:35:58.841] [hta-chsnk-mixer]: scheduling stream for 5758.340691, now 5758.211791 ba 79616, od 0, t 0
[1970-01-01 01:35:58.841] [chsnk-as]: perfect initial sync 5758.340691, available 79616
[1970-01-01 01:35:58.841] ending startup delay @5758.211972
[1970-01-01 01:36:01.392] Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a4pdPtRcBmOSQDlJ3Fk945m?sid=9&flags=8224&sn=5, friendly name: Let Me Love You, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a4pdPtRcBmOSQDlJ3Fk945m?sid=9&flags=8224&sn=5, ip: , host: , extra info: , http: -1, framer: spotify-nts
[1970-01-01 01:36:04.744] Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a5NsOnvpjvH9sCz8TyVOmOz?sid=9&flags=8224&sn=5, friendly name: Désolé, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a5NsOnvpjvH9sCz8TyVOmOz?sid=9&flags=8224&sn=5, ip: , host: , extra info: , http: -1, framer: spotify-nts

Latested report: 7519094
Hi there,

we have got the same problem, when playing music via spotify it skips after about 2-3 seconds.
An excerpt from the errors from ".../status/dropout_triggered.xml":

[1970-01-01 04:44:58.916] Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a39X4uAMYA6zDru0huLriQP?sid=9&flags=0&sn=5, friendly name: First, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a39X4uAMYA6zDru0huLriQP?sid=9&flags=0&sn=5, ip: , host: , extra info: , http: -1, framer: spotify-nts
[1970-01-01 04:45:02.051] Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a6m70oXSfjcGyi2ne1O7yVN?sid=9&flags=0&sn=5, friendly name: You & Me, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a6m70oXSfjcGyi2ne1O7yVN?sid=9&flags=0&sn=5, ip: , host: , extra info: , http: -1, framer: spotify-nts
[1970-01-01 04:45:07.208] discontinuity detected after scheduled resync: 17113.667583 -> 17113.667584
[1970-01-01 04:45:07.998] Transport error ERROR_CORRUPT_FILE for account type 2311, URI: x-sonos-spotify:spotify%3atrack%3a0Y828fxq3gdkel9rjmqApA?sid=9&flags=0&sn=5, friendly name: Run Rabbit Run, share/server: Spotify, path: x-sonos-spotify:spotify%3atrack%3a0Y828fxq3gdkel9rjmqApA?sid=9&flags=0&sn=5, ip: , host: , extra info: , http: -1, framer: spotify-nts
[1970-01-01 04:45:15.401] NTS: ERROR: CDN server response timed out.


We sent diagnostics under the id: 7538641

Regards
AdviDigi
Hi Sonos folks! I am experiencing this issue with both apple music and spotify, and also having an apple music playlist set on repeat to play overnight randomly stopping playing throughout the night with no error message but will resume if i wake up and hit play again

My diagnostics number is 7539557 - any insight will be greatly appreciated
Userlevel 6
Badge +3
Latested report: 7519094
I see you where is connect with our support team by phone with the ticket number: 170622-002123. If your system is still experiencing the same issue.
The best would be to contact us by phone again and use the same ticket number. We will need to have a deeper look into your router settings.

We sent diagnostics under the id: 7538641
Hello AdviDigi, I also see you already have a ticket for this issue. Best would be to continue with the ticket and let us know how it goes.

Hi Sonos folks! I am experiencing this issue with both apple music and spotify, and also having an apple music playlist set on repeat to play overnight randomly stopping playing throughout the night with no error message but will resume if i wake up and hit play again

My diagnostics number is 7539557 - any insight will be greatly appreciated


Hi Bigshow, in the customer care ticket 170625-000232. I see we've sent you an email asking to check your Sonos WiFi channels. How is your system working today?
If the system is still experiencing the same problem. Please give us a call and use the same ticket. A Sonos agent will be able to review your case and continue the troubleshooting.
Hi support - I have made a bunch of changes to my system and its cutting out less but still happening on occasion - any new info? new diagnostic ticket as of a second ago: 7628673
Userlevel 3
Badge +2
Hello Bigshow5454 it looks like your support ticket was closed due to inactivity. Are you having dropouts more in one room than others?
Hi there - My main floor is actually open concept and has 5 sonos in total in it and thats where I do notice drop outs the most
Hi there,

I am also experiencing the same problem.

My system diagnostic confirmation number is 7689236.

Thank you.
Userlevel 1
Badge +1
Hi there,

I am also experiencing the same problem.

My system diagnostic confirmation number is 7689236.

Thank you.


Hello outrgis, thanks for reaching out. It looks like the diagnostic is reporting version 7.3 installed on your Sonos system and we've since released version 7.4. Does this issue continue after updating to the latest 7.4 software version for Sonos?
I am having the same issue playing from Spotify. Diagnostics conf # is 8078937
Userlevel 7
Badge +19
DawnHalpin: Hello there. What exactly are you experiencing in Spotify? Can you tell us about your local network? What is the make and model of your router? It seems the diagnostic report came back incomplete or corrupt. Would you mind submitting another? Thanks in advance.
Hi Sonos I am also having the same issue with Spotify losing the connection and now can no longer play any music through Spotify it doesn't even complete one song before dropping out. I recently completed a system update and it has only happened this update. Diagnostics # is 8421785
Userlevel 7
Badge +19
Hi there, kylieokeefe. Thanks for posting and for the diagnostic report. It seems to come out incomplete or corrupt. This is normally due to connectivity problems on the network. Your best bet may be to give our support technicians a call to troubleshoot this in real time.
Same problem: Diagnostic is # 180312-002154
I hope you're able to help here, 'cuz the support line only works while I'm in the office.
Can't stay home from work for tech support--can I use another region's support?
You could use the twitter support, I'd bet.

contact Sonos