Answered

Error 900 while adding music library to Synology NAS


Hi

i recently had to replace the hard drive in my Synology NAS and on reconnecting the NAS to the Sonos I got error 900 unable to add music library. 

Both had been working flawlessly before the hard drive replacement.

thanks in advance 

icon

Best answer by jgatie 23 June 2020, 20:38

View original

19 replies

It must be running SMB v1, not v2 or v3.

Hi jgatie,

i’ve checked and its set to Maximum SMB3 and Minimum SMB2, should these be both set to SMB1?

thanks in advance

cheers 

Yes, you must run SMB1.

I am only ever a lurker but I was going nuts: I replaced my Synology 918+ because of a blown mother board. I had never had a minutes problem with the sonos library. Then I could not get it added. Just error 900 ovr and again. I have a Macbook Pro. I then read your comment and found the SMB setting and changed minimum and maximum to SMB1 and VOILÀ.

THANK YOIU

PS. I called support and wasted and hour with them and they were useless. their advice in the end was to call apple because it was an apple problem, which it is not.

The fun thing is that sometimes, not always, a background update to the software running on the NAS can flip SMB v1 back off. Suddenly, Sonos stops working, and it’s a bear to troubleshoot, since generally, you’re not expecting updates to change your settings. 

Hello, I am recently having the same issue with getting an 900 Error when trying to add a music library shared folder to a new Sonos system with a Beam, S2 app, and a new Synology DS120j NAS. I've installed dozens of Synology drives with Sonos in the past and never encountered a problem adding a shared folder in the Music Library settings. 

Could someone elaborate on where these SMB settings are that the previous posts are referring to that fix the problem? Are these Mac or Synology settings? Thank you for your assistance. 

Badge

Hello, I am recently having the same issue with getting an 900 Error when trying to add a music library shared folder to a new Sonos system with a Beam, S2 app, and a new Synology DS120j NAS. I've installed dozens of Synology drives with Sonos in the past and never encountered a problem adding a shared folder in the Music Library settings. 

Could someone elaborate on where these SMB settings are that the previous posts are referring to that fix the problem? Are these Mac or Synology settings? Thank you for your assistance. 

Hi,

So I had the issues with Sonos after updating to Sonos S1, but for the most part the fixes I utilized should also apply to your issue on S2. 

For Synology and Sonos libraries to interact, the SMB settings under the Share need to have the minimum level set to SMB1. Mind you Win 10 will have a fit on setting up a share at SMB1 only, so set the maximum level on the Synology DSM to at least SMB2(SMB3 preferred). This is done under the “File Services” choice in Control Panel. Once on File Services the first tab will be “SMB/AFP/NFS”.

-Make sure SMB is enabled. 

-Click on Advanced Button under SMB settings

-Set Max setting to SMB 2 or above(so windows will still play nice)

-Set Min setting to SMB 1 (So Sonos will work)

-Hit Apply and your Sonos Controller should see the share

(anyone at Sonos listening, could you please add SMB2 support. It’s only been standard since 2011)

Additional Case Sensitivity Issue-

A note of caution, even though I set these things correctly, I fixed the Error 900 issue this way, but then I got Authentication errors(even though no settings were changed). I spent 2 days changing things around, but kept having Sonos error that it would not get connection authentication. I’m an IT Director and live in security day and night in our servers for AD and SSH. So I was scratching my head. I enlisted one of my Tier3 techs for personal reconnaissance. Turns out Sonos S1 is case sensitive for SMB. I have never in all my years seen SMB ever be case sensitive, but alas whoever programmed S1, and most likely S2, made the paths case sensitive for shares. I even called Sonos Tech Support, and even they were unaware of this fact. This obviously was not the case in the Old Sonos Controller, but S1 and S2 revel in case sensitivity. So be very cognizant of case in your paths to your shares. 

Hope this helps you and anyone else going nuts out there. 

Happy Listening

Ericinnj,

Thank you very much for the reply, fantastic information. I will be logging in to the customers system later this afternoon and will make those setting changes. Really appreciate the info. Clarification: so these settings are all in the Synology NAS drive File Services settings, there are no settings that need to be changed on the Windows 10 PC or a Mac correct?  

Sonos support actually responded with a link to this Synology KB article on SMB settings: https://www.synology.com/englobal/knowledgebase/DSM/help/DSM/AdminCenter/file_winmacnfs_win 

I have been installing Sonos with Synology and QNAP NAS drives for years and years and while I have been aware of the case sensitivity requirement when setting the file path from Sonos to the shared folder on the NAS this is the first time I’ve ever encountered the Error 900 issue. 

Thanks again. 

Badge

@sjc51

No problem on the info. To answer your subsequent question, the answer is yes to only needing to configure SMB in Synology.

Mind you Windows Firewall can play havok with tcp at times on a Win 10 pc. So if your still experiencing issues after making the above changes I would take a look at windows firewall settings. If port 445 is closed SMB may be affected to that PC. Not sure if that would cause the error 900 for share mapping in Sonos S1. I haven't tested that to date.

Happy listening 

 

 

 @ericnnj

As per your instructions, changing the file service settings in the Synology Control Panel did the trick. Set the Max limit to SMB3 and the Minimum to SMB1, in the Sonos S2 app I typed in the file path to the shared folder and the Music Library linked up without issue. Didn’t have to adjust any firewall settings. When you first install the Sonos software there is a prompt to configure the Firewall settings of the computer for use with Sonos so that is usually taken care of during the setup process. 

Thanks again, we learn something new everyday! 

 

Spent over 2 hours on the phone with Sonos support, then tried setting the min limit to SMB1 - that fixed the issue.  Wow!

Same here - setting min limit to SMB1 did the trick. Thank you.

Thank you! Worked for me as well!

Awesome, worked for me as well.  You just have to go to the right place and get the right information from the right people.  Thanks For the help

Userlevel 1
Badge

Thanks so much for this info, its been driving me crazy trying to set up SONOS to see a new DS920+

Badge

Wow, enable SMBv1 for sonos. The sonos products are very good, but a security nightmare at all. Not only of the SMBv1 requirement.

sorted, thanks to you all !

Badge +2

Thanks for this! I’ve felt like I was going made trying to get it to connect, glad I found this! Thanks again!

But the big question is, when will Sonos support SMBv2 or 3. SMBv1 has a number of security vulnerabilities that are widely exploited (think of Wannacry and Petya).

Reply