Answered

Error 9 when leaving beta and updating software...please help!


Added a Playbar and Sub to my existing Sonos network last night. Everything went fine as usual, but when making adjustments to the TV and Playbar setting with regards to how they respond to the volume button on my Verizon FiOS remote control, one of the instructions was to go into the Sonos app and adjust the Room Settings. To my surprise when doing so, I discovered that setting is no longer there. After researching online, I learned that the Room Settings option is not available/visible to Sonos users who are in the beta program, and Hat I'd have to leave the beta program and update the software in order to get that option back. So I logged into the Sonos website and left the beta program, but when I tried updating the software, it failed. I tried updating from my PC, my Sonos remote, my iPhone and my iPad and they all failed.

After looking through posts in the Sonos support community, it appears as though this can only be resolved with the help of a Sonos tech.

Please help!

Mike
icon

Best answer by Jeff S 6 December 2016, 18:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

138 replies

Userlevel 7
Badge +20
Hi everyone,

The beta is now complete and you should be able to update to the live version without issue. If you have any trouble, try leaving the beta program. Feel free to message me directly if you need a hand.
Hi Jeff, having the same problem. I'm usually much better about betas and honestly I just didn't read all the instructions. Can you help me out?
Jeff S, having the same issue. Could you please send me the update instructions too?
Userlevel 7
Badge +20
I got the same undocumented error code after leaving the beta program and have spent hours and hours trying to be able to use my 8 SONOS speakers again!!! I will NEVER waste my time with your crappy beta program again if ever I get these things working again. I have tried EVERYTHING A SOFTWARE ENGINEER COULD IMAGINE, including factory resets of ALL speakers (which is real a pain btw) and un/reinstalled all software on my Win10 PC and two Android devices, and my system is DEAD!!! Won't update!!! $3000 down the toilet it seems.

I can't even add one single hard wired speaker to my router w/o the REQUIRED update giving error code 9 and so can't do anything else.

Also, your Android speaker addition logic is crap where you have to run around finding which speaker has the MAC address it want to add, rather than the PC procedure, where you just press the key chord to add the speaker. I can't haul my desktop PC around the house from speaker to speaker, and so would prefer to use the Android. So please fix that most ill thought out scenario as well!!!

Not a happy SONOS user since this is apparently a known problem and there is NOTHING here or on the website that works to actually back out of the beta program, and even that did not work from my PC, and I had to go to the website and do that again!!! Says I'm inactive. And so are my speakers!!!


Hi mushroomhunter,

The beta profile is assigned to your email address. So factory reseting your Sonos system wouldn't help unless you used a different email to register when setting things back up. This beta is different than usual, where it is easy to leave the beta. We'll have to help you do a 2 step update. Please check your inbox for a message from me with some instructions.


Hi Jeff S, can you please send the 2-step update to me too. I followed the same process as mushroomhunter. Thanks!


I can help out. Please check your inbox for a message.
Badge
I got the same undocumented error code after leaving the beta program and have spent hours and hours trying to be able to use my 8 SONOS speakers again!!! I will NEVER waste my time with your crappy beta program again if ever I get these things working again. I have tried EVERYTHING A SOFTWARE ENGINEER COULD IMAGINE, including factory resets of ALL speakers (which is real a pain btw) and un/reinstalled all software on my Win10 PC and two Android devices, and my system is DEAD!!! Won't update!!! $3000 down the toilet it seems.

I can't even add one single hard wired speaker to my router w/o the REQUIRED update giving error code 9 and so can't do anything else.

Also, your Android speaker addition logic is crap where you have to run around finding which speaker has the MAC address it want to add, rather than the PC procedure, where you just press the key chord to add the speaker. I can't haul my desktop PC around the house from speaker to speaker, and so would prefer to use the Android. So please fix that most ill thought out scenario as well!!!

Not a happy SONOS user since this is apparently a known problem and there is NOTHING here or on the website that works to actually back out of the beta program, and even that did not work from my PC, and I had to go to the website and do that again!!! Says I'm inactive. And so are my speakers!!!


Hi mushroomhunter,

The beta profile is assigned to your email address. So factory reseting your Sonos system wouldn't help unless you used a different email to register when setting things back up. This beta is different than usual, where it is easy to leave the beta. We'll have to help you do a 2 step update. Please check your inbox for a message from me with some instructions.


Hi Jeff S, can you please send the 2-step update to me too. I followed the same process as mushroomhunter. Thanks!
Userlevel 7
Badge +20
I got the same undocumented error code after leaving the beta program and have spent hours and hours trying to be able to use my 8 SONOS speakers again!!! I will NEVER waste my time with your crappy beta program again if ever I get these things working again. I have tried EVERYTHING A SOFTWARE ENGINEER COULD IMAGINE, including factory resets of ALL speakers (which is real a pain btw) and un/reinstalled all software on my Win10 PC and two Android devices, and my system is DEAD!!! Won't update!!! $3000 down the toilet it seems.

I can't even add one single hard wired speaker to my router w/o the REQUIRED update giving error code 9 and so can't do anything else.

Also, your Android speaker addition logic is crap where you have to run around finding which speaker has the MAC address it want to add, rather than the PC procedure, where you just press the key chord to add the speaker. I can't haul my desktop PC around the house from speaker to speaker, and so would prefer to use the Android. So please fix that most ill thought out scenario as well!!!

Not a happy SONOS user since this is apparently a known problem and there is NOTHING here or on the website that works to actually back out of the beta program, and even that did not work from my PC, and I had to go to the website and do that again!!! Says I'm inactive. And so are my speakers!!!


Hi mushroomhunter,

The beta profile is assigned to your email address. So factory reseting your Sonos system wouldn't help unless you used a different email to register when setting things back up. This beta is different than usual, where it is easy to leave the beta. We'll have to help you do a 2 step update. Please check your inbox for a message from me with some instructions.
Userlevel 4
Badge +4
Same error code 9 message here after leaving the beta program. Disappointing after such a solid quality experience on both my Play 5 and Play 1.

You volunteered for beta. By definition beta software is unfinished software that you are running in order to uncover problems and bugs. A such, it comes with responsibilities and deficiencies. If you are easily disappointed by unfinished software which may have problems and bugs, and comes with responsibilities and deficiencies, I suggest you do not volunteer for beta in the future.


That is a rather outrageous attitude, since as you call it, unfinsihed software should have been tested to the point where 1) it does not destroy your system, and 2) it is possible to back out and go back to the original non-beta. Get off your high horse...

Pretty sure I didn't ask for your opinion or suggestions!
Userlevel 4
Badge +4
I got the same undocumented error code after leaving the beta program and have spent hours and hours trying to be able to use my 8 SONOS speakers again!!! I will NEVER waste my time with your crappy beta program again if ever I get these things working again. I have tried EVERYTHING A SOFTWARE ENGINEER COULD IMAGINE, including factory resets of ALL speakers (which is real a pain btw) and un/reinstalled all software on my Win10 PC and two Android devices, and my system is DEAD!!! Won't update!!! $3000 down the toilet it seems.

I can't even add one single hard wired speaker to my router w/o the REQUIRED update giving error code 9 and so can't do anything else.

Also, your Android speaker addition logic is crap where you have to run around finding which speaker has the MAC address it want to add, rather than the PC procedure, where you just press the key chord to add the speaker. I can't haul my desktop PC around the house from speaker to speaker, and so would prefer to use the Android. So please fix that most ill thought out scenario as well!!!

Not a happy SONOS user since this is apparently a known problem and there is NOTHING here or on the website that works to actually back out of the beta program, and even that did not work from my PC, and I had to go to the website and do that again!!! Says I'm inactive. And so are my speakers!!!
Badge
I have the same problem. Left the beta program and now getting error code 9. Help!
I have the same problem, Tyringe to leve beta and get errorcode 9 when updating. Please help.
Me too, trying to leave beta but error code 9 preventing me...help Sonos!!!
Userlevel 7
Badge +20
having the same issue - music library stopped working (error 1002 - even when plugged into ethernet and after troubleshooting) so had enough of beta - now getting error 9 over and over. 3x3 & 3x1 - not best pleased

I can help you leave the beta program. Please check your inbox for a private message containing instructions.
having the same issue - music library stopped working (error 1002 - even when plugged into ethernet and after troubleshooting) so had enough of beta - now getting error 9 over and over. 3x3 & 3x1 - not best pleased
Same issue here. What prompted me was a message saying that I needed to Re-Authorize Apple music. Now I have Error code 9 and can't roll back after leaving the Beta.
Oh and there is no tech support on the weekend when I call....
Note, the Sonos rep in this thread is now accepting PMs for this issue:

https://en.community.sonos.com/troubleshooting-228999/unable-to-update-error-9-6760800/index4.html#post16067425
Can someone forward me the instructions to resolve this please without calling them because they are closed today

Not going to do any good. Sonos needs access to your account info.
Can someone forward me the instructions to resolve this please without calling them because they are closed today
Please PM me the solution as well, been on hold for support for 15 mins and still 58th in line. Error code 9 trying to downgrade from the beta. I tried uninstalling the controller after leaving the beta and re installing with no luck
Only eight minutes elapsed from the time that I initiated the call to the time that my system was restored. Ya, I was pretty upset with Sonos because of this debacle, but I must applaud their call center response time today and the ease at getting the problem resolved.
Userlevel 6
Badge +3
This topic has already been answered here Unable to update error 9. Let us know if you have any other questions.
Userlevel 7
Badge +20
Can you send me instructions too please? Am on the phone, 73 in line...spent an hour waiting yesterday too...

Please check your inbox, I'm sending you a message.
Can you send me instructions too please? Am on the phone, 73 in line...spent an hour waiting yesterday too...
Userlevel 7
Badge +20
Hi - same problem. Can I also receive a PM to fix? Thank you

Hi Klewis,

I'm sending you a message now.

Hey jeff, can you send me a pm as well?


Hi jbabcock,

I'm sending you a message with some instructions.
Badge
Hi - same problem. Can I also receive a PM to fix? Thank you

Hi Klewis,

I'm sending you a message now.

Hey jeff, can you send me a pm as well?
Userlevel 7
Badge +20
Hi - same problem. Can I also receive a PM to fix? Thank you

Hi Klewis,

I'm sending you a message now.