Answered

Error 9 when leaving beta and updating software...please help!


Added a Playbar and Sub to my existing Sonos network last night. Everything went fine as usual, but when making adjustments to the TV and Playbar setting with regards to how they respond to the volume button on my Verizon FiOS remote control, one of the instructions was to go into the Sonos app and adjust the Room Settings. To my surprise when doing so, I discovered that setting is no longer there. After researching online, I learned that the Room Settings option is not available/visible to Sonos users who are in the beta program, and Hat I'd have to leave the beta program and update the software in order to get that option back. So I logged into the Sonos website and left the beta program, but when I tried updating the software, it failed. I tried updating from my PC, my Sonos remote, my iPhone and my iPad and they all failed.

After looking through posts in the Sonos support community, it appears as though this can only be resolved with the help of a Sonos tech.

Please help!

Mike
icon

Best answer by Jeff S 6 December 2016, 18:54

Hi everyone,

The beta is now complete and you should be able to update to the live version without issue. If you have any trouble, try leaving the beta program. Feel free to message me directly if you need a hand.
View original

138 replies

Userlevel 7
Badge +25
Hey Mike, I'm sending you a private message to continue.
Ryan... I have exactly the same issue. I followed the instructions at https://sonos.custhelp.com/app/answers/detail/a_id/2978/kw/Leave%20beta#How_to_leave but I get the same error. I too needed access to the room configuration options after a change I made in the room.

Thanks
Userlevel 7
Badge +25
Ryan... I have exactly the same issue. I followed the instructions at https://sonos.custhelp.com/app/answers/detail/a_id/2978/kw/Leave%20beta#How_to_leave but I get the same error. I too needed access to the room configuration options after a change I made in the room.

Thanks


I'll private message you too.
Userlevel 1
I also have this problem. PM me? Or better yet just tell us what to do here so we don't have to wait around?
Userlevel 7
Badge +17
Maybe sonos should come clean about the problems currently going backwards out of beta, Ryan? PMs a bit cloak and dagger ;O)
Hello from France.
Sorry for my english.
my problem :
when i update the beta Sonos version 7.0 to 6.4 ... i have a error : number 9.
have you find a good solution ?
thanks for your help
Maybe sonos should come clean about the problems currently going backwards out of beta, Ryan? PMs a bit cloak and dagger ;O)
Set your suspicions aside. The PMs are to protect the user's confidentiality (email, SonosID, etc).
I have removed myself from the beta. Same error. Code 9. What do I need to do?
Userlevel 7
Badge +21
I have removed myself from the beta. Same error. Code 9. What do I need to do?

I'd PM Ryan S above with your e-mail address used to register your Sonos
I have removed myself from the beta. Same error. Code 9. What do I need to do?

I'd PM Ryan S above with your e-mail address used to register your Sonos



Thanks. I will.
Dear Ryan s,
Im having the same problems as listed above. I have two play:1 to start and I'm planning on expanding my "empire".

Could you please help me. The play ones are 7.0
And I've left the beta but I can't update
It always says error 9. I tried it on my mac and iPhone.

Regards,
A.w.
Ryan,
I am having the exact error as above. Can you please post the fix for everyone

Thanks
Jon
Same Problem :-/

Ryan can you help me ? Us ?

Someone already succed to downgrade thanks to Ryan help in PM ? Is it fast and easy ?

Thank you, from France
Hello. Same issue (code 9) due to an attempt to leave beta program. Could you help me please.
Hello!
I have the same problem as you guys. Anyone know how to solve this?
/ Abel
Same problem here. First and last sonos product ill ever buy. Ive currently got a $200 brick
Hello. Same issue (code 9) due to an attempt to leave beta program.Please, help me please.
Userlevel 7
Badge +17
Blimey is this the worse beta chaos ever!!
can't iOS devices be barred from beta?

might as well bump all these to the top 😛
Same problem for me, diagnostic id 6790613.

Can you please help me by PM ? Or I have to call French support team by phone ?

Vincent, from France
Call support. They need access to your account info, so it must be done via phone or PM, and the forum support team is not usually available on weekends.
thanks
Same Problem with my Play:1 - This isn't iOS specific, the desktop client on my MacBook Pro gives the same error.
Some issue encountered here. 3 Play 1's and one Play 3.
I'm having the same issue 😞
Help please 😞 6 play ones, play 5, sound bar and sub all playing up after beta download and attempted rollback

Reply