Question

Error 1002 with Spotify

  • 19 December 2016
  • 8 replies
  • 484 views

Badge
I entered this a few days ago on another (older) thread, but I assume that it got buried due to the age of that thread. I've done a lot of research and troubleshooting, but can't seem to get this fixed.

I've submitted a diagnostic with the confirmation number 6873177. I am getting the 1002 error when trying to load all of my Spotify tracks (approximately 5200). This is a recent but consistent occurrence. I can load all of my music on my local hard drive (~14,700 tracks), and all of my Amazon music (~500 tracks), but Spotify consistently gives me the error. Initially, it would give me the error but work on the 2nd try, but even that stopped in the last few days.

I have removed and re-added my Spotify account to my controller, but continue to get the error. Adding a single album from Spotify works fine.

I've changed the wireless channel on my router to 6 so that it is different than the SonosNet channel (11). Did not make a difference.

This happens from both my iPhone and my Windows 10 machine. It happens when I select "play all" or "shuffle" for all tracks.

On the Win 10 controller, I can select the first song, scroll all the way to the bottom and control-select the last song and drag all ~5200 songs to the queue. That seems to work, but it's painfully slow and not possible to do from the iPhone. I control my Sonos system 95% of the time from my iPhone.

Thanks for your help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Badge
Thanks - I was out of town for the holiday but will call this week.
Userlevel 7
Badge +20
Thank for the reply, Jeff. Initially, both my home wifi and Sonos setup were on channel 11 (I purchased my first Sonos speakers in April, so this setup worked for over 7 months).

After submitting my first diagnostic last week, I changed my wifi channel from 11 to 6, keeping Sonos on 11. This did not fix the problem. I have just changed the Sonos channel from 11 to 1, but still having the same issue. I'm submitted another diagnostic - 6896546.

Please help - this is getting very frustrating. I am a true Sonos fan and have just bought over $1300 worth of speakers for Christmas gifts, so I REALLY want/need to get this resolved!

One thing that has occurred to me - this never happened prior to linking my Sonos and Spotify accounts and signing up for the beta to test the Spotify direct output to Sonos. Am I really the only one having this issue?

Thanks,
Mike


Hi Mike,

Since changing the wireless channel didn't help it would be best to work with our phone team to get this sorted out. Please give us a call and reference case number: 161221-001834. Our phone number can be found here.
Badge
Thank for the reply, Jeff. Initially, both my home wifi and Sonos setup were on channel 11 (I purchased my first Sonos speakers in April, so this setup worked for over 7 months).

After submitting my first diagnostic last week, I changed my wifi channel from 11 to 6, keeping Sonos on 11. This did not fix the problem. I have just changed the Sonos channel from 11 to 1, but still having the same issue. I'm submitted another diagnostic - 6896546.

Please help - this is getting very frustrating. I am a true Sonos fan and have just bought over $1300 worth of speakers for Christmas gifts, so I REALLY want/need to get this resolved!

One thing that has occurred to me - this never happened prior to linking my Sonos and Spotify accounts and signing up for the beta to test the Spotify direct output to Sonos. Am I really the only one having this issue?

Thanks,
Mike
Userlevel 7
Badge +20
I did on Friday, as noted in my first post. That was diagnostic 6873177. I just re-created the problem and submitted diagnostic 6889711.

Hi Ylenroc,

There are some wireless communication errors showing up which might explain the error you're getting. Please try changing the wireless channel your Sonos system is using.
Badge
I did on Friday, as noted in my first post. That was diagnostic 6873177. I just re-created the problem and submitted diagnostic 6889711.
No, all standard DNS

Next time it happens, I would submit a diagnostic and contact Sonos support with the reference number, with by posting it here or via phone/email.
Badge
No, all standard DNS
Are you running any kind of non-standard DNS proxy? Spotify tends to have timeout issues with some DNS proxy settings, especially those used for geo-spoofing.