Question

ER Lite with Cisco Wave (2702i) - Sonos surround (2* play 1) not connecting to playbar

  • 12 December 2017
  • 0 replies
  • 240 views

ER Lite with Cisco Wave (2702i) - Sonos surround (2* play 1) not connecting to playbar [ Edited ]
Options
2 weeks ago - last edited 7m ago

Hello Guys,

I am posting this thread because after sevral days of research I was not able to find a solution.

My problem is that at the end of the Sonos Surround setup, there is a last configuration step to makes the all system working together. This last step is my problem because I obtain an error:

https://ibb.co/nrr5vG

and then the error Step:

https://ibb.co/bN9KNw

My setup is the following:

ER Lite 3:

ETH0: connected to a POE switch for LAN access (everything is on the same subnet)
ETH1: WAN
ETH2: Free (nothing connected)

Switch Dlink POE 8 ports fro the LAN (connected to ERLite ETH0):
PC, ISP TV, NAS, Cisco 2702i (Wifi Access Point), again: everything is on the same subnet.

Cisco 2702i (Wifi Access Point):

5Ghz: For Mac, Cell phone, etc...
2,4Ghz: dedicated to sonos surrounds and playbar

Here is my config ERLite config:
firewall {
all-ping enable
broadcast-ping disable
ipv6-receive-redirects disable
ipv6-src-route disable
ip-src-route disable
log-martians enable
name WAN_IN {
default-action drop
description "packets from Internet to LAN"
enable-default-log
rule 20 {
action accept
description "allow established sessions"
log disable
protocol all
state {
established enable
invalid disable
new disable
related enable
}
}
rule 30 {
action drop
description "drop invalid state"
log disable
protocol all
state {
established disable
invalid enable
new disable
related disable
}
}
}
name WAN_LOCAL {
default-action drop
description "packets from Internet to the router"
rule 1 {
action accept
description "allow established session to the router"
log disable
protocol all
state {
established enable
invalid disable
new disable
related enable
}
}
rule 2 {
action drop
description "drop invalid state"
log disable
protocol all
state {
established disable
invalid enable
new disable
related disable
}
}
}
name WAN_OUT {
default-action accept
description ""
}
receive-redirects disable
send-redirects enable
source-validation disable
syn-cookies enable
}
interfaces {
ethernet eth0 {
address 192.168.0.1/24
description LAN-ET-TV
duplex auto
speed auto
}
ethernet eth1 {
description Internet_ONT
duplex auto
speed auto
vif 832 {
address dhcp
description "Internet Orange DHCP"
dhcp-options {
client-option "send vendor-class-identifier "sagem";"
client-option "send user-class "+FSVDSL_livebox.Internet.softathome.Livebox3";"
client-option "send rfc3118-auth 00:00:00:00:00:00:00:00:;"
client-option "request dhcp-lease-time, dhcp-renewal-time, dhcp-rebinding-time, domain-search, rfc3118-auth, SIP;"
default-route update
default-route-distance 210
name-server update
}
egress-qos "0:0 1:1 2:2 3:3 4:4 5:5 6:6 7:7"
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
out {
name WAN_OUT
}
}
}
vif 838 {
address dhcp
description "VLAN TV VOD"
dhcp-options {
client-option "send vendor-class-identifier "sagem";"
client-option "send dhcp-client-identifier 1:78:94:B4:E0:1E:D8;"
client-option "send user-class "\047FSVDSL_livebox.MLTV.softathome.Livebox3";"
client-option "request subnet-mask, rfc3442-classless-static-routes;"
default-route update
default-route-distance 210
name-server update
}
egress-qos "0:4 1:4 2:4 3:4 4:4 5:4 6:4 7:4"
}
vif 840 {
address 192.168.255.254/24
description "VLAN TV Canal 1 - Zap"
egress-qos "0:5 1:5 2:5 3:5 4:5 5:5 6:5 7:5"
}
}
ethernet eth2 {
description LAN2-LiveBox
duplex auto
speed auto
vif 832 {
address 192.168.2.254/24
description VoIp
}
}
loopback lo {
}
}
port-forward {
auto-firewall enable
hairpin-nat disable
lan-interface eth0
rule 1 {
description FTPES-QNAP-CONTROL
forward-to {
address 192.168.0.92
port 21003
}
original-port 21003
protocol tcp_udp
}
rule 2 {
description FTPES-QNAP-DATA
forward-to {
address 192.168.0.92
port 21004-21023
}
original-port 21004-21023
protocol tcp_udp
}
rule 3 {
description Transmission-QNAP
forward-to {
address 192.168.0.92
port 49091
}
original-port 49091
protocol tcp_udp
}
rule 4 {
description Plex-Server
forward-to {
address 192.168.0.92
port 32400
}
original-port 14377
protocol tcp_udp
}
wan-interface eth1.832
}
protocols {
igmp-proxy {
disable-quickleave
interface eth0 {
alt-subnet 0.0.0.0/0
role downstream
threshold 1
}
interface eth1.840 {
alt-subnet 0.0.0.0/0
role upstream
threshold 1
}
interface eth2 {
role disabled
threshold 1
}
}
}
service {
dhcp-server {
disabled false
global-parameters "option rfc3118-auth code 90 = string;"
global-parameters "option SIP code 120 = string;"
hostfile-update disable
shared-network-name LOCAL_NETWORK {
authoritative enable
subnet 192.168.0.0/24 {
default-router 192.168.0.1
dns-server 8.8.8.8
dns-server 8.8.4.4
lease 86400
start 192.168.0.10 {
stop 192.168.0.99
}
static-mapping Cisco_AP {
ip-address 192.168.0.29
mac-address 50:87:89:a9:42:34
}
static-mapping GTX-Barichon {
ip-address 192.168.0.97
mac-address 2c:56:dc:97:fd:7f
}
static-mapping GTX-Barichon-WiFi {
ip-address 192.168.0.31
mac-address 30:52:cb:53:61:61
}
static-mapping Home {
ip-address 192.168.0.92
mac-address 00:08:9b:f6:bd:e2
}
static-mapping Mac-Akamai {
ip-address 192.168.0.19
mac-address a0:99:9b:13:f6:3d
}
static-mapping Mac-Maison {
ip-address 192.168.0.98
mac-address 6c:40:08:a2:1f:c4
}
static-mapping Rear-Left {
ip-address 192.168.0.34
mac-address b8:e9:37:ed:e1:e4
}
static-mapping Rear-Right {
ip-address 192.168.0.35
mac-address b8:e9:37:ed:e1:ca
}
static-mapping Samsung-Galaxy-S7 {
ip-address 192.168.0.99
mac-address 8c:f5:a3:05:a3:e3
}
static-mapping SonosZP {
ip-address 192.168.0.21
mac-address 00:0e:58:b5:fd:9a
}
static-mapping iPhone-boubou {
ip-address 192.168.0.20
mac-address c0🇨🇨f8:f0:e8:ce
}
static-mapping ubuntu_QNAP {
ip-address 192.168.0.33
mac-address 02:00:00:f8:89:99
}
}
}
shared-network-name Livebox {
authoritative enable
subnet 192.168.2.0/24 {
default-router 192.168.2.254
dns-server 80.10.246.136
dns-server 81.253.149.6
lease 86400
start 192.168.2.21 {
stop 192.168.2.200
}
static-mapping Livebox {
ip-address 192.168.2.1
mac-address 78:94:B4:E0:1E:D8
}
subnet-parameters "option rfc3118-auth 00:00:00:00:00:00:00:00:00:00:00:********;"
subnet-parameters "option SIP *******;"
}
}
use-dnsmasq disable
}
dns {
forwarding {
cache-size 1000
listen-on eth2
listen-on eth0
}
}
mdns {
reflector
}
nat {
rule 5010 {
description "Masquerading outgoing connections"
log disable
outbound-interface eth1.832
protocol all
type masquerade
}
rule 5011 {
description "Masquerading TV"
log disable
outbound-interface eth1.838
protocol all
type masquerade
}
}
ssh {
allow-root
port 22
protocol-version v2
}
unms {
disable
}
upnp {
listen-on eth0 {
outbound-interface eth0
}
}
upnp2 {
listen-on eth0
nat-pmp enable
secure-mode disable
wan eth1
}
}
system {
config-management {
commit-revisions 5
}
conntrack {
expect-table-size 4096
hash-size 4096
table-size 32768
tcp {
half-open-connections 512
loose disable
max-retrans 3
}
}
name-server 8.8.8.8
name-server 8.8.4.4
offload {
hwnat disable
ipsec enable
ipv4 {
forwarding enable
pppoe enable
vlan enable
}
ipv6 {
forwarding enable
}
}
My Cisco 2702i AP config:

hostname CISCO_AP
!
aaa new-model
!
dot11 pause-time 100
dot11 syslog
!
dot11 ssid Pik4-Fast=
vlan 1
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii 7 *******
!
dot11 ssid Pik4-Low=
vlan 2
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii 7 ********
!
!
!
no ipv6 cef
!
username Cisco password 7 *******
!
!
ip ftp username ******
ip ftp password 7 ******
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm tkip
!
encryption vlan 2 mode ciphers aes-ccm
!
ssid Pik4-Low=
!
antenna gain 0
stbc
speed basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
station-role root
world-mode dot11d country-code FR indoor
!
interface Dot11Radio0.1
encapsulation dot1Q 2 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
shutdown
!
encryption mode ciphers aes-ccm tkip
!
encryption vlan 1 mode ciphers aes-ccm
!
ssid Pik4-Fast=
!
antenna gain 0
peakdetect
no dfs band block
stbc
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23. a1ss9 a2ss9 a3ss9
channel width 80
channel dfs
station-role root
no dot11 extension aironet
world-mode dot11d country-code FR both
!
interface Dot11Radio1.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface GigabitEthernet1
no ip address
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
mac-address 5087.89a9.4234
ip address dhcp client-id GigabitEthernet0
no ip route-cache
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
bridge 1 route ip
!
end

Any kind support would be very appreciated.

P.S: No problem when connecting the surrounds wired to my Dlink switch...

Thanks by advance,

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.