eero setup hints

  • 19 March 2016
  • 24 replies
  • 12369 views

Badge
Just thought I'd post this up here as I've troubleshooted my configuration and I think I finally figured out what my issue was.

I have an eero wifi mesh system (3 eeros for what it's worth), and Sonos boost, Sonos connect:amp and some play:5's, as well as an ethernet switch next to my router.

My problem had been that on wifi (the eero) initially, I had been able to connect but my iOS controllers would lose their connection to the Sonos network (while wifi in general was still fine).

The first thing I did was to set my modem to passthrough mode, and let the eero do all the router work. At this point my system had a configuration of:
modem-to-switch
switch-to-eeros

I was still experiencing connection issues, and purchased a Boost. I could not get the Boost to be recognized at all by the eero network when the Boost was connected to the switch at all.

Finally (duh) figured out to put one of my eeros as:
modem-to-eeros-to-switch

And connecting the Boost to the switch recognized instantly (and fingers crossed, no drop outs yet for scenarios that were easy to reproduce previously).

Anyways, hope this helps somebody (I should have figured this out initially I guess! I thought that the eeros system off the switch would have handled everything ok; but the Boost just needed to be behind the eero all the time)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

24 replies

The eeros include NAT routing. In the configuration where the BOOST was wired 'upstream' of the first eero it would have been on the public side, i.e. not on the local network.

The second arrangement put the switch -- and hence the BOOST -- on the LAN subnet, along with the iDevices.
Hi,
I am having trouble and it seems like you guys figured it out, but your answers are too advanced for my lack of knowledge. I have a sonos system using a boost. I had an all in one modem/wireless router by time warner cable. I was able to turn off the wireless function and add the eero system mesh (two up now). The sonos controllers on my laptop, phone and sonos controller cannot find the system. Can you walk me through your fix and what you wired to what? Much obliged.
If the BOOST is wired to the cable router, put the eeros into bridge mode:
https://support.eero.com/hc/en-us/articles/208276903-How-do-I-bridge-my-eeros-

Alternatively, wire the BOOST to one of the eeros.

In either case change the SonosNet channel to 11, in Advanced Settings.
thank you! all is working just by changing the order of the wiring as you suggested.
The eeros include NAT routing. In the configuration where the BOOST was wired 'upstream' of the first eero it would have been on the public side, i.e. not on the local network.

The second arrangement put the switch -- and hence the BOOST -- on the LAN subnet, along with the iDevices.


I've been having issues with Eero and Sonos as well. I've currently got Sonos set up over wifi but rooms keep dropping out. I was thinking of getting a Boost to help with this but wanted to be sure I had the proper setup/configuration.

I was going to wire the Boost to one of the Eero access point (does it matter which one? Does it have to be the Eero that is wired directly to the cable modem?). I was then going to change the SonosNet channel to 11. Am I missing anything?

Thanks in advance for your help!
I was going to wire the Boost to one of the Eero access point (does it matter which one? Does it have to be the Eero that is wired directly to the cable modem?).
I don't believe it matters.

I was then going to change the SonosNet channel to 11. Am I missing anything?

Unknown unknowns! Try it and see.
Hello everyone--

I'm sure I'll get on your nerves a bit with the following but I currently have 1 eero (testing before I commit to more) connected to main modem and 3 Sonos speakers and the drop off have been happening since the beginning (over a month now). I keep reading above about different configurations and changing the SonosNet but my Sonos speakers are connected directly to Wi-Fi. I don't have the SonosNet set up. Later today I'll try to set the modem to modem-to-eeros-to-switch eventhough I'm not sure if I'm supposed to that on the mode itself or the eero. I haven't seen those type of setting on my eero so I'll have a look at the modem's settings.

Let me know if you head anything new about this issue or if other mesh network devices are better at playing with Sonos toys.

Many thanks everyone!


Marcin
dohigley answered this in another thread and his solution worked for me:

Here's the fix - which was sorted out by Sonos not Eero (even though it's an Eero issue). We used my old router (but disabled the wifi) and set Eero in bridge mode (network settings/advance settings/DHCP & NAT/[select]Bridge. So from a set up standpoint it goes modem to old router and old router to Eero in bridge mode. Once we did this everything worked. Eero has done multiple upgrades and I tried to go direct just last weekend (i.e., modem to Eero and removing old router) and Sonos no longer worked. Internet was also intermittent as well so there were other problems that Eero has not fixed with the modem. Hope that helps!
Userlevel 2
So I have the SONOS / BOOST/ EERO combo as well. I would be careful putting the EERO in bridge mode. I experienced weird issues with various eeros dropping out (turning red in the app) and reconnecting periodically - very strange. Eero support mentioned that some people were experiencing this and they recommended auto mode so ymmv. With bridging I would have a SONOS speaker drop out of the list sometimes or stop being responsive (keep playing but unable to connect to it).

I switched to a similar config mentioned above except I have a dedicated firewall computer (running pfsense) and several subnets. I put the main EERO between my firewall and switch for my home subnet and let EERO provide the DHCP for my home subnet. The BOOST is plugged into that so gets the EEROs dhcp.

Things seem to work better after that for the most part - it's a "double-nat" configuration which is not ideal but workable.. I now sometimes have issues with the SONOS app grouping failing to include all devices I select. This could be an issue with my phones WIFI connection though. If you let EERO provide the subnet then you get some cool features like profiles.
Userlevel 2
Badge
Seems as though the Eero may have a NAT table limitation, or maybe a sessions limitation of some sort, just a guess.
Userlevel 2
Yeah I'm not thinking it's SONOS either - the new element in my topology is the eero. I suspect their routing engine may need some work to properly handle things like bridging (even though it's supposed to) and weird configurations / lots of devices. I was able to mostly resolve the issue by relocating some of my devices like my slingboxes from the eero double-natted "subnet" to a different subnet and eliminating a switch. I can't complain about the wifi speed - seems decent and no deadspots around the house. My nexus 6 does have issues here and there- been using decaf monitor app to check connection to the main eero while connected wirelessly - getting some failures. This does not happen on my android tablet (2013 Nexus 7) running the same app.

Bottom line if you have a slightly complex setup you need to be aware that there may be issues...
So, I need to be in bridge mode with EERO in order for Sonos to function? I am doing that and Sonos is fine. I lose some EERO functionality with this set up but I don't follow any of the other recommended set ups above besides the easy one of simply toggling Bridge setting on (sorry). Let me know if anyone has a clear alternative to offer. Many thanks!
Userlevel 2
I had trouble with Bridge mode - my 2 wired eeros (I have 4 total) kept cycling from online to offline. Support suggested I use NAT (double NAT actually). I also "simplifyied" my home subnet a bit by removing unnecessary devices switches etc. Things are working and I have the extra controls like profiles so all good for now. Note: I have a PSense firewall in front and several subnets including my home subnet. The firewall provides DHCP services which the main eero uses as it's "WAN" connection and then has it's own NAT if that makes any sense. I don't know if this has improved since their firmware update but I like the control I get so am currently sticking with the NAT setup.
Thanks erktrek, I'll experiment with that configuration
So, I need to be in bridge mode with EERO in order for Sonos to function? I am doing that and Sonos is fine. I lose some EERO functionality with this set up but I don't follow any of the other recommended set ups above besides the easy one of simply toggling Bridge setting on (sorry). Let me know if anyone has a clear alternative to offer. Many thanks!

I have same issue and work around. But eero bridge mode disables desired eero functionality. Wish the could get this resolve. Otherwise I really enjoy both products. If others know of a non-bridge solution I would love to learn about it.
Hoping someone can help here. My configuration is:
Cable Modem > Eero > Boost > 2 Sonos Play 3 speakers. I also have 3 additional Sonos Connects, two of which are wired to switches that connect to the Eero, and have two additional Eeros. I am experiencing repeated drop outs. I don't want to put my Eero in pass-through mode as I understand that doing so means I lose some of the "mesh-y" features of the three Eeros working together.

Is there anything I can do? If not, is there a different mesh access point product that "play well with others", in particular Sonos, more than the Eero?

Last, as I am not a techie, is there anyone that can provide either remote or on-site support, as Sonos support seems not to be very helpful. I live in the San Francisco Bay Area. Thanks in advance
I had a Sonos system (3 Connect amps) that was fine until I replaced my Airport Extreme with 3 euros. Couldn't get anything to connect. Didn't want to fiddle with bridging my cable modem or my eero. Got a Boost which I plugged into the main eero and presto, everything works just fine.
I was having similar problems right after I installed eero. What I ended up doing was turning off eero plus advanced security feature (Network Settings | Network Security), restarted all Sonos hardware and everything worked perfectly again.

You can judge me to choose entertainment over security, but I need my Sonos to work. Plus, I save the eero plus subscription fee.
I was having similar problems right after I installed eero. What I ended up doing was turning off eero plus advanced security feature (Network Settings | Network Security), restarted all Sonos hardware and everything worked perfectly again.


I'm curious about this configuration. Did an install with a few issues on the exitsting network side (Verizon Fios wifi crashing etc) We used an eero 2nd gen as a router and wifi and extended with the existing Pakedge WK-1 Access point. The eero helped us to have remote visibility of the network via the app to see what was going on. Found out that in addition to the Verizon having issues that there were a few back connections causing loopbacks and broadcast storms. On the Sonos Side they were set up as Boost and wifi connections. We set up the 4 Connect Amps and a playbar (1 near the router and the others in the family room cabinet or under the TV) with direct ethernet connections then disabled wifi on these units. We were having issues with the wifi in these areas do to RF saturations and this resolved that issue. The other 10 assorted playbars, Subs, and Play3 and 5s all work fine after this. No other issues with the eero so I am surprised that you were having them and I'm curious what you have and how it is connected.

Just as a side note I have sold and installed eero from a distribution and installation standpoint and have set up systems sonos, heos, Russound, Apple product and other media players and they have all worked flawlessly out of the box over eero, pakedge, luxul and trendnet networking devices (routers, switches and WAPs)
Here are my notes from the install.
Verizon modem bridged, Eero set up as a router to manage the network. Simplified wired connections to switches.
First eero connected to modem and a 5 port gigabit switch.
Added Connect Amp same location hardwired to switch and disabled wireless.
Added 3 connect Amps, a playbar and apple TV to living room cabinet via switch and link connections disabled wireless for all but one Connect Amp (reducing wireless coupling that was causing issues originally.
Added 2 playbars, sub, and 5 various play3 and play5s wirelessly using wifi.
Everything working and playing nice. Have been checking in on the system via the eero app and everything is online with no dropouts. Client is very happy.

As a side note: this client had taken to connecting extra cables that were either not terminated or would loop back to switches. This caused most of their issues.
@EdTech10
My configuration is very simple.
Comcast coming into a Arris Surfboard.
Arris Surfboard connected to a TP-Link Switch.
TP-Link Switch connected to Eero (2nd generation). We have a total of 3 placed throughout the house.
Sonos: 2 Playbars, 2 subs, 2 Play1 and 1 Play3.
What worked for me was hardwiring one of the Connect's into the network even though I have a Boost in the system. Now I just have to get Sonos and ESET to play nice together...
So...I've tried Router > eero > switch > Boost, and Router > eero > Boost (with Router also going to Switch). Have also tried changing CH 6 to 11. No joy 😞
I was having similar problems right after I installed eero. What I ended up doing was turning off eero plus advanced security feature (Network Settings | Network Security), restarted all Sonos hardware and everything worked perfectly again.

You can judge me to choose entertainment over security, but I need my Sonos to work. Plus, I save the eero plus subscription fee.
Thank you! Yes, that was exactly my issue! Disabling the Eero Plus service fixed the issue immediately.