Answered

Echo with sound-bar and one

  • 31 October 2019
  • 87 replies
  • 7033 views

I am having an “echo” sound coming from my Sonos One speakers that are in surround sound mode with my sound bar. I have them grouped and they have been this way for a long time, I have done a truesound calibration a couple times, it will sound good for a day or two and then I notice an echo coming from the One speakers again. Can someone help me, please?!?!

icon

Best answer by Ryan S 19 November 2019, 22:41

We’re still working on this issue, it’s being investigated and as soon as a fix is ready to go we’ll let everyone know. For now, using the home theater device as the first in the group will work while we get this resolved.

 

Edit: For clarity, this means play music first to your home theater player, such as a Playbar or Beam, and after the music is playing, use the Sonos app or press and hold the play/pause on your other speakers to group them together. If the home theater speaker is the group coordinator, the first one in the group, the echo won’t start up with music playback.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

87 replies

Userlevel 7
Badge +26

We’re still working on this issue, it’s being investigated and as soon as a fix is ready to go we’ll let everyone know. For now, using the home theater device as the first in the group will work while we get this resolved.

 

Edit: For clarity, this means play music first to your home theater player, such as a Playbar or Beam, and after the music is playing, use the Sonos app or press and hold the play/pause on your other speakers to group them together. If the home theater speaker is the group coordinator, the first one in the group, the echo won’t start up with music playback.

Badge

My Sonos system is setup with a Playbar, two Sonos Play:1s in my living room, a Sonos 5 in the adjacent dining room/kitchen area and a Sonos One in my bedroom. Recently I’ve noticed that the sound in my living room area gets out of sync. When I pause the music and re-start it, the echo goes away. This almost definitely comes from the Playbar and Play 1 pair getting out of sync.

Diagnostic #: 656172140

The “specific issue” exactly as described in the very first post in this thread is:

”I am having an “echo” sound coming from my Sonos One speakers that are in surround sound mode with my sound bar. I have them grouped and they have been this way for a long time, I have done a truesound calibration a couple times, it will sound good for a day or two and then I notice an echo coming from the One speakers again. Can someone help me, please?!?!”

This is exactly the problem I’m having, except I have Play1’s as surrounds vs. Ones. 

I’ve reached out to support several times and the problem remains.  I will give that another try since I am finding no real solutions here.  Hope your engineers can resolve this.  Clearly there is a problem, and clearly I am not the only one affected. 

Exactly same problem here, has only arisen over the last month or so after being perfect for years before. 

 

Playbar, sub, 2x play 1s, grouped together as the 5.1 setup. TV playback is faultless, it's just music that is the problem. 

 

https://en.community.sonos.com/ask-a-question-228987/playbar-two-play-1s-sync-issue-6832152#post16373325

 

I seem to be having the same issue. The echo starts up, but can be fixed by pausing but then comes along a bit later. When playing music the surrounds go out of sync. It’s pretty bad. 
My system (playbar plus 2 ones) has been fine for months. These problems seem to have started after installing a new router and then having to reconnect all speakers. 
I’ll post a diagnostic next time it happens. 
 

Ryan,

Do you have an update and timeline for this?

The first post is already a month old and I think everyone here expects finally a solution for this problem.


We all paid a lot of money and expect a solid sound system.

If this is not already classified as highest priority on the bug fix list it should go straight to the top since this has a major impact on the enjoyment of the Sonos system. 
 

Thanks,

Pete

This morning, my Playbar and the “surround” Play:1 speakers started falling out of sync, creating an echo effect.  The difference is noticeable after about 15 minutes or so and gets worse as time goes on.  Stopping and then restarting the audio fixes the problem for the moment, but the sync problem once again is quite noticeable after about 15 minutes.

I submitted diagnostics, confirmation 1806934340.

 

Thanks.

I have tried the suggested temporary fix, start with the Beam and surround first and then add other groups and it seems to be working. No more echo for now. Now waiting for a proper fix from Sonos, @Ryan S please keep us posted! Thanks!

Userlevel 7
Badge +26

There’s an update today, Sonos version 10.6.1, which has some improvements made which should correct this issue. When you have a moment, check for updates (if your system doesn’t update automatically) and you can test this out. We’re still monitoring the issue to make sure these changes have resolved it, so please let us know if you’re still seeing any trouble with playing music on home theater Sonos speakers and grouped rooms.

Having the same problem, it sounds to me that the soundbar is slightly behind the surround speakers causing that echo. When I remove the “theater” group from the rest of the grouped speakers and add it back it fixes it for a few songs and than the echo appears again. I will try the suggested workaround tonight. 

Sonos state they are looking into the matter and hopefully it will be fixed soon. 👍

As previously explained:

We have a soundbar and three one satellites

One satellite is configured as standalone the others are configured as surround.

The echo returns each half day averaged.

Reset by on / off is just a temporary solution and becoming really annoying for system in this price class.

 

Userlevel 7
Badge +26

That’s correct, AjTrek1. However, there may be a specific issue that we’re looking into where sometimes the two are slightly out of sync. The diagnostic will let me know if that’s what we’re seeing here.

Userlevel 7
Badge +26

Hi @mbeemsterboer, I merged your thread to this one as I suspect you might be experiencing the same issues. Your diagnostic shows that you are seeing something that’s currently being worked on by the team. To prevent this echo from coming up, you should be able to group your devices with the Playbar as the main speaker instead. To do this, when you press “group”, do so on the Playbar’s line, not any other rooms. That sets the Playbar as the coordinator for the group, and should keep everything in sync while we work on this issue.

Have you updated to the new Sonos controller, version 10.6.1?

If you have, then you’re experiencing a different issue, and I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and contact Sonos Support to discuss it.

I usually suggest the phone folks, they have more tools available, but are only available Monday through Friday during business hours. The Twitter support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

I finally had a chance to update. Everything seems to be working correctly now. Thank you for your help!

Dear all,

i just heart from Sonos support a fix is coming soon but in the mean time be sure the playbar is your main system of the group. any other system above in the group will cause the echo -;(

 

regards,

Jan

In my room I have a Beam and 2 Play1 as surrounds.  The surrounds are not in sync with my beam and creates a terrible echo.  It’s been fine since it was set up roughly a year ago, but similar to NDZ above the problem started after having to make changes to my router and reconnecting the Sonos system. 

 

Diagnostic confirmation # 691778977

I am having the same issue. My TV is one sound source and the other sound source are my playbar and my two play 1’s that I am utilizing for surround sound. The only way that the echo stops is to Turn the TVs sound off. 
 

Has there been any updates on this? 

The issue you’re hearing would likely happen with every soundbar/receiver, as the internal speakers are meant to be ‘off’ ... most TV’s switch off their internal speakers automatically, as soon as any external Home Theatre system is attached...it’s a case (normally) of using the internal TV speakers ‘or’ the external HT system and not both at the same time. Nothing for Sonos to update here.. I would discuss the issue you are experiencing with your TV manufacturers customer support, or see if there is a later firmware/software update for the TV which may resolve the matter.

Same problem. Bought a Playbar on 11/30/19. Set up with my two Play1’s as surrounds. Listening to TV is fine. Listening to (non-tv) music ends up with a delay where sound coming from the Playbar clearly lags sound coming from the surrounds.  It’s actually physically nauseating to listen to after a short time and I have to shut off the surrounds.  I’m ready to return the Playbar and get my 20-year-old home theater system out of the basement for the tv and go back to music only on my Sonos speakers. I’ve been so happy with Sonos products until now.  Also disappointing that I’ve called and emailed Sonos support and no one I dealt with knew anything about this known issue.  Please fix this Sonos!

Been using Sonos since 2015 and just started having this issue over the last few weeks. Glad to hear I’m not alone! Workaround seems to have done the trick for now 😊

Nico-84, 

Make sure you contact Sonos through the link I supplied in my earlier post. Hope you get it sorted soon.👍

Thank you Ken Griffiths,
I was contacted today by Sonos support. They suggested to make my Beam the group coordinator and then add my connect:amp after that. I didn’t know a speaker could be a group coordinator.  I’m trying it out now and it seems to have solved the problem untill now. Good news!

 

Our system is just one year old. Switching to another brand is no option. Sonos is obligated to deliver the fix very soon when they want to avoid any further negative commercial.

But how can you play on the Playbar first and not the surrounds when the surrounds are linked to it? I can't see there's a workable temporary fix in this scenario (and I've tried unlinking the surrounds and re-adding them while the Playbar is playing but music still goes out of sync 10-15 mins later...).

Hi,

I’m using a Beam in combination with 2 Sonos Ones and a sub in a surround setting.

I have been facing the echo issues for the last weeks as well. I’ve updated the Sonos app on all my devices to version 10.6.1, however I am still facing the same echo effect. It only becomes apparent after an hour or more. The echo effect is very clear if a person is talking e.g on the radio, then it becomes very annoying. The only thing which helps is pushing the stop and play buttons in the app.

Are other users also still facing this issue?

Having the same problem, it sounds to me that the soundbar is slightly behind the surround speakers causing that echo. When I remove the “theater” group from the rest of the grouped speakers and add it back it fixes it for a few songs and than the echo appears again. I will try the suggested workaround tonight. 

Userlevel 7
Badge +26

@Datakiller01 do you have any trouble when playing music just to the home theater speaker with it’s bonded surrounds? Not grouped together with any speakers? And what about when you’re grouped with other speakers with your home theater speaker as the first room in the group? That workaround should keep things working in sync unless you happen to have two home theater setups there.