Answered

Echo with sound-bar and one

  • 31 October 2019
  • 87 replies
  • 7427 views

I am having an “echo” sound coming from my Sonos One speakers that are in surround sound mode with my sound bar. I have them grouped and they have been this way for a long time, I have done a truesound calibration a couple times, it will sound good for a day or two and then I notice an echo coming from the One speakers again. Can someone help me, please?!?!

icon

Best answer by Ryan S 19 November 2019, 22:41

We’re still working on this issue, it’s being investigated and as soon as a fix is ready to go we’ll let everyone know. For now, using the home theater device as the first in the group will work while we get this resolved.

 

Edit: For clarity, this means play music first to your home theater player, such as a Playbar or Beam, and after the music is playing, use the Sonos app or press and hold the play/pause on your other speakers to group them together. If the home theater speaker is the group coordinator, the first one in the group, the echo won’t start up with music playback.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

87 replies

Userlevel 7
Badge +26

Hey Ryan,

I have a Sonos Beam, 2 Play 5 surrounds and a sub in the living room.  I also have a Playbar, 2 Play 5 surrounds and a sub in the family room.  How should I set it up so that I don’t get the echo in one of the rooms?   

That’s a tough one since both can’t be the master at the same time. Probably better to have the Playbar as the first in the group, but it’s possible things will still fall out of sync.

 

Same problem. Bought a Playbar on 11/30/19. Set up with my two Play1’s as surrounds. Listening to TV is fine. Listening to (non-tv) music ends up with a delay where sound coming from the Playbar clearly lags sound coming from the surrounds.  It’s actually physically nauseating to listen to after a short time and I have to shut off the surrounds.  I’m ready to return the Playbar and get my 20-year-old home theater system out of the basement for the tv and go back to music only on my Sonos speakers. I’ve been so happy with Sonos products until now.  Also disappointing that I’ve called and emailed Sonos support and no one I dealt with knew anything about this known issue.  Please fix this Sonos!

Have you tried the workaround where you play to the Playbar first and group others to it? That should prevent it from falling out of sync unless you have multiple surround sound setups.

Hi Ryan.  Please let me know exactly how to use this workaround.  I have two Play1 speakers setup as surrounds with a Playbar.

Do I need to do the following every time I play music:  

1) Go to Settings > System > Family Room 3 (+LS+RS) (playbar) > X Remove Surrounds.

2) Start playing music.

3) Re-add two Play1’s as surrounds.  

I just did this, and it took several minutes. Please tell me I’m mistaken and that the workaround you have in mind is much simpler, because there’s no way on earth I’m performing the above process every time I play music.  Please provide step-by-step details.  

Userlevel 7
Badge +26

Hi Atom, if all you have is the Playbar and the Play:1s set up as surrounds than the specific issue shouldn’t apply, assuming those Play:1s are bonded as surrounds. So in the Sonos app if you see under “Rooms” just the single Family Room, than this shouldn’t be happening. If you have another Sonos player in the household, such as a Play:1 that’s not part of the single room setup, you just need to make sure you play music to the room with the Playbar first, then group to the others.

 

If you have just the Playbar and surrounds and are getting an echo, I’d advice that you reach out to our support team to see what else might be happening, or if there’s a different issue you’re running into. 

The “specific issue” exactly as described in the very first post in this thread is:

”I am having an “echo” sound coming from my Sonos One speakers that are in surround sound mode with my sound bar. I have them grouped and they have been this way for a long time, I have done a truesound calibration a couple times, it will sound good for a day or two and then I notice an echo coming from the One speakers again. Can someone help me, please?!?!”

This is exactly the problem I’m having, except I have Play1’s as surrounds vs. Ones. 

I’ve reached out to support several times and the problem remains.  I will give that another try since I am finding no real solutions here.  Hope your engineers can resolve this.  Clearly there is a problem, and clearly I am not the only one affected. 

Been using Sonos since 2015 and just started having this issue over the last few weeks. Glad to hear I’m not alone! Workaround seems to have done the trick for now 😊

Userlevel 6
Badge +13

Just had another update this morning, unfortunately the echo is still there when 5.1 setup is grouped onto another room (and not the "master" room).

I’m pleased I’ve found this thread as I’m facing the same issue. It’s been driving me crazy for the past 6 weeks.

Playbar is linked to 2x Play1’s for surround sound with TV.

Looking forward to a fix! 

I’ll join the masses, I also have this problem. So really looking forward for a fix. Can’t go around restarting my music every 30 min when the echo appears.

You don’t have to, if you simply employ the previously posted (by Ryan S, in this very thread) work around.

I am also having the same problem but I have a Playbase with 2 ones in surround mode.

ok to start with then after 10-15 minutes the echo kicks in. Never used to do it, probably around a month now. Its the sonos ones that seem to he out of sync
Def not the tv speakers as these are disconnected, have tried re setting bit no change.

The workaround, posted up thread, should work for you while they fix the problem.

We also discover the same issues previously discribed since a couple of months now. We have to reset the Sonos every half day averaged.

We do irritate us enormously because the music sound was always perfect.

Please Sonos come up with a fix asap or do a roll-back from the working software software version.

Kind regards

Jan

 

 

Hi, this has been over two months and it is getting very annoying! I have over $3000 in Sonos equipment and I am getting ready to switch everything to Bose...can we please have some kind of update or progress report. I feel like I have been patient with this problem and I have submitted diagnostic every time this happens. Any update? Very disappointed and growing impatient! 

Userlevel 7
Badge +26

The team is still working on it! As soon as I’ve got an update on when a fix is available I’ll let you know. Hopefully the workaround helps work in your home while that’s being worked on. 

Our system is just one year old. Switching to another brand is no option. Sonos is obligated to deliver the fix very soon when they want to avoid any further negative commercial.

Userlevel 7
Badge +26

@Datakiller01 do you have any trouble when playing music just to the home theater speaker with it’s bonded surrounds? Not grouped together with any speakers? And what about when you’re grouped with other speakers with your home theater speaker as the first room in the group? That workaround should keep things working in sync unless you happen to have two home theater setups there.

As previously explained:

We have a soundbar and three one satellites

One satellite is configured as standalone the others are configured as surround.

The echo returns each half day averaged.

Reset by on / off is just a temporary solution and becoming really annoying for system in this price class.

 

Hi all, i have the same problem with echo on playbar with sub and 2 play 1 as surround speakers. It happens only when playing radio music. It starts randomly between 2hours or more. Stopping the radio and starting again solves that issue. But within the next 2 hours it occurs again.

Hope you guys get that fixed very soon.

Regards Wolfgang

Got this same issue, very disappointing how long it is taking Sonos to sort it !

Fine on TV radio has echo, spent an hour thinking it way my system at fault before googling it !

It happened after the last update, is it possible to roll back an update ? :thinking:

 

Thanks

 

Dear all,

i just heart from Sonos support a fix is coming soon but in the mean time be sure the playbar is your main system of the group. any other system above in the group will cause the echo -;(

 

regards,

Jan

Userlevel 7
Badge +26

There’s an update today, Sonos version 10.6.1, which has some improvements made which should correct this issue. When you have a moment, check for updates (if your system doesn’t update automatically) and you can test this out. We’re still monitoring the issue to make sure these changes have resolved it, so please let us know if you’re still seeing any trouble with playing music on home theater Sonos speakers and grouped rooms.

Hello all. I’m having this same issue. I’ve tried making the playbar the group coordinator, but after 10 to 15 minutes I can hear the echo as well. All of my speakers are hardwired back to the router, nothing is wireless. Is there any ETA on a possible fix for the echo/sync issue that’s being experienced? I just got my playbar for Christmas. It works perfectly with the tv, but when grouped with all my speakers to play music, the echo shows up eventually.

Have you updated to the new Sonos controller, version 10.6.1?

If you have, then you’re experiencing a different issue, and I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and contact Sonos Support to discuss it.

I usually suggest the phone folks, they have more tools available, but are only available Monday through Friday during business hours. The Twitter support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

Hi, is Sonos still working on a fix? It's been in the pipeline for almost two month now? We really love to have it fixed permanently, not having to start a stream on my playbar first….

Userlevel 7
Badge +26

Hi Marcel, I see you got answered in another thread, but the 10.6.1 software has a fix for this issue. Just make sure you have that installed and you should be all set.