Default Netgear Switch Settings cause STP issues

  • 23 February 2011
  • 7 replies
  • 14143 views

Userlevel 2
I just installed a Netgear GS716T switch today, in the middle of my network. The default settings for the switch have it blocking STP BPDU packets. This caused a network storm, as Sonos units behind the switch were not getting the BPDU's from the switch.

Turning on BPDU flooding fixes the issue.

I then turned on the switches STP. Same issue. It turns out that you have to enable STP for the switch, and enable it on each port, or at least each port that can cause a loop (the sonos connections, and connections to other switches).

Its working fine now that things are properly configured. Just posted this as a heads up.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

So having STP disabled with the BPDU packets set to Flooding worked?

By having STP disabled, what else uses this protocol?
So having STP disabled with the BPDU packets set to Flooding worked?

By having STP disabled, what else uses this protocol?

BPDU flooding means that the switch is transparent ('dumb') as far as STP is concerned. It doesn't participate in the spanning tree calculation.

All broadcast STP traffic is forwarded ('flooded') straight out of all the ports.
Userlevel 2
I have had a similar problem with the gs716t out the box. Basically after around 24 hours all connected lights start flashing with switch crash, needing system reboot. Sonos advised to turn on BPDU flooding but this did not help - Same crash result. I have just tried enabling STP and enabled on the ports for the 2 x wired sonos ZP's. So far working but usually only crashes after about 1 day. Did your system work and if so please advise what settings you are using on the switch. Thanks.
Bob55,

You've been posting on several threads with this query. This is not terribly helpful as regulars don't know which to reply to, and may end up replying to none.

This reference post from Sonos Support may help shed light on the STP issue: http://forums.sonos.com/showthread.php?t=16973

Your switch will need to either actively participate in STP (with STP enabled on ports facing the ZPs) or be configured to use BPDU Flooding. In addition if there is an "Edge" setting for ports facing the ZPs it should be set to "NO".

You said you've now made a change and that things were apparently okay. I suggest you see how things work out before making any further adjustments.
Userlevel 2
Thanks. Will only post 1 in future. Has been an ongoing problem but the forums have many conflicting solutions. Still working so far.
Userlevel 2
I'm coming in late on this thread, but wanted to share my experience, in case it helps someone.

I had a big struggle last year w/ Netgear & Sonos, and I made this post...

http://forums.sonos.com/showpost.php?p=102296&postcount=53

within this thread...

http://forums.sonos.com/showthread.php?t=14720&page=6

Bottom line I think was that BPDU Flooding = enabled (all) was the key setting for me.

However I had 2 interconnected Netgear switches in my configuration and each had different STP/BPDU capabilities, so your mileage may vary.
Userlevel 2
Badge +1
OK this is a very old problem with links that doesn't work anymore....

I have a netgear switch, GS748. what is the proper set up for this to work, cuz it's not working good at all....