Controling sonos ONE does not work.

  • 9 February 2019
  • 12 replies

I've been using sonos for over a year now, and it was working great until this christmas(2018). I think something happened when I updated sonos and clicked auto update on a choice.
After the update, when I was going to set the mood with music, I weren't able to start songs from 'TuneIn'.
After that I tried different ways of startings songs, from the device, from spotify and from TuneIn. TuneIn never works anymore. And it seems like I'm able to start songs by adding them to the que, or chosing them durectly from a device.

The second problem is, if I'm able to start a song, I won't be able to pause it, stop it or skip it with the Controller App on the phone or PC. The choices are greyed out, even when I'm able to start a song.

Third probelm is controlling the volume does not always work properly, especially when I'm gouping my units. I'm not able to controll the individual units when gruped.

I got 4 sonos ONE. No matter which i choose i get the same problem or if i group them.
I've tried to restart all the deviced at the same time for 5 minutes. And today I tried to resett the units and the controller application. Both atempts resulted in no change.
And there is nothing showing in the error log.

I'm starting to think that the update broke my units, and they don't work properly any more.
This goes for all my units.
Is it possible that this could be caused by the network? The only change I've done to it is to fw update it.
I've send the diagnostics and got this ref number: 1361946626

Anyone had the same issue or similar issue?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

All three of your symptoms point to issues in your local wifi, with your speakers not maintaining a constant connection to the wifi.

While you wait until Monday for the Sonos folks to return to look at your diagnostic, you may want to try a simple reset of your local wifi. Unplug from power all of your Sonos devices, then do a power cycle of your router. Once it comes back up, plug in one of your Sonos devices, and wait a minute for it to come back up. Then move on to the next one, and plug it in, again waiting a minute, and so on.

This might help. And if it does help, you may want to look into your router's manual on how to set up reserved IP addresses for all of your networked devices.
Thanks for the reply Airgetlam, I tried your solution but unfortunatley it had no affect.
My all my devices have unice IP adsresses.

I also found this yeasterday and tried it out today, but that did not helpd either:

Just hope I'll be able to get it working again...
Huh. Well, let's see what they say about your diagnostic on Monday, when the forum folks will be back in.
Userlevel 7
Badge +19
Hey there, MrTJ. Just as Bruce was advising, it seems that your Sonos speakers are having a hard time maintaining each individual connection to the network. That being said, is it possible to plug one of the Sonos Ones into the network using an Ethernet cable? This will significantly change how data is routed along to Sonos, allowing for the speakers to talk to each other, rather than over (relatively) longer distances to the main router.
Hi Keith, thanks for the reply.
I tried your solution. It does seem to work slightly better now? I pluget one in to my network switch and it's connected with 10/100 link.

This is what happens now:
I have 4 units as said, 'Hallway', 'Diningroom' and two in stereo named 'Livingroom'.
I did not restart anything, just plugged 'Hallway' in to the network switch. They are now showing up on the switch with the same IP's they had on the Wifi.
Waited for a bit and tryed to start a radio station. No sound. Did not show as palying or in the cue.
The second time i played a different station on TuneIn I got sound. I grouped them all, and I'm able to controll the volume on them, except from 'Hallway' It's greayed out(the one with the direct link).
After ungrouping them I'm now unable to start playing a station on 'Hallway'.
I tried for a second time and I'm now able to play it, but it does not show up as playing('no music choosen', or what it says in english). And the stop button is greyed out again.
While 'Hallway' is greyed out and does not seem to work properly, 'Diningroom' on the otherhand does seems to work properly. I can start tracks, radio stations, que shows as normal and use the buttons as normal in the controller on my PC. Although, clicking Skip track does not skip the track. It just keeps playing. Waited 30 sec and than hit next again. Now it seems to work. It seems for me that some times there is lag, for some seconds when i click on somthing before it does it. Can't really remember that it did so when it worked laster year.

One more funny thing is that it seems like 'Hallway' is showing the que that 'Diningroom' is playing/showing on my mobile phone. While on my PC it shows an empty Que. And to stop 'Hallway' from playing the que, i have to empty it to stop playing.
I'm now going to restart them and test again.

I have three changes done. Change os ISP, FW on network units and Sonos units. I can't understand why there shud be anything else triggering this. My wifi works perfectly with my phone, PS4 and Android TV as it did with Sonos before the three changes. My TV has a link speed of 325Mbps, with -81 dBm signal strenght. This is next to the sonos placed furthest away from the AP(access point).
The Sonos units did all show up on the network port on my switch when I pluged 'Hallway' in to it, wich means, if i'm not mistaken, that they did use 'Boost' mode.
Afther i restarted every sonos unit, and checked that it's using 'Boost'(Mesh) mode, it's still quirky. I'am however able to controll all volumes from my phone when everything is gruped. I started a list on spotify to test. And nothing is showing in the que, it's still playing, and all controll is greyed out except for volume on the Phone. On my PC 'Hallway' and 'Diningroom' volume is grayed out(as for every other button) after i grouped them. Controling the group volume only adjusts 'Livingroom' volume. And it's draging far behind my adjustments(3-4sec). The volume from the speaker even changes(3 sec.) sometimes before the 'Livingroom' volume follow my volume change after 5 sec. Sometimes it's instant changing with my change.

Even though the units are quirky, they play at perfect sync(to my ears) when grouped. And can play a hole playlist without interuptions. Both by wifi and in 'Boost' mode.

Now that you have your Sonos devices running on SonosNet (Boost) mode, can I perhaps suggest you do the following:

1. Remove/Reset your WiFi credentials from 'Advanced Settings/Wireless Setup' in the Sonos App.
2. Set your router (and any connected hubs, or extenders, if relevant) to a particular chosen fixed 2.4ghz wifi channel. They should all be on the same channel.
3. Set your SonosNet Channel in Advanced Settings of the Sonos App to a wireless channel that is at least 5 channels away from your chosen fixed router wifi channel

And then see if that works any better for you.

If you are resident in a densely populated area, then it would pay to use the least-used non-overlapping 2.4ghz wifi channels (1, 6, or 11) for your router etc. and so it maybe best to scan the locality to establish which are the best channels to use. Search Google for free WiFi scanner software, like wifiinfoview ...and do a scan and select those that are least-used by your neighbours.
Hi Ken,
Thanks for your reply. Good decriptions and a good test.
My wifi environment has only my own wifi devices, there are no others in the vicinity. Except for the ocantinally 1 that shows up every other minute on chanell 1.
My wifi is running on Channel 6, and I made the Sonos use 11.

After following your instructions I still had the same problems.

So I started testing every unit by them selfes(exepct 'Livingroom' which use stereo mode).
'Hallway' and 'Diningroom' share the same errors. Que don't show properly, volume controll and so on.
'Livingroom' seems like it's working, as they don't have that many quirks going for them.

I Switched back to how my wifi originally was set up, and did the test again. Same result.
2 of the units are definatley not working correctly. I will at least swap these two units for new ones where I got them.
And I'm also going to test 'Livingroom' by disabling stereo and put them in different 'rooms' and see how they work.

Thanks for the help guys! 😳
I went to the store today, and we where able to test them. Fun thing, they actually worked, and also on my phone.
Grouping, volume the hole shabang.
So you guys might have been right about that something wierd is going on on my network.
I dug some more and I might have found a loop. Removed it, but the problem still persist.

Still not sure what makes this happen. Have been resetting one of the units all day to try and figure it out... The two units that are in stereo continues to work. I haven't 'unstereoed' them, because I love so much that they work and that I'm able to use them.

Sent another diagnosis to Sono: 1490530634
This time I only have one of the units I'm unable to get to work connected, with a fresh resett of controller and the unit.
Any help would be appreciated, as I'm fresh out of ideas...

Now you have established with the store that there is not an issue with your Sonos speakers, You need to perhaps describe your current setup in far more detail. It’s still not clear what devices you are using for your (entire) LAN setup. It’s also not clear if you are currently running the devices on SonosNet, or the wifi channels in use, etc

You mentioned a network loop... is it a case you have managed, rather than unmanaged, switches?

Does the store where you bought the Sonos speakers not offer an installation/setup service that you could take advantage of.., it may save you the time and the bother here.

I think more detail about your local setup is perhaps needed, including brand names/models numbers/connection types etc.
I've been doing a lot of testing this weekend.
Since I have several Vlans I tryed connecting to a different SSID. I set up one of the units that I where unable to get to work.
And it worked like a charm.

There are basically no difference from that Vlan to mine. So I started unplugging devices.(I also did this in case I had to make a network topology map, it would than have been as small as possible)
Once everything was off, except for the AP-AC-PRO and the unifi switch(on my Vlan), it did still not work. So I reboted the sonos unit and tested again. This time it worked. So I resett the rest of the sonos and added them again. Everything was working as it should. I than started adding my network devices again.

After everything was added it still worked.
I'm not 100% sure why it now works, and why it didn't earlier. But I do suspect it was my Homey unit from Athom.
If it happens again, I'm going to unplug this unit and reboot the sonos. That should give me the answer for it.

Thanks for the help guys!
This topic can now be closed 😳