Connection with Spotify lost - again and again and again



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

413 replies

This is total crap. I keep having to power cycle my 2 play:1 speakers. Sonos, wtf? I haven't changed anything in 8 months. Now you can't seem to play more than a few songs. I'm actually in the process of deciding how to get digital streams to my hifi system. Do I buy a sonos connect for $350?

or spend the money on a high quality bluetooth -> dac -> amp/receiver device

http://www.arcam.co.uk/products,rSeries,Wireless-DACs,rBlink.htm

or go with Bluesound

http://www.bluesound.com/products/node/
I raised this particular thread four months ago and little seems to have progressed.  I now get the same issue on Qobuz as well as Spotify.  My bridge is hardwired to the router via Ethernet - and, yes, I have tried more than one cable.  The router is two storeys away in the house.  There are no other wireless devices anywhere near except my laptop which is generally about 5 metres away. 

Playing Spotify or Qobuz through their desktop apps rarely has any issues.  However, I am plagued daily by 'not enough bandwidth' (I get 4.5 Mb); 'the next track is encode incorrectly' (even though it was encoded correctly the last time I played it; 'the connection to Spotify / Qobuz has been lost'; 'problem searching' etc etc. 

The lex parsimoniae (or the principle of Ockham's Razor) says that the when faced with competing hypotheses, with the one with the fewest assumptions should be selected.  That is: there is something wrong with the Sonos API / method of connecting to these services.

You owe it to the large number of people who have invested heavily in buying your products to sort this out.   At the very least, you have to explain why you think it is not your system that is the root cause and then find a way of making it work for everyone so that the performance matches the advertising.
Can I downgrade my SONOS operating system to an earlier version?
Userlevel 5
Badge +3
This is total crap. I keep having to power cycle my 2 play:1 speakers. Sonos, wtf? I haven't changed anything in 8 months. Now you can't seem to play more than a few songs. I'm actually in the process of deciding how to get digital streams to my hifi system. Do I buy a sonos connect for $350?

or spend the money on a high quality bluetooth -> dac -> amp/receiver device

http://www.arcam.co.uk/products,rSeries,Wireless-DACs,rBlink.htm

or go with Bluesound

http://www.bluesound.com/products/node/


Hello Bill,

I'm happy to take a look at your system to see what issues you may be experiencing. Mind submitting a diagnostic after you experience an issue and I'll be happy to take a look. Please reply back with your number here. 

In regards to your question and streaming digital content- if you need an audio input, you could consider the CONNECT, PLAY:5, or CONNECT:AMP. 

What digital content were you trying to stream to the system? 
Userlevel 5
Badge +3
Can I downgrade my SONOS operating system to an earlier version?

Hello Zeklink.de,

Once the system has been updated, you can not roll back or reverse to a previous update version. 
Same issue—just started this evening and when looking into it found this thread. Sort of discouraging, the number of problems people seem to be having. Submitted diagnostic: 4288977 
Same issue,

Diagnostic #4302322
Userlevel 5
Badge +3
Same issue—just started this evening and when looking into it found this thread. Sort of discouraging, the number of problems people seem to be having. Submitted diagnostic: 4288977 
Hello Ivan, 

Thank you for including the diagnostic. You are experiencing a particular type of error that would best be addressed live with a technician. I've created an incident for you, reference number: 150115-000261

When you have some time to troubleshoot the issue, please give us a call and we'll be happy to assist you.
Userlevel 5
Badge +3
Same issue,

Diagnostic #4302322

Hello Rochester Art,

Please try the following steps to help narrow down the issue:

Reboot your router and test the service again. Unplug your router from power for about 30 seconds, then plug it back in to power. Wait for the network to come back up.Then test again. Please clear your queue and then re-add and test playback. 

Remove and re-add the Spotify Service. To do so from your computer, please select: Manage > Service Settings > select Spotify > 'Remove' or ' - ' then select 'Add' or ' + ' > Spotify > enter your username and password

Test other services on the system. Test Internet Radio and other services to see if you experience the same skipping. This will let us know if other services are being affected as well. 

There is also a bit of interference on your system as a whole. If you still experience the same issue with Spotify, please try changing your router's wireless channel. It's currently on channel 1 and there is a lot of traffic in the area on this channel- change it to channel 11 and test again.

Please grab another diagnostic after these tests and I'll be happy to take a look. 
Same issue, diagnostic #4306541 

Spotify was working perfectly for last year, all the sudden started giving me problems.  I have tried the exact steps above suggested to Rochester Art.
I am having the same problem with spotify cutting in and out.I reset my router and removed andre-added spotify. My diagnostic number is 4307145.
I am also having this same issue.  Sonos - doesn't it seem like this is a common problem now?

Here is my diagnostic number: 4307873
Same issue—just started this evening and when looking into it found this thread. Sort of discouraging, the number of problems people seem to be having. Submitted diagnostic: 4288977 
Hey Dominique, thanks for the reply. I meant to follow up on my comment sooner to let whoever know that it magically started working again two days later. Anyway, as the people below have mentioned, this seems like a pretty common issue. I’d love to know that this is being worked on by the Sonos team, as I hope I don’t run into this again. Is there any way to submit a feature request like “have Spotify work all the time?”
I am having the same issue. Please help. Diagnostic confirmation number is 4309019
Same issue here as well. Rebooted router, disconnected all Sonos, removed Spotify account and reauthorized. Other services not experiencing issue. Confirmation number 4309290
Userlevel 1
Having same issue here. Sonos constantly losing connection to Spotify. I have completed all of @Dominque's suggestions several times to no avail. My system has worked fine for the last ~60 days since purchase and all of a sudden having issues. Please advise. My diagnostic number is 4309300.
I have the same issue. Losing connectino to Spotify. I have submitted Diagnostic. Diagnostic confirmation number is 4309302
Same Problem
Confirmation Number: 4309303
I've followed all the steps mentioned in this thread
yep same issue 😞
Same issue. Diagnostics 4309356, this makes my Sonos basically unusable, and this happened last night as well...
I write this directly to SONOS. Are you ever going to give us some clear communication on why this is happening? I'm trying to be very patient, but have been experiencing this problem for weeks, with no communication from you. I am on the verge of beginning a Twitter campaign and trying to embarrass you into talking to us about this. Please respond.
This exact issue just started happening on our system two days ago. We've tried everything suggested in this thread, but have had no luck getting Spotify to work (other services do work, like SoundCloud). I submitted a diagnostics - 4309401. Any help would be greatly appreciated. The main reason we got the system was to use with Spotify, so this issue is a major dealbreaker.
My twitter handle is @TysonMatt and I've just called @sonos out. Follow/retweet if you like to help me embarrass @sonos into action
following
Don't forget to retweet. Need to get some volume to make them pay attention.