Answered

Connection to Spotify was lost


Hello,

I am having an issue playing Spotify through my Sonos app. I keep getting an error message saying "Unable to play (song) the connection to Spotify was lost." After spending some time searching for a solution online, it became apparent that this is a widespread problem with no definitive solution. Nevertheless, I am determined to find an answer.

Additional information:

• Diagnostic: 2024196285

• Internet connection is stable.

• Issue just occured today during playback. Sonos system was installed a few weeks ago, and everything was working fine until today.

• Spotify app works fine by itself, and I can play Sonos Radio through the speakers. The issue only seems to be when I try to play Spotify through Sonos.

• I have tried powering the Sonos amps off and on. No fix.

• I have removed my Spotify account in the Sonos app, and then reconnected it. No fix.

• I have tried clearing my queue in the Sonos app. No fix.

• I checked for updates on both apps after the problem occured. No update for Spotify, but I did update Sonos. No fix.

I believe that is all the relevant information that I can provide at this time. I look forward to a response and hopefully a fix.

Thanks in advance!

 

icon

Best answer by Corry P 7 June 2021, 13:47

View original

65 replies

Sonos hasn’t changed anything on their side of the equation, to my knowledge. So it’s either an internal network change in your home, or an issue with Spotify. I’d recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Maddening that this has been a known issue for Sonos for more than 9 months and still no fix (or even transparent discussion on why it’s happening).

Maddening that this has been a known issue for Sonos for more than 9 months and still no fix (or even transparent discussion on why it’s happening).

Maybe this is a Spotify issue - they are due to rollout their HiFi service at some point this year. It is supposedly behind schedule, so maybe the cause of their ongoing issues has some bearing on these matters, although personally speaking, I’m not seeing any service interruptions here, but I only use their free service, with advertisements.

I'm having this issue right now and it's ridiculous. Song plays, song ends, next song doesn't play (connection to Spotify was lost). Song plays, try to skip, next song doesn't play (connection to Spotify was lost). 

 

If it is a Spotify issue, perhaps Sonos work directly with them to figure out what's going on if they haven't already. Also, updates on any progress on said issue would be very professional and customer friendly of them as well. 

Hmmm, so it could be something, it could be nothing, but right after posting that last message, I checked to see if maybe the Spotify app was actively running in the background on my phone and it was. I did a force stop on the Spotify app and mysteriously the Spotify connection while using Sonos app has been solid since. Unfortunately, I don't want to attempt to reproduce the problem right now because I just got my music working, but if anyone reads this, maybe try the above to see if it works for you. 

Hoped the above might be useful but unfortunately made no difference. When using my major playlist that is basically all Spotify song I either get that two consecutive songs will play ok, then the third fails, or each alternative song fails. The song that then plays also seems to sort of fade in having missed the first couple of seconds.

 

Because I have Android and iOS devices I’ve tried all combinations of using one or the other, both or none but nothing seems to fix it. Ironically about 6 months ago I thought this problem had gone but it’s back with a vengeance and worse than ever. Added to which to Sonos app generally seems to be getting more buggy. For example here’s my Home Screen on iOS at the moment. No Sonos playlists shown, when there are at least 5 to show and you can see the message about recently played…


this is my Android app at much the same time

 

 

I'm having exactly the same issue. I've reinstalled / restarted every component of my system and I still get the message "connection with spotify was lost" every time I try to play music. I really dont know what else I can do apart from buy some bluetooth speakers and just use the Spotify app directly. At present my Sonos system is just a number of bricks scattered throughout the house! It all worked for years...now it doesn't. I spent hours reinstalling, restarting etc. Coming to the conclusion that it's just never going to work again!

….and for what its worth, just installed Sonos on my desktop Mac, which is directly connected to my router via an ASDL cable. Exactly the same issue so nothing to do with WiFi.

 

For what it’s worth, I’ve converted my playlist to a Spotify playlist using free tools to export the playlist from Sonos, import it to Spotify (free tool only allows 200 songs per playlist and can’t add to existing playlists) and then merge the resultant playlists into one.

 

Then the playlist is available through Sonos and plays perfectly, no missed tracks or skipping half way through… and honestly now I’ve gone through that bit of pain at least now my playlist is in a piece of software that allows me to manage/sort the playlist etc in a way that Sonos has always been really poor at. The Sonos app is now just a way of selecting a Spotify playlist and starting/stopping the music.

….and for what its worth, just installed Sonos on my desktop Mac, which is directly connected to my router via an ASDL cable. Exactly the same issue so nothing to do with WiFi.

 

An invalid conclusion. The Sonos controller is just that: a remote control. It sends commands to the players. They then fetch the music stream directly.

This is almost certainly a network issue. Occasionally the internet or the remote servers can be at fault, but usually the problem is local. 

I suggest you submit a system diagnostic within 10 minutes of a dropout, note the confirmation number, and contact Sonos Support. They have the tools at hand to analyse your local network conditions. 

I have absolutely had enough of switching things off, restarting things, reinstalling apps, rebooting things. So many people have had the same issue and I've spent literally hours on this and nothing I've done has made any difference. Sonos was working with Spotify up until a few weeks ago, now it isn't. 

I actually went out this AM and bought a cheap portable Bluetooth speaker...so nice to be able to listen to music in the kitchen. 

No energy left to devote to Sonos I'm afraid.

.....and bizarrely enough .... after typing that message its suddenly started working perfectly!!

The Sonos system diagnostic is extremely comprehensive. The chances are that a support tech would offer advice very quickly.

As for “so many people have had the same issue”, this board would be inundated with thousands of posts if there was a fundamental problem with Sonos. 

Userlevel 1
Badge

After months of not a single playback problem, yesterday the connection to Spotify was lost-problem started again. Anyone else noticing this?

It has worked to just restart the app this time and i am pretty sure that didnt work last time. Weird.

@ratty 
 

The Sonos system diagnostic is extremely comprehensive. The chances are that a support tech would offer advice very quickly.

As for “so many people have had the same issue”, this board would be inundated with thousands of posts if there was a fundamental problem with Sonos. 

It may not be a fundamental issue but its pretty wide spread. Its not just a single incident and not just this single thread. It is something that has been going on for quite a while and nobody can seem to give any straight answers other than bandaid fixes. Here are just a few threads from not only sonos community but spotify community as well. And these aren’t even  moving past the first half page of a google search for this problem.

 

https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Sonos-Unable-to-play-the-connection-to-Spotify-was-lost-Nov-2018/td-p/4621312

https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Can-t-play-Spotify-on-my-Sonos-speakers-Connection-to-Spotify/td-p/4956833

Reply