Answered

Connection Problem


hello everybody, 

I have a big Problem to Connect all my sonos. I Lost all of them when I wanted to add a new sonos on my system. I already use it since a lot of years but when I connected my new sonos, my application said   no system detected so I Lost everything. 

Someone have a solution please ? 

Need some help urgently. 

 

icon

Best answer by GuitarSuperstar 12 March 2021, 20:25

Try rebooting your router and your phone and unplugging all of your Sonos devices from power for about a minute.

View original

17 replies

Userlevel 7

Try rebooting your router and your phone and unplugging all of your Sonos devices from power for about a minute.

Thank you very much. All is ok thanks to you. 

 I have 4 devices connected to my Sonos amp. My iPhone Sonos app sometimes doesn’t recognise my amp when I return home. So I have tried the methods advise by Sonos ie turning off and on my amp. Turning off and on the router. This is quite frustrating does anyone have any other advice please thanks 

Same problem. Getting fed up having to turn off all speakers, router and mobile phone every time I want to use Sonos as it constantly jams “on” and I have no control over the system at all. I just keep getting “can’t connect to Sonos” error message. Totally useless system in my humble opinion.

Userlevel 5
Badge +13

Hi @Paulwright007, welcome to the Sonos Community!

Issues connecting to the system are often related to the network - mind letting us know how your network is set up?

Do you have any wireless extenders or Access Points? And do you have any Sonos devices connected via Ethernet cable?

Yes my devices occasionally need to be reconnected, on chat and telephone call to Sonos they informed me that the amp was to far away from the router/ or had other devices interfering with my amp. I’ve had it for 3 years without past issues. . I was told that WiFi extender could interfere with connecting issues. Turned this off still connected problems. I have excellent WiFi signal. Don’t know what to do. Can’t keep unplugging amp connect to router with Ethernet cable every week. 

Hi Xander P - it’s a really simple set up. Connection to 4 speakers of various ages via wireless to BT router. No Ethernet connection. No boosters. Only other connections to the wireless are home heating system, and iPads / phones. 
 

Operating on S1 as one of the speakers is “old” in Sonos logic, but not mine as I have no intentions of bricking perfectly decent technology (well, when it works). The system has been pretty reliable in the past, but with the current problems  is virtually unusable. Any recent  updates that may be disturbing the system?

Thank you for any advice - turning routers / speakers / peripherals on and off isn’t a solution.

Userlevel 5
Badge +13

Understood @Paulwright007, some routers can have a bit of difficulty passing messages between devices on 5GHz wireless, and devices on 2.4GHz wireless - would it be possible to test “splitting " the two WiFi bands, by adding “-5" to the end of the 5GHz wireless name?

I believe with BT routers this process is made fairly straightforward, however if you’d prefer some assistance to make this change, feel free to get in touch with our Support Team.

Another option if you don’t want to make any changes to the router settings would be to wire a Sonos device to your router via Ethernet cable, which should also allow you to consistently connect.

There haven’t been any recent changes to how Sonos is discovered on the network, and if the system itself works when you are able to connect, then I suspect the discovery messages aren’t being passed across the network properly.

 


@Tonithecat got it - have you noticed if, when you’re unable to connect using the app, the Amp will play whatever was last queued if you press the Play button on the Amp itself?

If so, then this would again indicate that the network isn’t properly passing on discovery messages, and if this persists with the extender powered off, it may be worth looking in to either wiring the Amp, or checking if your router allows for the 2.4 and 5GHz bands to be “split".

Thank you. I’m so nervous about splitting the router settings, as inevitably this will upset something else I want to connect to, and cause more problems than I have in the first place. So, I will source an Ethernet cable to see if that resolves the issue. Does it matter which speaker I connect the Ethernet cable to -as there is only one suitable near my router?

what is the boot-up routine once I have the cable? Turn everything off, connect Ethernet cable to speaker, turn on router, turn on speaker, make connection with iPhone to that speaker, then turn all other speakers on and connect to those?

Userlevel 5
Badge +13

@Paulwright007, not a problem - if there’s a Sonos device (not configured as a surround or Sub) close enough to connect via Ethernet cable, then that should do the trick :)

Generally all you need to do is connect the speaker via cable, and the rest of the system should automatically swap over to the SonosNet connection - you can check this in the Sonos app by going to Settings > System > About My System - if devices are listed with WM:0, then they have joined the SonosNet connection, WM:1 indicates that they are connecting to your home WiFi, and WM:2 is reserved for surrounds or a Sub bonded to a Home Theatre setup.

If you do notice any of your devices still show WM:1, then a quick reboot should get them to connect via the Sonos mesh. Let us know how you get on!

OK - thanks. Cable arrives tomorrow, I’ll let you know if it fixes the issue. 

Understood @Paulwright007, some routers can have a bit of difficulty passing messages between devices on 5GHz wireless, and devices on 2.4GHz wireless - would it be possible to test “splitting " the two WiFi bands, by adding “-5" to the end of the 5GHz wireless name?

I believe with BT routers this process is made fairly straightforward, however if you’d prefer some assistance to make this change, feel free to get in touch with our Support Team.

Another option if you don’t want to make any changes to the router settings would be to wire a Sonos device to your router via Ethernet cable, which should also allow you to consistently connect.

There haven’t been any recent changes to how Sonos is discovered on the network, and if the system itself works when you are able to connect, then I suspect the discovery messages aren’t being passed across the network properly.

 


@Tonithecat got it - have you noticed if, when you’re unable to connect using the app, the Amp will play whatever was last queued if you press the Play button on the Amp itself?

If so, then this would again indicate that the network isn’t properly passing on discovery messages, and if this persists with the extender powered off, it may be worth looking in to either wiring the Amp, or checking if your router allows for the 2.4 and 5GHz bands to be “split".

No no last queued I am unable to connect with wiring amp it’s the other side of the room. The whole thing about Sonos is no wires. How do I know if my router allows for 2.4 and 5GHz bands to be split? Thanks 

Userlevel 5
Badge +13

@Tonithecat most reasonably recent models of router allow for the bands to be split :) 

Do you have the make/model of your router? I’ll be happy to take a look for some instructions on how to split the bands on your router.

@Tonithecat most reasonably recent models of router allow for the bands to be split :) 

Do you have the make/model of your router? I’ll be happy to take a look for some instructions on how to split the bands on your router.

TTSCOMFAST5364 hope this helps 

 

Userlevel 5
Badge +13

Thanks for that @Tonithecat - you can find here some instructions on Splitting the SSID (wireless name) on your router, the Sagemcom model.

I’d recommend leaving the 2.4GHz WiFi name as it is, and adding “-5" to the end of the 5GHz name. If you’d like any assistance with making this change, then as mentioned earlier feel free to get in touch with our Support Team, or alternatively your ISP should be able to assist as well :)

Thanks for that @Tonithecat - you can find here some instructions on Splitting the SSID (wireless name) on your router, the Sagemcom model.

I’d recommend leaving the 2.4GHz WiFi name as it is, and adding “-5" to the end of the 5GHz name. If you’d like any assistance with making this change, then as mentioned earlier feel free to get in touch with our Support Team, or alternatively your ISP should be able to assist as well :)

Thanks for the advice 

 

OK - so the £2 Ethernet cable arrived and plugged into router and speaker as recommended. All information on the app disappeared, the only speaker to be recognised was the one plugged into the router. After a quick reboot, all speakers now working and not “jamming” as previously reported. All speakers now back up and running again - a bit strange that a wireless system now relies on a piece of wire, but hey, I’ll take that, as it happens to be hidden near my router and not visible. Let’s hope it stays stable, as honestly I was close on chucking it all out of the window.

Reply