Connection Issues When Playing from Spotify

  • 19 March 2021
  • 5 replies
  • 59 views

Badge
  • Contributor I
  • 3 replies

Hello Sonos Community. I am having an issue when playing music from Spotify. When I play music from Spotify on more than 4 units grouped together, the music will cut in/out between the speakers for about the first 30-45 seconds of the song. After the first 30-45 seconds then all the speakers will join in and play together in sync. When Spotify naturally goes to the next song the issue is not present, but if I select another song before the current song ends then the issue happens again. If I play from Spotify on 4 units or less then this issue doesn’t happen; when I select a song all 4 units will play immediately, or within the first few seconds.

 

The issue is consistently happening when playing on more than 4 units. It also seems to only happen when playing from Spotify. If I play from my local library on my iPhone or from Soundcloud then the issue doesn’t happen. I have been working with Sonos support for about 2 months now with no luck, so I’m hoping maybe someone else has come across this issue. 

 

Setup Overview

2 Sonos Connects

5 Sonos Ones (Gen 2)

2 Symfonisk speakers

1 Sonos Boost

Asus RT-AC68U Router

 

 These are the steps I’ve tried so far:

  • Rebooted router and all Sonos units
  • Rebooted AT&T modem
  • Factory reset the router
  • Changed Sonos Net to Channel 1 and set router to Channel 11
  • Turned off QoS on the router
  • Changed Spotify streaming rate to the lowest quality
  • Turned off Asus AiProtection
  • Setup Sonos units on the AT&T modem

Side note - I added the Boost to my setup about a while back to see if it would help, but it hasn’t made a difference. Now I’ve waited to long to return it so I figured I may as well keep it tied into everything. As of now, the Boost is connected via network cable directly to my router and all the other units are connected to it. Any help would be much appreciated!

 

 

 


5 replies

Userlevel 7
Badge +17

Hi @Ayng 

Welcome to the Sonos Community!

This is a not-uncommon problem that’s usually a result of the total bandwidth available to a particular group/unit.

The first (and simplest) thing to think about is who is in charge of a group. When you select one room, and then group other rooms to it, the device in that first room becomes the Group Coordinator (GC). Once a group gets over a certain size, the choice of GC becomes more important. The GC’s job is to fetch the stream from whatever source is asked for and send it out to the other units in the group - directly, if in range - and arrange synchronisation. As the GC has the most work to do, it’s best for the GC to be the one in the group that has the best connection. This is either a unit that is itself wired to the network, or is the closest unit in the group to the Boost or wired unit. If someone doesn’t have any wired Sonos devices, then the best choice for them is the unit closest to the router. For you, changing the GC to the room that’s closest to your Boost may be enough for you to enjoy your larger group without issues. It also helps if the GC has CPU power to spare - your Sonos Ones will have more power to spare than the rest.

Sometimes, however, the GC reaches the limit with what it can do with it’s WiFi radio. In these circumstances, it’s best to have a second wired Sonos device in your system, ideally at a distance from the first. The ideal setup for a single wired product is for it to be in the centre of your Sonos system, but the ideal setup for 2 wired devices is to have them at opposite ends of the system, so they share the load evenly. This is rarely practical, of course, but the closer you can get to this, the better. If careful choice of the GC doesn’t help, you may need to wire a second unit (not necessarily a Boost) to your network to improve matters. If you can wire one of your intended large group, this would instantly become the best choice for that group’s GC (with the possible exception of your Symfonisks - the antennae don’t appear to be as good).

Another thing that may help is to get as many of your WiFi-enabled devices (TVs, phones, computers, games consoles) to use 5GHz, or ethernet, as you can - this will lower 2.4 GHz interference in your home. In fact, interference could be the only problem (interference can always be the problem) in your way, though I would assume our support team would have spotted this, in your case. We have guide on reducing wireless interference that’s helpful on identifying possible sources. Rule 1 is to keep your router and Boost at least 1m apart.

I hope this helps.

Badge

Corry

 

Thank you for the detailed response! I have tried different combinations of which room is the GC and none of that has changed, but I have not tried wiring a 2nd unit to my router. This sounds like it would be the next test to see if it will resolve my issue. I don’t believe my issue is with interferance as there are only 2 devices (not counting the Sonos) that are using 2.4GHz. All my other devices are either hardlined or using 5GHz. 

 

The easiest option for me would be to wire both my Boost and one of my Connect units as they are the two closest to my router. The down fall is that they are both in the same room - do you think that would help at all? 

 

If I had to I could probably run a line to both my Boost and my other Connect unit which is in a different, more centrally-located room. While it might be a bit difficult to run the line to the Connect unit in the other room I would be willing to do it for the sake of solving the issue. Would this be a more ideal setup? 

Userlevel 7
Badge +17

Hi @Ayng 

Sorry for the delay.

It’s conceivable that having two wired units in one room would help, but I doubt it. It’s worth trying, however, as it sounds a lot easier than the alternative.

Running a ethernet cable to another part of the house would be much better, yes.

Although it’s not supported by Sonos, I have another idea - Powerline. 2 units (for around $20-$30) would allow you to use your home’s mains power cables as networking cables. This would probably be the easiest way to get ethernet to another unit, but it’s unsupported for a reason - it may introduce as many problems as it fixes. Some people use Powerline and Sonos together without issue though. You could always try it and get a refund if it doesn’t work. Again, running an ethernet cable would be better (from our point of view).

Badge

@Corry P 

 

The Powerline suggestion worked!! I was going to just buy it and return if it didn’t work, but it’s working beautifully. I don’t have any drops anymore and the music plays through all the speakers with ease. 
 

Thank you so much for the tip! I truly appreciate it. 

Userlevel 7
Badge +17

Fantastic! Glad to hear it’s helped you out. Don’t forget that if there ever are problems, you now have two more devices that may need a reboot.

Reply