Answered

Compatibility WiFi 6 (802.11ax) mode

  • 25 January 2021
  • 41 replies
  • 4011 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

Badge

Right. I’ve rolled back my router firmware to version 384.9948.

I can see Sonos is already behaving differently on the network. 

Fingers crossed this works.

Nice one controlav.

Badge

 

Out of interest, in wired mode (i.e. SonosNet) how does my iOS app then communicate with the Sonos hardware? In wirelss mode, it communicates via the 2.4GHz wireless SSID..? 

Your phone sends info to your router, using whichever WiFi band your phone is connected by, then over the wired link to the wired Sonos component.  2.4GHz SonosNet is used for the communication between Sonos devices.

Ok, that so that’s the Captain Obvious bit that I’d missed, hence why wired connection to a “Modem” isn’t going to work ;)

Badge

I am wondering whether I can try and get two Sonos components to be hard wired into something somehow… Either the Modem, or the Router. The former potentially being more likely with a little creative placement of hardware… 

Note that you can’t wire two Sonos units if one is ‘upstream’ of the Asus router and one ‘downstream’. They’d wirelessly bridge the two subnets on either side of the Asus unit and cause addressing mayhem.

If the double-NAT arrangement causes problems in terms of what can be conveniently wired where, there is of course the option to just put the Asus router into Access Point mode. There’d then be a single flat subnet throughout. 

Yep, thanks Ratty. I’d read something elsewhere that was similar. 

It basically means, that unless I want to cause a new WiFi range problem, and the try and solve this by buying another router or node for my Asus network, I need to either fix this wireless drop out issue through process of elimination, or purchase a Sonos Boost. 

Boost seems the cheaper option, with less likelihood of impacting something elsewhere in the network…

I appreciate everyone’s input so far. I’ve learned quite a bit this weekend. 

So far, I’ve managed to gradually bring everything back into the network. Conclusion is the system does not like WiFi 6… So I’ve put the 2.4GHz band into “compatibility mode” and reserved the 5GHz to WiFi 6… 

Now to let it settle down and allow time to give me an answer... 

Badge

So, 4 days on and the plot thickens. 

It looks like the entire system just times out of the network every now and then. I’ve found this in Wifi 6 mode of the compatibility mode as mentioned above. 

Because of the way my modem and router are physically located in the house, using the SonosNet network is a little tricky. As I think I need the Sonos device linked to my wireless router, rather than directly to the modem (via a small network switch). 

I’ve also found that Asus routers did cause some issues unless “AirTime Fairness” and “IGMP Snooping” was turned off. So I’ve done that now. 

I’ve therefore 531957540 submitted a diagnostics directly to Sonos to see if they can find anything…!

In the meantime, am I right that connecting, via my modem (not WiFi router) also via a Network Switch might explain why I cannot seem to activate the SonoNet (it just drops off the app never to be found again if I plug in an ethernet cable (note I’ve tried 3 different cables into either ethernet slot of my Playbar so ruled out a hardware issue)..!

I’ll update as and when I hear more… but if anyone else can spot an obvious thing I should try, please post a reply. 

Thanks

Ben

 

 

In SonosNet mode you are advised to turn IGMP Snooping ON in order to prevent network loops.

If your network switch is managed configure it as follows Configure STP settings to work with Sonos. Finally Remove the WiFi details from Sonos system.

 

Wire either the Playbar or the left unit in a stereo pair to the WiFi router, do not use the Sub or speakers that are set up as surrounds as the solely wired items.

Badge

In SonosNet mode you are advised to turn IGMP Snooping ON in order to avoid network loops.

If your network switch is managed configure it as follows Configure STP settings to work with Sonos. Finally Remove the WiFi details from Sonos system.

 

Wire either the Playbar or the left unit in a stereo pair to the WiFi router, do not use the Sub or speakers that are set up as surrounds as the solely wired items.

Unfortunately I can’t seem to remove the WiFi settings from the system. The option is either greyed out or, it just hangs. Any way to force the system to forget the settings?

I think I you’ve answered my query to say I must connect to the WiFi router rather than just the modem via an unmanaged (dumb) network switch?

@BunkMuffin, You didn’t disable the wireless radio on the wired unit, did you? If so re-enable it for “Disable WiFi” is disabling SonosNet.

 

Afterwards remove the WiFi details as follows: On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to 'Settings → System → About my Sonos System' and see if WM:0 is being displayed next to each unit.

Badge

@BunkMuffin, You didn’t disable the wireless radio on the wired unit, did you? If so re-enable it for “Disable WiFi” is disabling SonosNet.

 

Afterwards remove the WiFi details as follows: On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to 'Settings → System → About my Sonos System' and see if WM:0 is being displayed next to each unit.

So the modem (which is where the Ethernet cable running into the playbar) has its WiFi disabled. This is so it doesn’t interfere with my wireless router (the sky modem is crap for wireless, hence linking it via wan to a better WiFi router) which has its WiFi radio set as on.
 

Are you suggesting that the modem should have wireless radio turned on, because it is where the Ethernet signal is passing into the playbar?

No, I wasn’t referring to the modem. You should wire the Playbar to the WiFi router otherwise you won’t see it as it’s most likely on a different subnet.

Badge

No, I wasn’t referring to the modem. You should wire the Playbar to the WiFi router otherwise you won’t see it since its most likely on a different subnet.

Ok. My challenge is that the WiFi router isn’t really accessible to the playbar, certainly not permanently. The modem, however, is another thing and can be permanently connected to at least one unit (the playbar).

By temporarily connecting to the WiFi, would then being able to change the Sonos settings enable me to revert to using the modem and the sonosnet network?

By temporarily connecting to the WiFi, would then being able to change the Sonos settings enable me to revert to using the modem and the sonosnet network?

 

No. You mentioned a dumb network switch. If it supports IGMP Snooping cable the Playbar to the switch (provided that the switch is connected to the WiFi router).

Userlevel 7
Badge +21

The only thing I see missing is trying static/reserved IP addresses once you sort the issues following that post’s question out.

Badge

As an update:

I continue to tweak settings including channels, static DCHP IP address for Sonos and roaming rules yet still experience drop outs...

I’ve found that my Ring Doorbell started dropping connections from the 2.4GHz band too. After moving this to the 5GHz band, I’ve had zero issues… This points me back tot he 2.4GHz band…

The Wifi 6 setting continues to be a red herring… so I’ve reverted back to “Wifi 6 mode” on 2.4GHz band...

My next route is to reduce the Channel Bandwidth. Presently, the router switches between 40 and 20MHz at will on the 2.4GHz Band. After a little research I understand that the 20MHz bandwidth setting is less likely to fall foul of interference… so that’s my latest setting change… 

Again, will let things bed in and see. At least by the end of this, I’ll have learned more about home network configurations...

Userlevel 7
Badge +22

Are you using an ASUS router? The new ones are incompatible with Sonos (and other gear) based on several other threads. You need to downgrade the firmware apparently to get a compatible one.

Badge

The only thing I see missing is trying static/reserved IP addresses once you sort the issues following that post’s question out.

Thanks for replying.

Sadly, I have done this too.

Last night I went back to basics, going through a process of resetting each part, starting with the modem… I’ll test this again today and see if I can weed out the issue....

I would like to go back to a comment in your first post:

“UNLESS I turn off Wifi 6 mode and go into a compatibility mode… Then everything is fine. “

What exactly does that mean?  Does it mean that 5GHz band is turned off, or does it simply mean that the router is happy to deal with older protocols using 2.4GHz.  If the latter, then you don’t really have a problem.