Clearly there is an issue with Spotify on Sonos

  • 11 February 2017
  • 1 reply
  • 143 views

Long time listener, first time caller. Have been using Sonos for years and my whole house is wired up. After either the latest Sonos or Spotify update I get the "lost connection" error from the Spotify service on all of my Sonos devices. Every other service I use (SoundCloud, Pandora, direct, TuneIn) all work flawlessly.

A cursory look at the support forum shows that a lot of people are having this problem. Can we get a global/pinned topic on this so we can try to figure this out instead of trying to do it on a case-by-case basis? It should be noted that I participated in the beta program for 7.1 so that *could* be it but I don't see anyone else talking about that in this forum.

Please advise!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +20
Long time listener, first time caller. Have been using Sonos for years and my whole house is wired up. After either the latest Sonos or Spotify update I get the "lost connection" error from the Spotify service on all of my Sonos devices. Every other service I use (SoundCloud, Pandora, direct, TuneIn) all work flawlessly.

A cursory look at the support forum shows that a lot of people are having this problem. Can we get a global/pinned topic on this so we can try to figure this out instead of trying to do it on a case-by-case basis? It should be noted that I participated in the beta program for 7.1 so that *could* be it but I don't see anyone else talking about that in this forum.

Please advise!


Hi kveton,

There are a few different things which can cause that error. This can be due to wireless interference, network congestion or DNS timeout issues. To determine what's going on with your system I'd like to see a report from it. Please send in a diagnostic report and reply here with the confirmation number.