Choppy audio 5.1

  • 15 January 2022
  • 5 replies

I'm having issues with choppy TV audio, it drops out for a split second every few seconds. Sometimes it's the playbar dropping, sometimes the One SL surrounds. 


Playbar is wired and surrounds and sub are wireless.


Diagnostic ID is 485431841.


I've tried removing the speakers and re-adding, rebooting router etc, but it's not helped.


Generally happens with Netflix, but also happens with Amazon, Apple TV etc.


TV is LG C9 if that matters.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Please tell us about your network setup. Such as router and are there extenders, access points or switches involved. Also is it a standard router/ modem or Mesh. 

Home network is a mesh using TP Link Deco M9’s setup as access points (my router doesn’t allow setting bridge mode). 

Playbar is connected to the TV over optical and via ethernet to one of the access points, sub and surrounds are connected to SonosNet on channel 11.

This was an issue prior to setting up the Decos, but watching a movie in 5.1 on Amazon Prime earlier was so choppy it prompted me to reach out finally, usually it’s a minor irritation.

Userlevel 7

The fist step is to remove the Play bar from the access point. A Sonos product should only be wired to the main node (or router) in a Mesh.

After you remove the Playbar try setting everything up over WiFi. 

Unfortunately I can't wire the speaker to the main router.


The TV audio stuttering issue happened when the Sonos speakers were all set up wirelessly, but there were issues with Sonos speakers in other rooms becoming unavailable in the app, hence the hardwiring of the playbar to fix that.


Worth noting that the HT system plays music fine (e.g. Spotify), without any of the stuttering/dropouts. It's a TV issue only.

Userlevel 7
Badge +22

A recent Sony TV has an issue exactly like this, that requires the TV switch from WiFi to Ethernet to work-around. Strange but true. The WiFi interrupts are messing with the digital audio stream, somehow.