changed router but play6 gen2 not getting wirelessly, password wrong is what its prompting.

  • 18 January 2020
  • 3 replies

A fortnight back vendor changed and new router got connected to all appliances except play 6 wirelessly, as the network name and password was kept same to first day it got connected itself and there after everything has been done, infact spoke to customer care for more than 30 minutes but no remedy. Everytime it's prompting wrong password, did everything,  reset, lan to wireless,  factory reset, changed name/ password but nothing worked. Infact now have seen all lights a sono can turn to, white, hard white, green, yellow etc.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 6
Badge +15

Two questions:

  • Sonos needs a 2,4Ghz b/g wifi network. Is your new network maybe 5Ghz only?
  • Have you tried connecting your Sonos device by cable to your router?

1. It has both 2.5 and 5 as well.

2. It was getting connected via lan cable,


To my surprise, it got connected, perhaps completely disengagement of router from power and lan made it happen. Thanks for prompt reply.



The flashing Status light, likely mean you’re in diagnostic dump mode. Press the join/infinity button and the flashing of status light should stop, then power off/on the speaker. 

The speaker should (hopefully) reconnect to the network on startup and then settle down and be okay, but if not, I would personally look to factory reset it and quickly set it up again on the Household, using the “Add Product” option in “Settings/System” within the App ...and that should then sort it once and for all.