Question

Cast to Device and Sonos


Badge +1
Hi, hope spmeone can help. I'm on latest Windows 10, and one of the great new features was to be able to Cast To my Sonos devices. However, since I've had a new Homehub 6, the Cast To feature now shows nothing. I've had a fresh windwows install courtesy off Microsoft, refreshed in cmd, and still no luck. Has anyone else had the same issue and resolved it? To recap, could Cast to Sonos, now can't after router change (btw BT help useless)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

user236485,

I used to use kaspersky and I found it often would block things even though I had opened various ports... but I'm talking some years ago, v5 I think it was and when I uninstalled it, it caused me untold problems with internet explorer and the browser support for activeX controls ... meaning that after the uninstall, I could not see some web pages, for example, my routers login page.

Reinstall kasperskey and the browser issue was fixed.

I never could fix the problem relating to the uninstall and eventually resorted to a PC backup (without it) . It put me off using kaspersky and I switched to ZoneAlarm... which also lost its way over time and now I just use built-in windows Firewall... not had any problems since... (touch wood).

So I reckon there are still 'possibly' some issues with the kaspersky firewall and its uninstall process... they have definitely had issues in the past because they did release a special 'removal and cleanup tool' for the old software .. which also never worked for me.

So my bet is there might be some issues (in general) with that firewall... we shall have to wait and see if any other users here go onto experience similar issues.
Badge +1
I think Hub 6 is coincidental at best. The updates for Kaspersky would seem to be the issue as WD is now fully updated with no problems. Kaspersky updates continually so could easily be that, and my thoughts are that there was a clash with firewalls as either Windows or Kaspersky would never seem to be fully off
Out of interest, you initially fingered the Hub6. What else happened around that time? Kaspersky install/update, or a Windows update?
Badge +1
Well, it is finally happening. This is th trail of events: I started to roll back the latest Windows update and my pc had issues so it gave me the chance to do a proper clean auto install. What this did was install Windows defender but totally wipe Kaspersky. Result is that cast to works and all sonos devices show up on local network. Would seem Kaspersky was the issue here. I'll wait and see what the Tec guys post and post here, but once again thanks for your help
So you had kaspersky firewall aswell? So is that three firewalls?

I assume there are no other firewalls remaining and you have turned off windows firewall (public/guest and private) as shown in my screenshots attached? If you do uninstall, or have to switch them off, I would also suggest a restart of the PC and then check..

If that still doesn't work, then in Windows there is a network trouble shooter, which can scan your system and repair any network problems so that would be the next step.

And finally, if it still doesn't work after that, then it may come down to running Windows SFC .. which again is 'last resort'. The system file checker will check and repair all the windows system files. Before doing that though my advice would be to wait for tier 2 Sonos Support and see what they can do to help you.
Badge +1
I have now removed Kaspersky, enabled Windows Defender and checked that Sonos is allowed. No luck, and still in Network Sharing, no Sonos shows and in All Networks only unknown types appear which I assume are Sonos. As Sonos works with in every other respect for some reason my sharing does not fully see Sonos
I have just checked that my Windows 10 PC is all upto date and the casting feature is still available to me (see screenshots), so I don't suspect it's the latest Windows update - The third party firewall, or windows firewall, is still looking the most likely area to focus on. Hope that helps a little.
In fact I will go and just update my windows 10 PC with the latest MS updates and see if I get any issues with casting and I will let you know shortly, that will save you uninstalling your windows update perhaps.
Yes, it is a strange issue my thoughts are not the windows firewall but the other firewall you mentioned. I think you said you had two in place. Normally when you install a third-party firewall it disables the windows firewall and takes control. I have seen issues similar to this with older versions of kaspersky firewall causing issues with access to uPnP/DLNA media streaming services .. but the fact you had switched things off should have resolved those issues.

In the windows control panel under the admin tools section is the 'Services' icon which will show you the services starting automatically or manually (delayed or otherwise) on your PC ... I would look through those for ones related to your 'third party' firewall and temporarily set them to disabled .. make a note of the changes you make so you can set them back later. Reboot the PC .. when you do this it may hand control back to the windows firewall and that too will then need to be checked that it is switched off ... I'm guessing you know how to do that. Then you may need to reboot again and see if that resolves the issue.

That would be the steps I would take ... there are other things we can do and that is to look what the PC is actually launching at startup besides the usual services but i would just go with disabling the related 'third party' firewall services for now.

Oh and you could alway uninstall the last windows update you mentioned, if necessary, just to test if that fixes the issue.

I'm sure the Sonos Support will sort it for you though in due course. Let me know what happens please and what was actually required to fix it. It would be nice to know for next time this happens to someone.

Thanks
Badge +1
Unfortunately I'm still facing problems despite the great help here. Did speak to Sonos yesterday who are baffled but are getting the tec support team to look at this. Their thinking is that this is something to do with the Windows firewall doing something even though apparently off. This is something since the last Windows security update.
I have also noticed here;
https://sonos.custhelp.com/app/answers/detail/a_id/42/~/sonos-and-incompatible-hardware

The BT Smarthub 6 did, at one point, have some incompatibility issues with Sonos and was handing out duplicate IP addresses, but this was resolved by an automatic update. I would however just check your router definitely has the latest firmware update installed. I suspect it will have done that automatically, but perhaps check it, just in case.
user236485

By same subnet, I mean that everything is connected to your router on an IP address between 192.168.1.1 through to 192.168.1.254 and that they have the same subnet mask of 255.255.255.0

Make sure all your devices are on the same routers wifi connection and not on another connection like a 'guest network' for example and I assume you are not using any any wifi extenders or powerline adapters to extend your network, as devices connected to these 'sometimes' have difficulty linking through to each other.
Badge +1
Many many thanks for the suggestion and will follow this today. One question though, how do I confirm all running on the same IPv4 subnet?
I would next turn things off and starting with the router bring the devices back on line one at a time. Giving each one a few moment to settle and get its IP address. Do you normally run your Sonos devices on SonosNet (meaning you have one device cabled to your network), or do you run them just on wifi ?

If you run on SonosNet just bring the device online cabled to your network first and ensure you can see that in whatever Sonos controller you use... then bring on your next Sonos device and check that appears in the controller and continue until they are all back up and running. Note only one device needs to be wired to the network for them to all be running on SonosNet. You will not need your router wifi credentials stored in Sonos ’Settings/Advanced Settings/Wireless Setup if (and only if) you are running on SonosNet, so remove those ... you can always switch to your own wifi later in Wireless Setup if you prefer to do that and not have any of your Sonos devices cabled to the network.

If they appear in your Sonos controller then they should begin appear in your PC casting list... I assume everything is running on the same IPv4 Class C local subnet 192.160.1.0/24 (254 hosts) 255.255.255.0

Let's see if that works ...
Badge +1
Well, a development in that the Cast To feature now shows Blu Ray player but alas no Sonos. This is after unchecking and checking all sharing permissions
user236485

See my screenshot attached to this post and also uncheck and re-check the option shown in Windows Media Player... this is in addition to disabling and reenabing the windows media sharing service.
Before doing that, I would disable and re-enable the windows media sharing service. I assume that is what has the built in MS Casting Facility ... that might fix it. Resetting your Sonos system is usually done only as a last resort.

Your computer name looks fine to me by the way... so just leave that as is.
Badge +1
Computer name shows as User-PC. The one difference between my sharing picture is your Sonos devices are named whereas mine are all unknown- Windows has failed to recognise them so I think I may need to reset the Sonos network as though new to resolve this
Right click 'my computer' if you have it on your desktop ... select properties and you can see/rename the computer from the tabbed dialog box that appears... or access the same screen via the control panel/system icon.
Badge +1
Wasn't quite sure if I could check that in Windows 10 as all I could see was BIOS version name which was the motherboard brand
By the way did you check the netbios name of the PC was 16 characters or less, as that may affect access?.. I know it applies to shared library folders but not sure if it applies to the UPnP/Media servers.
user236485

Here is my windows media streaming device list (see screenshot) ... Windows 10 does correctly identify the Sonos devices. So I suspect your issue is with Windows rather than with Sonos .. you appear to have "customised" streaming preferences setup in the case of one device shown. I don't know why that is, or if that is the cause of the issue. Perhaps turn off the media streaming sharing service, reboot and then re-enable it. That would be my suggestion.

Badge +1
Latest is that Ihave enabled the Smart Hub 6 firewall and connected the PC to the Connect box. Result is that the hub connections show as in attached but in Windows Network Sharing Sonos shows as unrecognised devices, which suggests that the PC knows something is connected but can't read it's name - interesting that they don't show in local network

I assume the Smarthub6 firewall is software for the PC ... make sure it hasn't restarted its service after your reboot... check the services in control panel and ensure it is stopped at the very least.
I assume the other controllers are working fine
Now that the two firewalls are disabled ... Try refreshing (not reinstalling) your windows Sonos Controller App and reconnecting it to the existing Sonos network. See if that fixes it. Did you ensure the PC name was less than 16 characters by the way ... it's a good thing to check and do that anyway.