Question

Cast to Device and Sonos


Badge +1
Hi, hope spmeone can help. I'm on latest Windows 10, and one of the great new features was to be able to Cast To my Sonos devices. However, since I've had a new Homehub 6, the Cast To feature now shows nothing. I've had a fresh windwows install courtesy off Microsoft, refreshed in cmd, and still no luck. Has anyone else had the same issue and resolved it? To recap, could Cast to Sonos, now can't after router change (btw BT help useless)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

Is the Windows machine on WiFi? If so which band? And how is your Sonos system set up?
Badge +1
Hi, windows 10 is through Ethernet. At the moment Sonos runs via s wired connect but have ran it wireless but still same results re cast to
Well if it doesn't work with both your PC and Sonos on the wired segment it seems strange that the Hub6 should have affected things.

Presumably the computer is wired to the router. You could try wiring it to a Sonos unit instead, then it really would bypass the Hub6.
user236485,

My first thoughts, it could simply be a 'local' PC firewall issue. Does it work with the firewall switched off?

One other thing to check is possibly the netbios name of the newly installed PC...is it longer than the 16 characters and needs to be reduced perhaps? It's worth checking the name of the PC anyway.
Badge +1
Thanks both. The hub has a firewall which only seems to allow port forwarding so will knock that off and attempt the other suggestions, and will report back
I was thinking more of it being perhaps the firewall on your newly installed Windows PC. The routers firewall is irrelevant in your situation as the issue is occurring across the LAN. Try switching off the firewall on the PC temporarily to see if that is what is causing the issue .. I would restart the PC after disabling it and then check. Once the cause is found, it will be easy to fix I'm sure.

After you have checked, then don't forget to re-enable the firewall.
Badge +1
OK - firewall is off (i had two I found out - one via Windows and one through Smarthub6!) but no joy with cast to after restarting - for info this is the view of my 2.4ghz connected devices:

There's no firewall in the Hub6 between local devices, and I'd strongly recommend you don't disable the external firewall.

Your table shows a Sonos player on WiFi. I thought you had a wired CONNECT? I would suggest you try wiring the computer to its second port as an experiment.
I assume the other controllers are working fine
Now that the two firewalls are disabled ... Try refreshing (not reinstalling) your windows Sonos Controller App and reconnecting it to the existing Sonos network. See if that fixes it. Did you ensure the PC name was less than 16 characters by the way ... it's a good thing to check and do that anyway.
I assume the Smarthub6 firewall is software for the PC ... make sure it hasn't restarted its service after your reboot... check the services in control panel and ensure it is stopped at the very least.
Badge +1
Latest is that Ihave enabled the Smart Hub 6 firewall and connected the PC to the Connect box. Result is that the hub connections show as in attached but in Windows Network Sharing Sonos shows as unrecognised devices, which suggests that the PC knows something is connected but can't read it's name - interesting that they don't show in local network

user236485

Here is my windows media streaming device list (see screenshot) ... Windows 10 does correctly identify the Sonos devices. So I suspect your issue is with Windows rather than with Sonos .. you appear to have "customised" streaming preferences setup in the case of one device shown. I don't know why that is, or if that is the cause of the issue. Perhaps turn off the media streaming sharing service, reboot and then re-enable it. That would be my suggestion.

By the way did you check the netbios name of the PC was 16 characters or less, as that may affect access?.. I know it applies to shared library folders but not sure if it applies to the UPnP/Media servers.
Badge +1
Wasn't quite sure if I could check that in Windows 10 as all I could see was BIOS version name which was the motherboard brand
Right click 'my computer' if you have it on your desktop ... select properties and you can see/rename the computer from the tabbed dialog box that appears... or access the same screen via the control panel/system icon.
Badge +1
Computer name shows as User-PC. The one difference between my sharing picture is your Sonos devices are named whereas mine are all unknown- Windows has failed to recognise them so I think I may need to reset the Sonos network as though new to resolve this
Before doing that, I would disable and re-enable the windows media sharing service. I assume that is what has the built in MS Casting Facility ... that might fix it. Resetting your Sonos system is usually done only as a last resort.

Your computer name looks fine to me by the way... so just leave that as is.
user236485

See my screenshot attached to this post and also uncheck and re-check the option shown in Windows Media Player... this is in addition to disabling and reenabing the windows media sharing service.
Badge +1
Well, a development in that the Cast To feature now shows Blu Ray player but alas no Sonos. This is after unchecking and checking all sharing permissions
I would next turn things off and starting with the router bring the devices back on line one at a time. Giving each one a few moment to settle and get its IP address. Do you normally run your Sonos devices on SonosNet (meaning you have one device cabled to your network), or do you run them just on wifi ?

If you run on SonosNet just bring the device online cabled to your network first and ensure you can see that in whatever Sonos controller you use... then bring on your next Sonos device and check that appears in the controller and continue until they are all back up and running. Note only one device needs to be wired to the network for them to all be running on SonosNet. You will not need your router wifi credentials stored in Sonos ’Settings/Advanced Settings/Wireless Setup if (and only if) you are running on SonosNet, so remove those ... you can always switch to your own wifi later in Wireless Setup if you prefer to do that and not have any of your Sonos devices cabled to the network.

If they appear in your Sonos controller then they should begin appear in your PC casting list... I assume everything is running on the same IPv4 Class C local subnet 192.160.1.0/24 (254 hosts) 255.255.255.0

Let's see if that works ...
Badge +1
Many many thanks for the suggestion and will follow this today. One question though, how do I confirm all running on the same IPv4 subnet?
user236485

By same subnet, I mean that everything is connected to your router on an IP address between 192.168.1.1 through to 192.168.1.254 and that they have the same subnet mask of 255.255.255.0

Make sure all your devices are on the same routers wifi connection and not on another connection like a 'guest network' for example and I assume you are not using any any wifi extenders or powerline adapters to extend your network, as devices connected to these 'sometimes' have difficulty linking through to each other.
I have also noticed here;
https://sonos.custhelp.com/app/answers/detail/a_id/42/~/sonos-and-incompatible-hardware

The BT Smarthub 6 did, at one point, have some incompatibility issues with Sonos and was handing out duplicate IP addresses, but this was resolved by an automatic update. I would however just check your router definitely has the latest firmware update installed. I suspect it will have done that automatically, but perhaps check it, just in case.
Badge +1
Unfortunately I'm still facing problems despite the great help here. Did speak to Sonos yesterday who are baffled but are getting the tec support team to look at this. Their thinking is that this is something to do with the Windows firewall doing something even though apparently off. This is something since the last Windows security update.
Yes, it is a strange issue my thoughts are not the windows firewall but the other firewall you mentioned. I think you said you had two in place. Normally when you install a third-party firewall it disables the windows firewall and takes control. I have seen issues similar to this with older versions of kaspersky firewall causing issues with access to uPnP/DLNA media streaming services .. but the fact you had switched things off should have resolved those issues.

In the windows control panel under the admin tools section is the 'Services' icon which will show you the services starting automatically or manually (delayed or otherwise) on your PC ... I would look through those for ones related to your 'third party' firewall and temporarily set them to disabled .. make a note of the changes you make so you can set them back later. Reboot the PC .. when you do this it may hand control back to the windows firewall and that too will then need to be checked that it is switched off ... I'm guessing you know how to do that. Then you may need to reboot again and see if that resolves the issue.

That would be the steps I would take ... there are other things we can do and that is to look what the PC is actually launching at startup besides the usual services but i would just go with disabling the related 'third party' firewall services for now.

Oh and you could alway uninstall the last windows update you mentioned, if necessary, just to test if that fixes the issue.

I'm sure the Sonos Support will sort it for you though in due course. Let me know what happens please and what was actually required to fix it. It would be nice to know for next time this happens to someone.

Thanks