• 22 December 2016
  • 2 replies

Hi, Have had all sorts of problems with my Sonos controller for Mac. It was working fine, then started repeatedly asking to allow incoming connections. I tried to uninstall and reinstall, reboot the Play1 and router etc etc but I keep getting loads of errors - unable to play ... unable to connect to //music folder, error occurred adding to queue (1002), unable to access music, etc. I've uploaded diagnostics with reference 6904436. Would really like this to be fixed before guest arrive for Christmas! Beginning to lose faith in Sonos as a system!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Connection problems which appear suddenly are often caused by network problems, not Sonos problems. The typical cause is duplicate IP addresses. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. To cure this, you need to refresh the IP's on your entire network. Do the following:

Reboot/power cycle your devices in the following order:

Switches or hubs
Wired Sonos units
Wireless Sonos units
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.
Thanks. We did have a power outage and also had to reboot the router so this may have been the cause. In the end I resolved it by factory resetting the Play 1, uninstalling the Sonos controller including deleting any related files or folders (including cache and preference files in the Library folder - several files with .plist extension, this is only for the Mac, not sure what Windows files would need removing), and then reinstalling from scratch - this seems to have worked. First few reinstalls missed some sonos files on the system so you need to clear all of them to get a clean install.