Answered

cant connect to system - frequent error this week

  • 29 September 2021
  • 5 replies
  • 66 views

I have a gen 1 play 5 and a Beam. I haven’t changed anything on the network but the last few days the controller can’t connect to Sonos. Sometimes resetting the router works, but other times not, and nothing else in troubleshooting list is working. Am using S1 as I have old play 5, but tried S2 today and it could find the Beam but not connect. At a loss

icon

Best answer by Corry P 1 October 2021, 13:17

View original

5 replies

I’ve just had this problem with a couple of 5s.  For about an hour the S2 app would not pick the 5s up; despite wifi signal not having changed/weakened.

Problem seems to have resolved itself now, without me needing to reset my broadband/wifi hub.  

This was a common problem I had with my Sonos products about a year ago, but so far this year they have been behaving most of the time.

 

I spoke to soon, the problem has returned.

The app is saying my wifi is the problem.  However, my Move is working fine in the room where the 5s are and my wifi signal strength has not dropped.

Additionally, I cannot access Calm Radio now.

Userlevel 7
Badge +17

Hi @Nowshesaturtle

Welcome to the Sonos Community!

Do you have anything that extends the range of your WiFi? If so, please try turning it off to see if that helps. If it does, you can turn your device back on again, and things should remain stable - at least until the speakers or network are rebooted. Rebooting the extender again afterwards will again resolve this, but temporarily. 

Sonos does not support the use of WiFi extenders as they typically do not do a good job, often filtering certain types of network packet that Sonos relies upon. Instead, we recommend the use of a much more robust mesh WiFi system.

If you don’t have any extenders, I recommend you try resetting the Sonos app. Once done, when you re-open the app you will need to opt to “Connect to an existing system”.

I also recommend that when you reboot your router, you leave it off for at least 30 seconds - if you did not do this, please try. It really can make a difference.

I hope this helps.

@Alexroy - the same advice goes to you :grin:

No extender. The only thing that changed was an upgrade to iOS15.  I’ve hardwired the two speakers and they seem to be OK at the moment.

Userlevel 7
Badge +17

Hi @Nowshesaturtle 

Apologies for the delay - I was on holiday.

There are a couple of options in iOS that can affect connecting to Sonos and may have been reset during the iOS upgrade process.

Specifically, these are Local Network permissions which should be on (iPhone Settings » Sonos » Toggle Local Network on) and Private WiFi MAC Address, which needs to be disabled:

  1. On your iPhone or iPad, open the Settings app
  2. Tap Wi-Fi
  3. Tap the blue “i” next to a network (one you’re already connected to or not)
  4. Tap the toggle next to Private Address to unmask your iPhone or iPad’s Wi-Fi MAC address (disable the option)
  5. If you’re switching this off while already connected to a network, tap Disconnect to finish the process (you’ll automatically reconnect to the Wi-Fi network in a moment)

That the speakers connect to your iPhone while hard-wired suggests that there may be a configuration issue with the router, however - you’re not using a guest WiFi are you? That would isolate WiFi devices from each other, though it should also isolate them from ethernet too.

I hope this helps.

Reply