Answered

Cannot use Airplay with

  • 22 October 2019
  • 6 replies
  • 137 views

I’ve lost airplay and I’m struggling to troubleshoot as too many changes happened at the same time.

I have two Sonos One and my old trusted Play 1 speaker.

I run an iPhone on IOS 13.1.3 , Mac on Mojave 10.14.6 and I’ve recently changed ISP.  I

’ve disconnected the Play 1, just in case it was creating the issue, however I’ve still not recovered the ability to Airplay from either Apple devices.

The router was recently changed. When I reconnected the two Sonos One to wifi, it didn’t make a difference.

What am I missing?

icon

Best answer by Ken_Griffiths 23 October 2019, 21:45

ToKn,

A few simple things to perhaps try…

  • reboot the router
  • reboot the phone 
  • power off/on all the speakers
  • check any firewall settings on the MAC
  • reset the network settings on the phone and recreate the WiFi network connection to your new router
  • reset the Sonos controller App and then connect back to the existing Sonos System (Do not create a new system) 

Do each of the above mentioned items in order and see if the speaker (rooms) reappear in the Airplay list after each step, before moving onto the next. You may not need to complete the list if you do get things working.

View original

6 replies

I think, based on your descriptions, what you’re missing is a connection between the iPhone and your wifi. 

Have you tested AirPlay 2 on your Mac? Does it work?

The PLAY:1 being connected or not doesn’t (shouldn’t) have any affect on this situation. But a smart test to reduce variables :)

I’d also try connecting one of the Sonos Ones to the router with an ethernet cable, temporarily, to see if that makes a difference. As before, taking out one of the variables in order to figure out where the real issue lies.

Oh, you’re not, by any chance, using the two Sonos Ones as surround speakers for a PLAYBAR, are you?

The thing is I cannot see my Sonos speakers via Airplay anymore Whilst the Sonos app works on my iPhone and on my Mac, I do not even get an airplay option. I do not have other device I can test with but the two Sonos One.

Your question about surround speaker prompted me to go again in the iPhone app, but the speakers are set up each in their own right.

When I go into Network > Wireless Setup> Networks it shows the correct router all the devices are linked to (iPhone, Sonos...).

System > Airplay dutifully lists my two Sonos One speakers.

I tried to use the HomeKit but they do not appear.

I cannot fathom why I do not get the Airplay option anymore on either iPhone nor Mac. The router is brand new, the iPhone too and it used to work before. The Sonos apps are up-to-date, the speakers too.

I cannot pin point exactly when it stopped working which is a real pity as it would explain why it’s not working now.

ToKn,

A few simple things to perhaps try…

  • reboot the router
  • reboot the phone 
  • power off/on all the speakers
  • check any firewall settings on the MAC
  • reset the network settings on the phone and recreate the WiFi network connection to your new router
  • reset the Sonos controller App and then connect back to the existing Sonos System (Do not create a new system) 

Do each of the above mentioned items in order and see if the speaker (rooms) reappear in the Airplay list after each step, before moving onto the next. You may not need to complete the list if you do get things working.

I’d certainly agree with Ken_Griffiths here. Each time I’ve had trouble with my AirPlay 2 in my system, a reboot of the iOS device has fixed it. So far, for me, it’s never been an issue with the Sonos, it’s always been the Apple device. However, that’s just my experience, not a guaranty.

AND IT WOOOOOOOOOOOOOOORKS *** Victory dance with airplayed music***.

Ahem….It was the router’s firewall. I’ve allowed the two speakers’ MAC addresses and I now see the airplay option on the iPhones & Mac.

Thank you both for the detailed and clear advice. 

Reply