Question

Cannot update sonos system (connect)

  • 23 December 2016
  • 5 replies
  • 386 views

Hi there,
I want to use my sonos system but i will not let me update.

i get the message: sonos needs to be updated before you can use it. please ask the sonos owner (me) to make sure everything is set up correctly.

if i go into the manage menu of the controller, it won't let me select anything.
Cant find any related issues regarding this.

Please help!

Regards,
D

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Anyone that can help me solve this?
Several questions, if anyone is going to be able to help you.

1) What are the speaker(s)/devices you have? (note: I see you identify the Connect in the title, do you have anything else?)
2) What machine is the controller on (PC/Mac/SmartPhone type)
3) What operating system is on the device that you have the controller on?
4) Which version of the controller are you using?

Based on the "can't select anything" statement, I'd hazard a guess that you're probably on a non-supported operating system, and that the controller has greyed out options. See the data here:

https://sonos.custhelp.com/app/answers/detail/a_id/127/~/sonos-system-requirements

But that's just a guess. If you can provide answers to the above questions, the many folks who frequent these boards might be able to hone in on a better answer.

Oh, one more thought. Have you tried connecting the Connect to your router directly with an ethernet cable while doing the update?
HI there,
thanks for your questions.

1. I just have a connect which is linked to my amp + B&W speakers
2/3. PC, Win 10
4. The one i could find was: SonosDesktopController70
5. Connection = router -- > hub --> connect
6 It is able to find the Sonos, just not able to select anything because of indeed greyed out options.

I think the problem occurred when i switched to windows 10. But i cannot be 100% sure since i had not used the sonos for a while. I did not change anything else.

Hope this additional information helps.

Kind regards,
D
Yea, I'll hope someone else jumps in on this, since I use a Mac or an iOS device to control my system. While I have a PC with Win10, I don't have music on it, so I've never installed the app on it. But what is your hub that sits between the router and the connect? Have you tried connecting the Connect directly to the router, rather than going through the hub?

There are several more knowledgable networking gurus here that hopefully will chime in, once they've read this thread.
Userlevel 5
Badge +3
Hi Deition (welcome to the community!) and thanks to you Airgetlam for assisting here.

@Deition, could you please send me a diagnostic number? I will have a look at it.