Answered

Cannot get SONOS to play from WD My Cloud Home NAS

  • 24 March 2018
  • 6 replies
  • 1985 views

Hi all
I recently purchased a WD My Cloud Home NAS server. I have already a SONOS system in the house.

I have some very inconsistent problems in getting my SONOS to play any music.
At first I set up PLEX on the NAS server to contain the media. Whislt it works fine for DVD Movies, I gave up trying to get it to work with music.
My music collection is currently on a PC. Sonos plays no problem from the pC libary. The music is encoded .m4a
I have copied some of the albums across to the WD NAS. I also using EAC (Exact Audio Copier) ripped a CD to the NAS.

I was able to see the WD Server in the SONOS app as "My Cloud Home"
However I could only see a couple of the albums in the folder. Of those that I could see, none of them would play through SONOS - the error being "Unable to play XXXX as the song is not encoded properly."
Yet they played OK on the PC. Also they all play OK direct onto the PC from the My Cloud Home app.

Please - anyone able to help me????

Thanks in advance

John
icon

Best answer by Stanley_4 24 March 2018, 17:52

I'm not sure about your Plex setup, never used it here with my WD and Sonos, so some of what you did to get it to work may be impacting the sharing. I just followed this from the support folks:

https://sonos.custhelp.com/app/answers/detail/a_id/79/kw/wd%20nas (searching support for wd nas)

Support has this on Plex, I didn't read it, just providing the link:

https://sonos.custhelp.com/app/answers/detail/a_id/4057/kw/wd%20nas
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +22
Did you try going via setup. Music library. Add other to wd drive and let Sonos index (no plex)
Hi Chris

Yes - I try to link via Network device - Browse to the network in the explorer. Lodate the folder on the NAS with the music. Then click next. Now it wants Username and Password. Unable to move on without putting something in these fields, but you can type something and delete it and the "Next" button is enabled. Then It goes off and thinks about it for a minute or two and comes back with the error
Sonos is unable to add the music folder - Check the path to the folder and Username and password are correct.

So frustrating.....

John
Userlevel 7
Badge +21
I'm not sure about your Plex setup, never used it here with my WD and Sonos, so some of what you did to get it to work may be impacting the sharing. I just followed this from the support folks:

https://sonos.custhelp.com/app/answers/detail/a_id/79/kw/wd%20nas (searching support for wd nas)

Support has this on Plex, I didn't read it, just providing the link:

https://sonos.custhelp.com/app/answers/detail/a_id/4057/kw/wd%20nas
Userlevel 7
Badge +22
Mid be somethjng with the security setting in the wd. I’m not familiar with.
Userlevel 5
Badge +12
All my CDs are ripped in FLAC format to the WD MyCloud in Public folder, never had a problem with Sonos connecting and playing them.

Maybe check SMBv1 is allows on the MyCloud.
@jatclarke999 The My Cloud Home service in SONOS did not have m4a support while the service was in Beta state. Now that the service is fully launched, give it a try again and see if it works now.