Question

Cannot change Alarm music with Tidal

  • 15 January 2021
  • 11 replies
  • 133 views

Since the last update to my Play One and S2

app, I can no longer adjust the music on any alarms, new or existing.

i have a series of Alarms with music defined, that leverages Tidal. I change the music every now and again to reflect what I’m currently listening to.

Alarms with existing tracks/albums/playlists chosen from Tidal work as expected. 
 

if I try and create a new alarm, I can’t choose music from tidal. I see the top level categories (Artists, Albums, etc), but can’t browse them, the app selects the category instead.

If I try and create an alarm using another service (amazon prime for example) I can browse fine.

From within the main music part of the application, I can browse Tidal as usual and can play music directly. 

There seems to be a bug/regression or similar that has broken the browsing function within the alarm, but only for tidal.
 

I’ve tried deleting and reinstalling the app,,to no avail. 
 

Any ideas?

 

Thanks

 

Dan

 

 


11 replies

Since that data is stored on the computer memory in the speaker, it’s unlikely anything would change if you uninstall and reinstall the app. 

I’d start by a simple reboot of that speaker, by unplugging it from the wall for two minutes, then plugging it back in. That would force a reload of the OS on the speaker. Then check to see if you can access and change the alarm.

If the issue continues, and you have more than one Sonos device, feel free to factory reset only the Sonos speaker that you’re setting the alarm on. If this is you’re only speaker, though, I would recommend not doing it, though, as it would erase all your settings. 

If the issue is continuing, I would recommend that you submit a system diagnostic within 10 minutes of working on the alarm, and call Sonos Support to discuss it, or post the diagnostic number here for a Community Moderator to pick up.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis.

Thanks for the reply Bruce.
 

have already rebooted the speaker, but didn’t leave it for a period. Will give that a go. It is my only Sonos device (I only use it as an alarm clock), but I may give a reset a go if the above doesn’t work.

 

thanks

 

Dan

Worth a shot, although if you’ve already rebooted it once, my expectations are lower than before. Definitely do not factory reset it, but do send in the diagnostic, and either post the number here or call in. They’ll likely be able to see what’s going on….but if you factory reset it, it just will erase that data, and they won’t see anything. 

Just as an extra troubleshooting step, try a reboot of the router while the Sonos is unplugged. It certainly wouldn’t hurt, and has a (low but not zero) chance of helping. 

Same problem here, I hope they are gonna fix that problem soon. :/

What did Sonos say when you submitted a diagnostic, and called in?

I’m having the same issue. Is there any more info on this fault, none of the solutions have worked for me so far.  
Thanks Paul

What did Sonos say when you called in, and gave them your diagnostic?

Userlevel 2

Same problem. Please fix, Sonos!

Same. I can select Tidal for my alarm and select the first level of options but I can't specifically select one of my playlist. That was an option. I would like to select a playlist in Tidal to wake up to. 

Userlevel 7
Badge +21

This is a TIDAL problem, not Sonos. They have messed up their metadata. You need to ask TIDAL to fix it, not a Sonos issue.

Userlevel 7
Badge +21

Specifically it is because “canPlay” has been set on the topmost items,which prevents enumeration when in alarm music picker.

 

Reply