Cannot add my music library; get the "The computer refused to let Sonos connect to it" message.

  • 13 October 2014
  • 34 replies
  • 18402 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

AustinBike, your solution help us, because I started to look at MacOS settings rather than Sonos software as the solution. Thank you! Definitely must have the SMB checked in the "File Sharing" options of the MacOS Sharing Control Panel.

However, the rest of the answer seems to be a matter of ensuring that the "Shared Folder" is checked in the "Get Info" dialog for the "iTunes Media" folder. That solved it for us.
Same here. Running Win10 and Play:1. I have checked firewall, file sharing, shared music folder etc. Like others, I can add a single folder under the \music folder but trying to add the \music folder with multiple folders under it fails. Says my PC is not allowing the share. I have tried adding the Music library as well as a folder on a USB Drobo. Same results. I've tried all of the Windows hacks in this thread but so far none have worked.
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 
Thanks. This worked for me (//computername/sharename). Note however, the link no longer works.
For me I changed the file sharing options on my iMac System/Sharing/file sharing and options
Userlevel 1
Badge
Same here. Really frustrating
!!!
FYI... Sonos was running on an existing system and my local music library was running fine. Purchased a new PC and moved the music library to an external USB 3.0 drive. When trying to add the moved library to Sonos, the computer refused the Sonos connection.

The solution was to move the external USB drive from a USB hub and directly plug it into the computer. Worked fine just then. For some reason the hub introduced something that interfered with the computers sharing/security/protocol (who knows) rules.

This might not be the solution for everyone, but it is one more thing to try!

Good luck and good listening.
After attempting to add my music library, I get the "The computer <my computer name> refused to let Sonos connect to it" message. 

I have both configured my firewall, and disabled the firewall settings per the Sonos suggested settings within the Guided Assistance FAQ.  Unfortunately, still cannot add the music library.

I'm able to stream through the various music services (Rhapsody, SXM, Pandora, TuneIn, etc.) however.

Thanks in advance.

For anyone using Synology NAS ensure 'Control Panel -> File Services -> Windows File Service' is enabled so Sonos can connect with CIFS Confirmed this is now working for me
That was it... Thanks!!
To solve this, you need to open your music folder in finder, "/Users/xxxx/Music/iTunes/iTunes Media", then right click on that folder, and show info (or shortcut cmd + i). It will show the info box i have attached, when Sonos tries to access that folder, it shows an additional name "SonosDMS" in the permissions, change the privilege from "Custom" to "Read only"... Sonos will now be allowed to see that directory.

Now back in the sonos preferences, library setup, click "In my Music folder", it should work fine.