Cannot add my music library; get the "The computer refused to let Sonos connect to it" message.

  • 13 October 2014
  • 34 replies
  • 18420 views

After attempting to add my music library, I get the "The computer <my computer name> refused to let Sonos connect to it" message. 

I have both configured my firewall, and disabled the firewall settings per the Sonos suggested settings within the Guided Assistance FAQ.  Unfortunately, still cannot add the music library.

I'm able to stream through the various music services (Rhapsody, SXM, Pandora, TuneIn, etc.) however.

Thanks in advance.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Userlevel 5
Badge +3
Hello Mark,

If you are still getting this error after you re-configured and disabled your firewall, I'd recommend that you call into our support line so we can take a deeper look.

This particular error message indicates an issue with the firewall or permission settings which is inhibiting Sonos from accessing the content properly. Even with the firewall disabled completely, there may be some settings that are lingering in the background which are causing conflict. 
Hi there.

I'm having the exact same problem here - and for the life of me I can't work out what's causing it! Any light that's shed on the issue above would be very useful - please share.
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

i get the same thing and my firewall isn't on.
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

hi yes, i was trying from my macbook
Userlevel 7
Badge +22
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

Here is some info on setting up Mac sharing

https://sonos.custhelp.com/app/answers/detail/a_id/2413/~/mac-os-x-music-sharing-help
Userlevel 5
Badge +3
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

Hi Bill,

The FAQ that Chris linked will have some useful steps to get your music library up and running. 

If you run into further issues, please submit a diagnostic and I'll be happy to take a look. Please reply back with your number here. 
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

i can now add one folder on my computer, but a different location won't work. i've had my sonos play1s for two years, and lately i've been having problems. diagnostics sent. #4456264 
Userlevel 5
Badge +3
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

Hello Bill,

What error message is it giving you when you try to add the other folder? Try adding the music folder manually to see if you get the same error message. 

If this doesn't work, please submit another diagnostic and send it our way. We'll then create an incident with our Customer Care Team to have a closer look. There may be a permissions issue or a folder issue which is not allowing Sonos to complete the index of that particular folder. 
Userlevel 5
Badge +2
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

Dominique,

I am getting the same error on my Sonos controller apps (iOS as well as Windows) when name resolution is used (e.g. \\hpc\Share ...) while the path via IP address works (\\192.168.25.1\Share ...).

The DNS resolver however works in the network as i can ping the the system from any device by name as well as ip address.

Not sure what it is. Looking at the config entries on the player under /status/etc/resolv.conf the name-server is correct. Same for /status/ifconfig, all settings are correct. The only potential errors i can find are under /status/opt/log/anacapa.trace with multiple entries for 
"<diag:dns,1> msmetrics.ws.sonos.com lookup failed "

A manual ping/nslookup to msmetrics.ws.sonos.com doesn't resolve.

Thanks
I was trying to add the folder manually (it wasn't in the music folder).  The error message I get is this:

Sonos was unable to add the music folder
The computre "NAME" refused to let Sonos connect to it

It lets me add the music folder, just not anything else, and most of my music is not in "music" on my mac. New diagnostics: 4491508 
Userlevel 5
Badge +3
Guys, I was experiencing the same thing.  I tried all of the firewall settings, share folder settings, reset controller, uninstall/reinstall etc etc ... nothing worked.  I then tried manually adding the folders and it worked.  So I tried letting Sonos automatically add the next one and, you guessed it, the same error.  I then manually added the same file path (cut & paste) and it worked like a charm.

Something must be screwy in the automatically add folders function (are you listening Sonos?).

The instructions below are pretty good, but it misses a step which could be confusing.  To manually add a file path, you SONOS -> Preferences -> Music Library -> [+] -> select the third option "On a networked device...".  Type in the file path as instructed and follow the steps.

If you are unsure of the file path name, then step through the automated process and copy the file path, and go back to the manual process.

I hope this works for you. 

https://sonos.custhelp.com/app/answers/detail/a_id/2414/related/1 

Hello Bernhard,

I've created a ticket for you so one of our technicians can take a deeper look at your system. We've seen network name/conflicts that do not allow certain computer to be added; however, you can add them via the IP as you have mentioned. We can investigate why we're unable to see the computer names and take a look at your system overall. 

When you have some time, please give us a call and we'll be happy to take a look. Your reference number is: 150414-000780
Userlevel 5
Badge +3
I was trying to add the folder manually (it wasn't in the music folder).  The error message I get is this:

Sonos was unable to add the music folder
The computre "NAME" refused to let Sonos connect to it

It lets me add the music folder, just not anything else, and most of my music is not in "music" on my mac. New diagnostics: 4491508 

Hello Bill,

I've created an incident for you as well. If you are able to add the music folder but not the secondary folder with your music in it, it points to potential permissions issue with that particular folder. 

Please give us a call when you can and our technicians will take a look and ensure that Sonos is able to pull in all of your music for you. We can also go over those settings and make sure everything is in order. Your reference number is: 150414-000943
Userlevel 7
Badge +22
Hello Mark,

If you are still getting this error after you re-configured and disabled your firewall, I'd recommend that you call into our support line so we can take a deeper look.

This particular error message indicates an issue with the firewall or permission settings which is inhibiting Sonos from accessing the content properly. Even with the firewall disabled completely, there may be some settings that are lingering in the background which are causing conflict. 


phone support is completely free
Hello Mark,

If you are still getting this error after you re-configured and disabled your firewall, I'd recommend that you call into our support line so we can take a deeper look.

This particular error message indicates an issue with the firewall or permission settings which is inhibiting Sonos from accessing the content properly. Even with the firewall disabled completely, there may be some settings that are lingering in the background which are causing conflict. 


Thanks!
Hi,

I'm experiencing the same issue as folks above.  OS is Yosemite (10.10.2), and have updates the songs controller software to version 5.3.  Firewall is disabled.  When I attempt to add the iTunes folder either automatically, or by specifying path i get the error message " <Computer> refused to let Sonos connect to it"

Any help would be appreciated.

Thanks
Userlevel 7
Badge +22
A few things. You could use a desktop computer mac software and try the beta 5.4 (just iOS would still have 5.3). Or call Sonos.
I have the same issue, using a WD MyBookLive. I get "The computer MyBookLive refused to let Sonos connect to it. I have tried using a dedicated user id for the NAS, and also just leaving it blank as it is a public share but nothing works.
I am having the same issue. My config to the Music share on my Synology NAS was previously working. OSX Yosemite can see the share ok via afp but for some reason Sonos can not
For anyone using Synology NAS ensure 'Control Panel -> File Services -> Windows File Service' is enabled so Sonos can connect with CIFS Confirmed this is now working for me
Seems this problem is also affecting my sonus system. It had been working ok for a few months but just a few days ago I could not get my controller to access my music library.

So, I deleted the library in the controller and added it again. The system worked fine for a couple of days.

Once again, today could not access the library so I tried deleting and adding it back again.

This time I get the error "...refused to let Sonus connect."

Help would be appreciated,

Sincerely
I have the same issue, using a WD MyBookLive. I get "The computer MyBookLive refused to let Sonos connect to it. I have tried using a dedicated user id for the NAS, and also just leaving it blank as it is a public share but nothing works.


I also had this issue with my WD MYBOOKWORLD NAS.

I could mount a (Z:)  drive from my PC to the Public share on the NAS using the sonos user/passwd I had set up without issue.

But when trying to add my NAS back into my Music Library Setting under Sonos from my PC I would get the same connection refused error.

I was browsing to my local network selecting the NAS, Public Share and the My Music folder then getting the same connection refused error.

It was fixed for me by replacing the Name of the NAS (MYBOOKWORLD) as it is seen on the PC with its IP address, a 192.168.xxx.xxx number. After this it just updated and got on with it.

Hope that helps.
Hi Guys. For what it's worth. I had exactly the same problem although mine seemed to start when I set up a windows homegroup, which made ALL devices on my entire home network work beautifully and seamlessly with all 3 computers ... EXCEPT SONOS which cacked itself. I was forced to dissolve the homegroup but SONOS didn't uncack itself completely and gave the unable to connect to music folder. So I thought I'd just delete it and re-add it. Deleted it fine, when I tried to re-add I got the same issue all the above posters were having.
Things that didn't work
-firewall configuration
-firewall disablement
-manually adding the filepath

What worked
-typing the IP address instead of the NAS name ie. \\"NAS name"\folder name didn't work, but \\192.168.1.2\folder name worked fine

Cheers

Stew
I fixed "the computer refused to let sonos connect to it" issue by fixing properties on my Ethernet adapter. A bunch of options were deselected.
Newtwork and Sharing > Change Adapter Settings > Right click Ethernet adapter > Properties
Checked all the options EXCEPT Multiplexor and LLDP

I'm a developer and had been playing with Azure in Visual Studio and Hyper-V had been enabled and disabled at some point. I think that may have fouled up my ethernet adapter settings.
Userlevel 2
Badge +1
I figured out the problem for me. You must have SMB enabled on the NAS. My NAS had SMB and AFP both enabled and I was seeing some flaky network problems so I killed SMB and was running only AFP. Access was suddenly dropped.