Can't recover controller connection S2 (iOS / Android / Windows)

  • 22 March 2021
  • 3 replies
  • 22 views

Hi

Over the last couple of days I’ve lost the control connection to all my devices whether accessing via iOS14, Android7 or Windows10.  I’m not aware that anything on my network has changed.  Diag #1441113905 S2 ver 13.  All on same wifi ssid.

I think I’ve tried everything, following the instructions for re-connection in the apps, and sometimes I get some progress, but now have nothing connected.  All devices re-booted, router re-booted, one Sonos factory reset.  I managed to connect a Play1 by connecting wired.  At this stage, I did a diagnostic and could see all the units in the Network page of the web diagnostics.  It then disappeared when I tried adding the other devices back.  I separately got my Play3 connected, but that disappeared when I tried to connect back a Play5 (it got through most of the setup, and failed at the last step after the app switches back to the wifi network in use.

I factory reset a Play1 and this got through most of the steps of adding back, but failed at the last step, rather like the Play5 above.

Any help would be greatly appreciated.

Thanks


3 replies

Userlevel 7
Badge +21

A factory reset is never a good idea for problems like this.

What state are you in now? Sounds like you have at least one device working, and as that was reset you will now need to factory reset each of your other devices and add them, one by one. Obviously your Sonos playlists and music services will all be lost due to the factory reset.

You may have got your system into such a confused state that a phone call to Sonos support may be the only way to get this back into a sane condition.

Thanks.  I expect that I’ll be able to repeat the addition of a different device by connecting wired.  It’s just that no additions seem to stick right now.

Any clues as to what type of network issue could cause a problem like this?  I checked that I don’t have DHCP reservations and the app is whitelisted in my firewall.

… my Play3 plays the radio when switched on but is not visible in the App and doesn’t get found when selecting Add a Device where it sits at “Searching for nearby devices”.

The Play1 I reset appears in the App when connected wired.  As soon as I pull out the cable it appears.  Plug it back in an it reappears.  So I guess there is a conflict / problem that has emerged with wireless setup.  It’s just curious that I succeeded briefly in adding back my Play3 without connecting.

Reply