Question

Can't Link Player To Account

  • 6 January 2018
  • 5 replies
  • 715 views

Badge
I just experienced the issue with Alexa and as a result I created a new Sonos account and tranfered to that - Alexa now works again (I know they've sorted it but I'd already done the switch).

When I log into the Sonos App I now get a message saying , Link Players To Sonos Account. I click Next and enter my new password and it tries to link. The attempt fails each time.

Is this because of a problem at Sonos' end? I've tried to log onto my account on the website but just get an 'Invalid URL' error so I suspect something is happening on the main site.

Anyone got any ideas?

Rich

5 replies

Userlevel 7
Badge +18
Hi, Rich_N. Thanks for your post. I don't necessarily think this is related to an issue on our end- though of course, it could be. So that I can determine whether or not this is the case, can you please submit a diagnostic and respond with the confirmation number? This will identify if there are any local issues. If there are not, it could very well be that we are having a problem, though there haven't been many other reports of this that I am aware of. You could also try some basic measures, like rebooting your router and the speakers to see if that helps at all. Please let us know how you get on.
Badge
I can't link one of my Play:5 either since a few weeks I didn't change anything in the system, it just stoped working. The diagnostic number is 2066335749.
Can't link my two play:1 surround speakers. My diagnostics number is 311178425.
I have the same issue ("When I log into the Sonos App I now get a message saying , Link Players To Sonos Account. I click Next and enter my new password and it tries to link. The attempt fails each time.". My 2 Play 1 speakers linked with no problems. My play 5 wont link. My diagnostics number is 2125925647.
Userlevel 7
Badge +20
I have the same issue ("When I log into the Sonos App I now get a message saying , Link Players To Sonos Account. I click Next and enter my new password and it tries to link. The attempt fails each time.". My 2 Play 1 speakers linked with no problems. My play 5 wont link. My diagnostics number is 2125925647.

Hi there,

Does it fail with an error message? You may need to reset the password on your account. Here's a guide to doing so, or transferring your account if you don't have access to reset the password.

Reply