Answered

Can't control volume, then sound stops altogether using Infinity remote

  • 13 November 2021
  • 7 replies
  • 61 views

Intermitantly can’t control volume and then sound cuts out altogether when using Xfinity remote. I have rebooted the router, unplugged the whole system and replugged, updated the TV, updated my Xfinity password which changed a few weeks ago. I can control the sound with the Sonos app OK, but once even that did not work. I even got a new remote from Comcast and it seemed to pair OK. All other actions using the remote work so I don’t think that it is the remote. I am out of ideas.

icon

Best answer by Ken_Griffiths 13 November 2021, 21:16

View original

7 replies

Which Sonos device are you using and how is it connected to the TV - Arc/Optical?

If it’s a Sonos Arc as I see mentioned in your community profile, then I assume you are using HDMI-CEC to control the audio and not infrared. In which case I would perhaps switch off CEC temporarily on your other connected TV peripherals and also switch off Infrared on your Arc and see if that solves the issue. 

Then go onto bring CEC back online on your other connected devices (one device at a time) to see if any are causing you the problem.. I don’t see the point in switching the infrared back on the Arc if the remote isn’t using that connection, or you mostly use the remote to control the TV audio over CEC.

The only other peripheral I have is Roku. How do I shut off CEC(I don’t know what this is) on the Roku. Also, how do I shut off infared on the ARC? Do I use the Sonos app to do this?

 

HDMI-CEC is a feature found on many (not all) HDMI-compatible devices which allows the user to control multiple HDMI devices from one remote, such as a TV remote.

"CEC" simply stands for Consumer Electronics Control. It may have a different name on some products, for example LG refer to is as ‘Simplink’, Sony call it ‘Bravia’ but some just call it CEC or HDMI-CEC.

If you can Google any devices you have and ask how to switch off CEC control - you may find the answer, but note not all devices have it and some may not let you switch it off - in which case you might opt to introduce a CEC-Less adapter into its connection to the TV - see this link for an example:

https://www.amazon.com/Lindy-HDMI-Adapter-Female-41232/dp/B00DL48KVI

If not using IR, to switch off Infrared on the Arc goto “Settings/System/[Arc Room Name] The option to switch it off is there in its room settings.

Thank you for your responses. This did seem to start not long after I got a newer Roku. I checked the IR settings and they all appear to be off anyway.

Thank you for your responses. This did seem to start not long after I got a newer Roku. I checked the IR settings and they all appear to be off anyway.

Maybe try the TV without the Roku plugged in for a short while and just see if the problem goes away. You may even find that when you power the Roku back on later (and it sets up the HDMI handshake again with the TV) that it might settle and work correctly, but see how it goes without it, just as a test.

I’m going to swith off the CEC using the Roku remote. I found instructions explaining how, also shutting off the ARC using the Roku remote. I’ll try this first. I ordered the adapter from Amazon just in case. If all else fails I’ll unplug the Roku. 

I unplugged the Roku and all the problems stopped. The adapter came and I hooked it up to the Roku. It is functioning OK now. Thank you for all your help.

Reply