Can't Control Sonos From Spotify (working previously)

  • 2 January 2017
  • 36 replies
  • 4339 views

I had Spotify & Sonos working together where I could use the Spotify App to play on my Sonos 1 directly. But now that has gone away, and I can't get it working again.

● I don’t see my Sonos speaker listed in the Spotify app anymore under DEVICES AVAILABLE.
● The speaker is turned on.
● I went to the Sonos app on my PC: Selected Manage > Settings > Advanced > Music Sources > ... but "Control Sonos from Spotify" is not listed as an option anymore
● Everything is fine with my Spotify account within Sonos (I can play from Spotify to my Sonos speaker within the Sonos app)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

I have the same issue, but there are a few things I tried. I have a Play:1 and it's no longer listed in Spotify's available devices WHILE I have the speaker configured wirelessly (which is the most common thing). But, when I connect the speaker via LAN cable direct to my modem, it appears in Spotify's available devices, the second I disconnect the cable, it disappers from the list. However, the music service still works through Sonos app, but its a pain in the eyes to use it that way. By the way, I'm using a Samsung Galaxy S8 to run Spotify, as well as Sonos app. [...]
Restart your router followed by the Play:1. If that does not help change the wireless channel of the router to 1,6,11. Also restart your mobile device.
Thanks man, that actually worked and now it's up and running again. I am most grateful!
I have the same issue, but there are a few things I tried. I have a Play:1 and it's no longer listed in Spotify's available devices WHILE I have the speaker configured wirelessly (which is the most common thing). But, when I connect the speaker via LAN cable direct to my modem, it appears in Spotify's available devices, the second I disconnect the cable, it disappers from the list. However, the music service still works through Sonos app, but its a pain in the eyes to use it that way. By the way, I'm using a Samsung Galaxy S8 to run Spotify, as well as Sonos app. [...]
Restart your router followed by the Play:1. If that does not help change the wireless channel of the router to 1,6,11. Also restart your mobile device.
I have the same issue, but there are a few things I tried. I have a Play:1 and it's no longer listed in Spotify's available devices WHILE I have the speaker configured wirelessly (which is the most common thing). But, when I connect the speaker via LAN cable direct to my modem, it appears in Spotify's available devices, the second I disconnect the cable, it disappers from the list. However, the music service still works through Sonos app, but its a pain in the eyes to use it that way. By the way, I'm using a Samsung Galaxy S8 to run Spotify, as well as Sonos app.

Cheers, and I apologize for any mistake in my english writing.
Gerardo Valderrama

This is my same reply at this forum: "Spotify no longer listing Sonos speakers?"
I too cannot use the Spotify app on my PC desktop to control Sonos. Only devices listed are the local computer and an Echo Dot on my network. It used to work fine, but doesn't now. The desktop Sonos app works OK, and my phone (Android) Spotify app can play on any Sonos speaker, but interestingly does not list the Echo Dot.

(My desktop and Sonos Connect are wired into my network. My phone connects wirelessly, like the Echo Dot.)

Here are my Sonos diagnostics - 1987120061
Same problem. Downgrading the Spotify app helped. Still, don't want to accept that I should use outdated SW that misses new features just because "old" functions are not supported ?!?! I guess the problem is with Spotify, however this has impact on Sonos. Please take this seriously and fix (or get Spotify to fix it) asap
Simply deleting the Spotity app, restarting your mobile device, and reinstalling Spotify from Google Play Store resp. iTunes App Store didn't help?
Same problem. Downgrading the Spotify app helped. Still, don't want to accept that I should use outdated SW that misses new features just because "old" functions are not supported ?!?! I guess the problem is with Spotify, however this has impact on Sonos. Please take this seriously and fix (or get Spotify to fix it) asap
Me too - it worked a couple of weeks ago, but not now. If I go into Spotify on my PC, and click on "Devices Available", I can still see my Sonos devices. But if I click on one of them, nothing happens. The good news is that if I go into Sonos, I can still choose Spotify as a music source.

Diagnostics number 6960988


Mee too: diagnostics number is: 8497861
Same here. Spotify app will show the Sonos players as "Devices available", but nothing happens when I select one of them. Was really happy when the Spotify Connect feature was added, so it is very annoying that it no longer works.
I have the same issue. I can se my room in Spotify Connect but when I click on it nothing happens. It's been working fine for about a year but not any longer. My diagnostic no is 8182394.
I am also having trouble using the Spotify App as my controller after a recent Sonos update. I had friends that could control it on their phones while at my house on their accounts. Of course it works perfectly on the Sonos app which has a horrible interface compared to the Spotify App. Please help!!!! So annoying. Tried re-installing everything multiple times.
Hello,

I've been a Sonos user since 2014 and currently have a Playbar with Sub, 2x Play:5. I have added my spotify account to Sonos and it works seamlessly when I play in the house. I cannot get the three speakers to show up on the Spotify app. I have removed and replaced Spotify on the Sonos app, restarted my router, the bridge, and each individual speaker and have had no change in control. I was able to control my Sonos speakers with the Spotify app previously before moving. Since then it has not functioned correctly. Please help!

-Nick
Userlevel 7
Badge +17
ACC - works perfectly for me also. I suggest you contact Sonos support
Userlevel 7
Badge +20
Yep Spotify works faultlessly from within Sonos or Using the Spotify app to play on Sonos
I do not remember adding Spotify to the Sonos app in the first place when all was working properly. However, I did add Spotify to the Sonos app and it briefly fixed the issue! However, not more than 8 hours later, the problem remains.

This is when I am on my home WiFi network.

Bockersjv, you are able to control your Sonos directly from your Spotify app, correct? For example, it will allow you to continually change songs, pause, play, etc. directly from Spotify app, correct?

Shouldn't this be a basic feature? I really hope it's me that's the issue and not the Sonos.
Userlevel 7
Badge +20
Have you tried removing and re-adding spotify to the Sonos app. Also are you on the WIFI network on your device or mobile network. Spotify control of Sonos only works for me when I am on my home wi-fi.
Issue: Spotify loses control of Sonos Playbar.

Details: Upon original set-up, Spotify worked beautifully and was able to control (play, skip songs, pause, etc.) the Playbar. As of two days ago (roughly 3 weeks from original set-up), I can start a song/playlist from Spotify but can not control the music, i.e. cannot skip tracks, pause, or switch song in Spotify. The only way to stop music or change track is to then open Sonos App and pause music, skip tracks, etc.

Help: would be fantastic! Being able to control the Playbar from Spotify is perhaps the most important feature to me, if that capability is unavailable I need to consider other options.

Thanks!
Userlevel 1
Badge +1
Hi, I have the same problem, nothing worked.
Diagnostic confirmation number: 7690818


Thanks for the diagnostic. Looks like Spotify has not been added to your Sonos system. As a test try adding Spotify to Sonos following these steps and let us know if the Spotify service encounters a similar issue using the Sonos app: https://sonos.custhelp.com/app/answers/detail/a_id/2768
Hi, I have the same problem, nothing worked.
Diagnostic confirmation number: 7690818
Userlevel 6
Badge +3
Hello,

Im a recent owner of a PLAY:1. I have been trying to connect my sonos to spotify but I have been failing miserably.
Sonos shows up at devices availabe at spotify but cant create a connection.
Can anyone please suggest me what should I do?


Hi azhad, sorry for the delay in our reply. We'd like a little more information about your Sonos system. Would you mind submitting a diagnostic and replying with the confirmation number?
Here's an article about it: How to submit a diagnostic
Hello,

Im a recent owner of a PLAY:1. I have been trying to connect my sonos to spotify but I have been failing miserably.
Sonos shows up at devices availabe at spotify but cant create a connection.
Can anyone please suggest me what should I do?
Userlevel 4
Badge +3
Hi JWettis, welcome to the community. Your diagnostic actually shows an open connection to the Spotify cloud and not really any problems with the system in general. I suspect this was just a temporary issue at either our cloud or Spotify's. We were a bit slow to pick up this post so it may all be resolved by now. Please reply here if if the issue is still ongoing for you.
I have the same problem. Worked a couple of months ago. It suddenly sopped to work.
Troubleshooting:
- Tried to connect from Spotify app on different devices (PC, iPhone and iPad)
- Rebooted my modem
- Rebooted my Sonos device
- Spotify connect works between my devices but not to Sonos



Diagnistic: 7464780
Userlevel 5
Badge +3
I have the same problem. This used to work. Had a HW failure on my phone, so had to replace it. May or may not be related, but it worked before that, but doesn't now. I've tried reinstalling and reauthorizing my Spotify app. No joy. My Sonos devices all show up as available in the Spotify app, but when I try to select one, it says "connecting..." for about 10 seconds, but nothing happens. Submitted diagnostics (7279230)

Hey dandehaan - I took a look at the diagnostic and didn't see any errors reported from Spotify. At the time you experienced this issue were there any tracks playing on Spotify? If the Spotify queue is empty the behavior from the Spotify app displaying Connecting... and then timing out is expected. Please reply back here with a new diagnostic number right after having issues connecting via the Spotify app.
Userlevel 6
Badge +3
Hi All,

While you are waiting on a Sonos rep to pull your report and respond this will not hurt anything.

Connection problems which appear suddenly are often caused by network problems, not Sonos problems. The typical cause is duplicate IP addresses. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. Rebooting the router may correct this temporarily, but it actually exacerbates the problem because as soon as another IP lease expires, it starts handing out duplicates again. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem
Router
Switches or hubs
Wired Sonos units
Wireless Sonos units
Computers/printers
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.

Also,

Make sure if you have a hard wired Sonos product to your router that Sonos and your router or on different channels

SonosNet


And that product is at least a few feet away from the router. Keep any other wireless devices as far away as you can.
I have the same problem. This used to work. Had a HW failure on my phone, so had to replace it. May or may not be related, but it worked before that, but doesn't now. I've tried reinstalling and reauthorizing my Spotify app. No joy. My Sonos devices all show up as available in the Spotify app, but when I try to select one, it says "connecting..." for about 10 seconds, but nothing happens. Submitted diagnostics (7279230)