Can't connect to my Sonos System

  • 15 August 2017
  • 7 replies
  • 630 views

I have the Sonos app (latest version) on my Mac and after playing a few tracks the tune fades and won't play the next track. It then works for a while and then again highlights the error message 1002. I've checked the firewall and it is allowing access to Sonos,I've reloaded the iTunes directory to Sonos preferences, and moved sleep preferences to never. Getting bored with this and am really disappointed after spending nearly £600 on 2x Play1's and 1 xPlay 3.(Sent diagnostic 7720304)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

James GI,

While you wait for a Sonos employee to swing by and look at that diagnostic, can I suggest a potential (non-harmful, too!) fix?

Unplug the Sonos speakers from the power. Reboot/Power cycle your router, whichever kind it is, and wait a minute or two for it to reboot. Then plug back in one of your speakers, and give it a minute to boot up (and request a new IP). Then move on to the next Sonos speaker and plug it back in, etc, etc. You need to do them one at a time.

What this is aimed at doing is resetting the IP addresses assigned to each device in your router's table. Wouldn't be a horrible idea to look in to assigning them static IP addresses for the future, but that's not a requirement.

The other possibility is less likely, but you may have a speaker too close to the router. Usually at least a meter is advised (3 feet) But if that were the case, you'd not get a few tracks in all the time, it would be much quicker. But it's also a low cost effort, so worth checking. Or some other form of wifi interference, like a wireless phone, printer, baby monitor.

Anyway, that might get you going more quickly than waiting....or at least keep you busy while you are waiting :)

Good luck!
thanks Bruce, I will give it a go. My Play 3 is right next to the router and the bridge, which might also be the problem?

James
Well, it could be an issue with that particular speaker, but I'm not sure it would affect the others. Is that speaker wired with an ethernet cable to your router?
No the bridge is cabled via Ethernet to router and the three speakers via Wifi to bridge.
It's interesting I have no problem playing music that is on my phone. Just through iTunes library on my Mac.
Thanks again

James
Ah, I hadn't twigged on the mention of the bridge before. Make sure the bridge is as far from your router as possible, as well. If you're still using the cable provided by Sonos, as far as it will reach 🙂 And change the SonosNet channel to something as far away from what your router is using. SonosNet is restricted to 1, 6 or 11, so as far as you can get from your router's channel is probably your best bet. If your router is on "automatic channel", turn that off, and restrict it to just one channel.

At the end of the day, it may behoove you to try some different ethernet cables. While I've never had a failure, I've seen other reports from folks who have, and it is a low cost test, too.

But it's interesting that you're only having an issue when playing from the Mac's HD. That would indicate an issue (in my mind, at least) of problems with Sonos maintaining a constant connection to your Mac. Is your Mac wired, or is it on the wifi?

According to the FAQ, 1002 is a "hey, it's taking too long to respond to my request" type of error message. You've said you've set your computer not to sleep, did you do the same thing to the Hard Drive? i.e. make sure that the "Put hard drives to sleep when possible" is turned off. Also, I'd make sure that Wake for Wi-Fi network access it turned on. And I'm assuming your Mac is permanently plugged in, and not a battery based unit.

Just wanted to also ask, what kind of Mac is this? What OS is it running?
Thanks Bruce

I will try your suggestions this evening and let you know how I get on.

Have a good day.

James
Hope it works (or worked) 🙂